Autor Tópico: 3DSP uWB não está funcionando  (Lida 6726 vezes)

Offline cbraga

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
3DSP uWB não está funcionando
« Online: 27 de MAR?O de 2011, 11:37 »
Bom dia!

Após realizar algumas atualizações pedido pelo Ubuntu 10.10, gerou uma nova versão de acesso a 2.6.35-28 generic, mas não consigo mais conectar pelo 3DSP uWB, porque não está funcionando.

Como faço para resolver esse problema?  ???

Como faço para evitar que acontece outra vez?  ???

Agradeço deste já!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3DSP uWB não está funcionando
« Resposta #1 Online: 27 de MAR?O de 2011, 13:56 »
Terá que reinstalar os drivers do 3DSP. Eles são amarrados à versão do Kernel.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline cbraga

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: 3DSP uWB não está funcionando
« Resposta #2 Online: 27 de MAR?O de 2011, 17:06 »
Terá que reinstalar os drivers do 3DSP. Eles são amarrados à versão do Kernel.

Como faço isso?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3DSP uWB não está funcionando
« Resposta #3 Online: 28 de MAR?O de 2011, 01:18 »
Como você fez da primeira vez?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline cbraga

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: 3DSP uWB não está funcionando
« Resposta #4 Online: 28 de MAR?O de 2011, 10:26 »
Como você fez da primeira vez?

Seguindo as orientação abaixo:

1 - Baixar todas as dependências para instalação do dispositivo:

Use os comandos abaixo no terminal (menu:Aplicativos / acessórios / Terminal)

$ sudo apt-get install build-essential linux-headers-`uname -r`

2 - Baixe o código fonte do dispositivo do fabricante, no site http://github.com/franciscosouza/3dsp. O código foi alterado por Francisco Souza, pois o drive do site do fabricante ao ser executado dá um erro de codificação no código fonte de instalação do dispositivo. Execute no terminal os comandos a seguir:

$ git clone http://github.com/franciscosouza/3dsp.git
$ cd 3dsp
$ sudo bash Install_3DSPUSB.sh

Para conectar proceder os seguintes passos através dos menus:

1) Aplicativos / Acessórios / 3dsp uWB
2) Aplicativos / Acessórios / 3dsp wifi radar


Sendo que já tentei e não está dando certo, porque informa que não consegue localizar linux-headers-`uname -r`. Por isso não estou conseguindo resolver esse problema.  :-\

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3DSP uWB não está funcionando
« Resposta #5 Online: 28 de MAR?O de 2011, 10:41 »
Vc consegue bootar sua máquina com o kernel antigo?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline cbraga

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: 3DSP uWB não está funcionando
« Resposta #6 Online: 28 de MAR?O de 2011, 12:59 »
Vc consegue bootar sua máquina com o kernel antigo?

Sim, estou acessando pela versão 2.6.35-27 generic

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3DSP uWB não está funcionando
« Resposta #7 Online: 28 de MAR?O de 2011, 14:10 »
O driver está funcionando no kernel antigo?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline cbraga

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: 3DSP uWB não está funcionando
« Resposta #8 Online: 31 de MAR?O de 2011, 21:06 »
O driver está funcionando no kernel antigo?

Oi, na versão antiga está funcionando direitinho. Como sera faço para resolver isso?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3DSP uWB não está funcionando
« Resposta #9 Online: 01 de Abril de 2011, 00:23 »
Use o kernel antigo pra baixar o pacote linux-headers da versão do kernel novo. Assim vc vai conseguir seguir a instalação do driver 3DSP no kernel novo, pulando logo pro passo 2 da instrução.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline cbraga

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: 3DSP uWB não está funcionando
« Resposta #10 Online: 03 de Abril de 2011, 22:52 »
Use o kernel antigo pra baixar o pacote linux-headers da versão do kernel novo. Assim vc vai conseguir seguir a instalação do driver 3DSP no kernel novo, pulando logo pro passo 2 da instrução.

Tentei fazer a instalação, coloquei o comendo "apt-get install linux-headers-`uname -r`" no terminar, mas a aparecer a seguinte resposta:

uname-r comendo não encontrado
E: não foi possível abrir o arquivo de trava /var/lib/dpkg/lock - open (13: permissão negada)
E: não foi possível criar acesso exclusivo ao diretório de administração (/var/lib/dpkg/lock), é root?

Ai agora? Não sei mais o que fazer, não tenho muita habilidade com isso.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3DSP uWB não está funcionando
« Resposta #11 Online: 04 de Abril de 2011, 01:02 »
Citar
uname-r comendo não encontrado
o espaço entre "uname" e "-r" é obrigatório.

Citar
E: não foi possível abrir o arquivo de trava /var/lib/dpkg/lock - open (13: permissão negada)
E: não foi possível criar acesso exclusivo ao diretório de administração (/var/lib/dpkg/lock), é root?
Você esqueceu do "sudo" no início da linha.

Faça o seguinte, em vez de executar esse comando, execute apenas o "uname -r". Anote o resultado (p.ex. 2.6.35-28).

Daí, vá na página http://packages.ubuntu.com/ e procure pelo pacote "linux-headers-<numero da versão>-generic".

P.ex. http://packages.ubuntu.com/maverick/linux-headers-2.6.35-28-generic

Baixe o arquivo e salve em sua pasta home. Instale-o com o comando "sudo dpkg -i <arquivo>", assim:

sudo dpkg -i linux-headers-2.6.35-28-generic.deb

Daí vc segue o tutorial, pulando esse passo que está dando problema.
« Última modificação: 04 de Abril de 2011, 01:08 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline cbraga

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: 3DSP uWB não está funcionando
« Resposta #12 Online: 04 de Abril de 2011, 10:42 »
Depois de muito brigar e bater cabeça consegui ativá-lo. Obrigada!

Só mais uma pergunta. Tinha configurado na versão 2.6.35-27 algumas senhas de acesso a internet que não estão aparecendo, há alguma forma de puxá-las?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3DSP uWB não está funcionando
« Resposta #13 Online: 04 de Abril de 2011, 10:46 »
Não há motivo pra isso ter acontecido. A mudança do kernel não implica em mudanças no desktop.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline cbraga

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: 3DSP uWB não está funcionando
« Resposta #14 Online: 04 de Abril de 2011, 13:33 »
Ok e obrigada! Tenho que fazer alguma coisa para fechar o tópico, para dizer que foi resolvido?