Autor Tópico: Rede sem fio em casa  (Lida 8247 vezes)

Offline Capslock

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Rede sem fio em casa
« Online: 07 de Maio de 2011, 14:05 »
Olá,
Sou iniciante e não entendo quase nada de computação. Nunca tentei conectar o meu note numa rede wireless depois que intalei o Ubuntu 10.04. Desta vez ele não detectou a rede lá da casa do meu pai. Depois de ter dado  uma pesquisada aqui no forum, resolvi postar aqui o resultade de alguns comandos que coloquei no Terminal. Alguém pode me ajudar a decifrar o resultado? Ei-lo então:
inspiron@Inspiron:~$ sudo lshw -C network
[sudo] password for inspiron:
  *-network:0 DISABLED   
       description: Wireless interface
       product: PRO/Wireless LAN 2100 3B Mini PCI Adapter
       vendor: Intel Corporation
       physical id: 3
       bus info: pci@0000:01:03.0
       logical name: eth1
       version: 04
       serial: 00:0c:f1:5b:5d:40
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ipw2100 driverversion=git-1.2.2 firmware=712.0.3:3:00000001 latency=32 link=no maxlatency=34 mingnt=2 multicast=yes wireless=unassociated
       resources: irq:5 memory:fcffe000-fcffefff
  *-network:1
       description: Ethernet interface
       product: 82801DB PRO/100 VE (MOB) Ethernet Controller
       vendor: Intel Corporation
       physical id: 8
       bus info: pci@0000:01:08.0
       logical name: eth0
       version: 81
       serial: 00:11:43:41:d8:b8
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=half firmware=N/A ip=192.168.0.2 latency=32 link=no maxlatency=56 mingnt=8 multicast=yes port=MII speed=10MB/s
       resources: irq:11 memory:fcffd000-fcffdfff ioport:ecc0(size=64)
inspiron@Inspiron:~$ iwconfig wlan0
wlan0     No such device

inspiron@Inspiron:~$ ifconfig -a
eth0      Link encap:Ethernet  Endereço de HW 00:11:43:41:d8:b8 
          inet end.: 192.168.0.2  Bcast:192.168.0.255  Masc:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

eth1      Link encap:Ethernet  Endereço de HW 00:0c:f1:5b:5d:40 
          BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          IRQ:5 Endereço de E/S:0x2000 Memória:fcffe000-fcffefff

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:28 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:28 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:1904 (1.9 KB) TX bytes:1904 (1.9 KB)

inspiron@Inspiron:~$ nm-tool

NetworkManager Tool

State: connected

- Device: eth1 -----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ipw2100
  State:             unavailable
  Default:           no
  HW Address:        00:0C:F1:5B:5D:40

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            e100
  State:             unmanaged
  Default:           no
  HW Address:        00:11:43:41:D8:B8

  Capabilities:
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Properties
    Carrier:         off


inspiron@Inspiron:~$

Offline Capslock

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: Rede sem fio em casa
« Resposta #1 Online: 07 de Maio de 2011, 14:17 »
Pelo o que eu entendi, o meu note possui uma placa de rede sem fio mas a mesma não está ativada. Como faço para ativá-la?  :-\

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Rede sem fio em casa
« Resposta #2 Online: 08 de Maio de 2011, 01:52 »
Confirme que o botão Liga/desliga do seu notebook esteja na posição "Ligado". Pela saída do comando acima, não está.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Capslock

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: Rede sem fio em casa
« Resposta #3 Online: 08 de Maio de 2011, 11:21 »
Olá Zekkerj,
Que bom ter te encontrado aqui. Pude ver que vc entende do assunto.
A questão é o seguinte, o meu note é um Dell antigo, Inspiron, e não encontrei nenhuma chave externa de liga/desliga. Existe alguma outra forma de ligá-lo? Desculpe a ignorância.
 

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Rede sem fio em casa
« Resposta #4 Online: 08 de Maio de 2011, 11:39 »
Pode variar de equipamento pra equipamento. No Dell Vostro, é um botão na lateral esquerda; no Latitude, é na parte da frente. Não sei no Inspirion; pode ser também uma sequencia no teclado, como Fn-F2 ou Fn-F10. O símbolo da antena em azul sobre uma tecla é o código pra isso.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Capslock

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: Rede sem fio em casa
« Resposta #5 Online: 08 de Maio de 2011, 17:02 »
O meu é o Inspiron 510m e pelo que vi possui a sequencia no teclado (Fn-F2). Porém ao teclar esta sequencia não acontece nada de aparente. O q vc sugere?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Rede sem fio em casa
« Resposta #6 Online: 09 de Maio de 2011, 04:30 »
Podemos tentar desbloquear por software, com o comando abaixo.

sudo rfkill unblock wifi
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Capslock

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: Rede sem fio em casa
« Resposta #7 Online: 09 de Maio de 2011, 10:19 »
Fiz isso e também não aconteceu nada. Continua sem detectar nada.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Rede sem fio em casa
« Resposta #8 Online: 09 de Maio de 2011, 11:42 »
sudo modprobe -r dell-wmi

Depois repita os testes iniciais.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Capslock

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: Rede sem fio em casa
« Resposta #9 Online: 09 de Maio de 2011, 16:48 »
Da mesma forma, não aconteceu nada de novo. Mas estou postando aqui os resultados dos comandos iniciais:

inspiron@Inspiron:~$ sudo lshw -C network
[sudo] password for inspiron:
  *-network:0 DISABLED   
       description: Wireless interface
       product: PRO/Wireless LAN 2100 3B Mini PCI Adapter
       vendor: Intel Corporation
       physical id: 3
       bus info: pci@0000:01:03.0
       logical name: eth1
       version: 04
       serial: 00:0c:f1:5b:5d:40
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ipw2100 driverversion=git-1.2.2 firmware=712.0.3:3:00000001 latency=32 link=no maxlatency=34 mingnt=2 multicast=yes wireless=unassociated
       resources: irq:5 memory:fcffe000-fcffefff
  *-network:1
       description: Ethernet interface
       product: 82801DB PRO/100 VE (MOB) Ethernet Controller
       vendor: Intel Corporation
       physical id: 8
       bus info: pci@0000:01:08.0
       logical name: eth0
       version: 81
       serial: 00:11:43:41:d8:b8
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=half firmware=N/A ip=192.168.0.2 latency=32 link=no maxlatency=56 mingnt=8 multicast=yes port=MII speed=10MB/s
       resources: irq:11 memory:fcffd000-fcffdfff ioport:ecc0(size=64)
inspiron@Inspiron:~$ iwcongig wlan0
Comando 'iwcongig' não encontrado, você quis dizer:
 Comando 'iwconfig' do pacote 'wireless-tools' (main)
iwcongig: comando não encontrado
inspiron@Inspiron:~$ iconfig -a
Comando 'iconfig' não encontrado, você quis dizer:
 Comando 'fconfig' do pacote 'redboot-tools' (main)
 Comando 'iwconfig' do pacote 'wireless-tools' (main)
 Comando 'vconfig' do pacote 'vlan' (main)
 Comando 'ifconfig' do pacote 'net-tools' (main)
 Comando 'mconfig' do pacote 'mono-2.0-devel' (main)
iconfig: comando não encontrado
inspiron@Inspiron:~$ nmtool
Comando 'nmtool' não encontrado, você quis dizer:
 Comando 'nm-tool' do pacote 'network-manager' (main)
nmtool: comando não encontrado
inspiron@Inspiron:~$

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Rede sem fio em casa
« Resposta #10 Online: 09 de Maio de 2011, 17:02 »
Capslock, eu já passei por uma situação parecida com essa em minha máquina (Dell Latitude com placa wireless Intel 5500). Lembro que tive que bloquear um módulo que jurava ser esse que te passei (dell-wmi), mas não encontrei nem na máquina nem aqui no fórum o registro disso (já comentei antes).

O que encontrei bloqueado aqui foi o módulo "dell-laptop", que é o próximo teste que eu vou te sugerir.

Crie um arquivo chamado "/etc/mopdprobe.d/blacklist-dell.conf", com o seguinte conteúdo:

Código: [Selecionar]
blacklist dell-laptop
Depois reinicie sua máquina e teste novamente a rede.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Capslock

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: Rede sem fio em casa
« Resposta #11 Online: 09 de Maio de 2011, 17:18 »
Desculpe, sou iniciante,
Como é que se cria um arquivo?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Rede sem fio em casa
« Resposta #12 Online: 09 de Maio de 2011, 17:29 »
Nesse caso, com o comando "gksudo gedit /etc/modprobe.d/blacklist-dell.conf".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Capslock

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: Rede sem fio em casa
« Resposta #13 Online: 09 de Maio de 2011, 20:21 »
Não sei se digitei o comando errado, mas apareceu uma janela com o seguinte título: *blacklist-dell.config(/etc/mopdprobe.d) - gedit.
Então digitei dentro dela o conteúdo que me foi passado: blacklist dell-laptop.
Aí apareceu o seguinte: "Não foi possível localizar o arquivo /etc/mopdprobe.d/blacklist.config".
Tentei também salvar sem digitar nada dentro, mas deu o mesmo problema.
Do que se trata? Errei em alguma coisa?
« Última modificação: 09 de Maio de 2011, 20:23 por Capslock »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Rede sem fio em casa
« Resposta #14 Online: 10 de Maio de 2011, 12:11 »
Vc errou o caminho do arquivo. Tente novamente, observe o caminho com cuidado. Copy/Paste da minha mensagem anterior ajuda.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D