Autor Tópico: Computador não está ativando driver wireless !  (Lida 5944 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Computador não está ativando driver wireless !
« Resposta #15 Online: 19 de Julho de 2011, 23:47 »
Certo. O módulo carregou, assim como o módulo "lib80211", necessário pro funcionamento da rede. Mas estranhamente, o módulo "cfg80211" não carregou, ele também seria necessário, até onde eu sei. Talvez não funcione com o módulo wl.

Algum sinal da interface ter funcionado, enquanto isso? Por exemplo, o comando "iwconfig wl0" agora dá algum retorno?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline phprogram

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Computador não está ativando driver wireless !
« Resposta #16 Online: 19 de Julho de 2011, 23:52 »
O comando continua sem nenhum resultado.

Offline phprogram

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Computador não está ativando driver wireless !
« Resposta #17 Online: 20 de Julho de 2011, 23:22 »
O que se resolve pelos fatos anteriores ?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Computador não está ativando driver wireless !
« Resposta #18 Online: 21 de Julho de 2011, 00:10 »
Eu vou pesquisar um pouco sobre sua placa e ver se há algum relato parecido.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Computador não está ativando driver wireless !
« Resposta #19 Online: 21 de Julho de 2011, 11:55 »
Pelo que vi até agora, sua interface deveria ter subido exatamente com os comandos que vimos antes. Mas a falta do módulo "cfg80211" pode ser significativa. Vamos tentar novamente o driver padrão, ao invés do proprietário:

sudo modprobe -r wl
sudo modprobe -r lib80211
sudo modprobe -v cfg80211
sudo modprobe -v mac80211
sudo modprobe -v b43
dmesg | grep b43
lsmod | grep 80211



EDIT: Se você leu minha resposta antes da correção, os comandos "modprobe" devem ser executados numa sessão de super-usuário, ou com o "sudo".
« Última modificação: 21 de Julho de 2011, 12:07 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline phprogram

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Computador não está ativando driver wireless !
« Resposta #20 Online: 21 de Julho de 2011, 13:49 »
Execultei os comandos. Siga os resultados:

sudo modprobe -r wl
nada ocorreu

sudo modprobe -r lib80211
nada ocorreu

sudo modprobe -v cfg80211
insmod /lib/modules/2.6.38-10-generic/kernel/net/wireless/cfg80211.ko

sudo modprobe -v mac80211

insmod /lib/modules/2.6.38-10-generic/kernel/net/mac80211/mac80211.ko

sudo modprobe -v b43
insmod /lib/modules/2.6.38-10-generic/kernel/drivers/ssb/ssb.ko
insmod /lib/modules/2.6.38-10-generic/kernel/drivers/net/wireless/b43/b43.ko

dmesg | grep b43
[  289.283974] b43-pci-bridge 0000:0b:00.0: setting latency timer to 64
[  289.423126]b43-phy0: Broadcom 4311 WLAN found (core revision 10)
[  289.568763] Registered led device: b43-phy0::tx
[  289.568826] Registered led device: b43-phy0::rx
[  289.568895] Registered led device: b43-phy0::radio

lsmod | grep 80211
mac80211            257001  1 b43
cfg80211          156212  2 b43,mac80211


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Computador não está ativando driver wireless !
« Resposta #21 Online: 21 de Julho de 2011, 14:36 »
Bom, muito bom. Acho que estamos no caminho.

sudo lshw -C network
iwconfig wlan0
nm-tool
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline phprogram

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Computador não está ativando driver wireless !
« Resposta #22 Online: 21 de Julho de 2011, 16:14 »
sudo lshw -C network

  *-network UNCLAIMED     
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0b:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:fe8fc000-fe8fffff
  *-network
       description: Ethernet interface
       product: NetXtreme BCM5755M Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 02
       serial: 00:1c:23:98:de:f9
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.116 duplex=full firmware=5755m-v3.29 ip=192.168.0.197 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:42 memory:fe7f0000-fe7fffff

iwconfig wlan0
wlan0     No such device

nm-tool

NetworkManager Tool

State: connected

- Device: eth0  [Auto eth0] ----------------------------------------------------
  Type:              Wired
  Driver:            tg3
  State:             connected
  Default:           yes
  HW Address:        00:1C:23:98:DE:F9

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.0.197
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             189.6.0.137
    DNS:             189.6.0.132
    DNS:             192.168.0.1


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Computador não está ativando driver wireless !
« Resposta #23 Online: 21 de Julho de 2011, 17:14 »
Você reiniciou a máquina nesse meio tempo?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline phprogram

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Computador não está ativando driver wireless !
« Resposta #24 Online: 21 de Julho de 2011, 17:29 »
Sim

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Computador não está ativando driver wireless !
« Resposta #25 Online: 21 de Julho de 2011, 18:54 »
Ah, OK. Repita os comandos "modprobe", depois os "lshw", "iwconfig", etc, mas sem reiniciar no meio tempo, senão os módulos são descarregados.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Miro

  • Usuário Ubuntu
  • *
  • Mensagens: 61
    • Ver perfil
Re: Computador não está ativando driver wireless !
« Resposta #26 Online: 22 de Julho de 2011, 09:15 »
Estou com o mesmo, problema, estou acompanhando o tópico, ja faz varios meses que após o up para o 11, fiquei sem wirelees também...

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Computador não está ativando driver wireless !
« Resposta #27 Online: 22 de Julho de 2011, 11:20 »
Estou com o mesmo, problema, estou acompanhando o tópico, ja faz varios meses que após o up para o 11, fiquei sem wirelees também...
Você já estava tratando do seu problema em outro tópico. Ainda estou aguardando seus dados lá.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re: Computador não está ativando driver wireless !
« Resposta #28 Online: 22 de Julho de 2011, 12:07 »
Ola agregando aqui, Miro http://ubuntuforum-br.org/index.php/topic,81937.msg472131.html#msg472131 alimente seu topico com as informaçoes solicitadas para termos base e recomendar alguma solução.
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997