Autor Tópico: Problema com o Gestor de Actualizações  (Lida 5065 vezes)

Offline AndreLMS

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Problema com o Gestor de Actualizações
« Online: 24 de Maio de 2011, 08:13 »
Boas pessoal,
resolvi à pouco tempo instalar e experiementar o Ubuntu 11.04.

Já conhecia e tinha gostado do 10.

Instalou sem (grandes) problemas, e fui utilizando.

Ontem, quando tentei verificar se existiam ou não actualizações, deparo-me com este erro:
http://yfrog.com/hqcapturaecramp


Como posso resolver isto?

Sempre que tento actualizar, aparece este erro.


Cumps,
AndreLMS

Paulo Correa

  • Visitante
Re: Problema com o Gestor de Actualizações
« Resposta #1 Online: 24 de Maio de 2011, 09:00 »
Boas pessoal,
resolvi à pouco tempo instalar e experiementar o Ubuntu 11.04.

Já conhecia e tinha gostado do 10.

Instalou sem (grandes) problemas, e fui utilizando.

Ontem, quando tentei verificar se existiam ou não actualizações, deparo-me com este erro:
http://yfrog.com/hqcapturaecramp


Como posso resolver isto?

Sempre que tento actualizar, aparece este erro.


Cumps,
AndreLMS
Primeiro tente
Código: [Selecionar]
sudo apt-get updatedepois
Código: [Selecionar]
sudo apt-get upgradee tente verificar novamente.

Offline AndreLMS

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Problema com o Gestor de Actualizações
« Resposta #2 Online: 24 de Maio de 2011, 12:43 »
Fiz como disse e o resultado foi este:

andrelms@andrelms-TOSHIBA-NB500:~$ sudo apt-get update
(...)
Obtidos 107 kB em 2s (36,5 kB/s)
A ler as listas de pacotes... Erro !
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/pt.archive.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
E: As listas de pacotes ou o ficheiro de status não pôde ser analisado ou aberto.
andrelms@andrelms-TOSHIBA-NB500:~$ sudo apt-get upgrade
A ler as listas de pacotes... Erro !
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/pt.archive.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
E: As listas de pacotes ou o ficheiro de status não pôde ser analisado ou aberto.



Cumps

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re: Problema com o Gestor de Actualizações
« Resposta #3 Online: 24 de Maio de 2011, 13:33 »
sudo rm /var/lib/apt/lists/* ; sudo apt-get clean ; sudo apt-get -f install ; sudo apt-get update ; sudo apt-get upgrade -y
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline AndreLMS

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Problema com o Gestor de Actualizações
« Resposta #4 Online: 25 de Maio de 2011, 05:46 »
Muio estranho...

Tentei uma vez, não funcionou (dizia que era impossivel).

Tentei uma segunda vez, correu tudo na perfeição xD


Muito obrigado pela ajuda ;)

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re: Problema com o Gestor de Actualizações
« Resposta #5 Online: 25 de Maio de 2011, 12:12 »
Ola isso pode ter acontecido porque vc interrompeu o dpkg, por exemplo, estava instalando alguma coisa pelo terminal e vc fechou, aguarde alguns minutos e tente novamente.

Se a sua duvida foi sanada, por gentileza adicione o icone "solucionado" editando a sua primeira mensagem nesse topico, para ajudar quem esta com o mesmo problema.
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Paulo Correa

  • Visitante
Re: Problema com o Gestor de Actualizações
« Resposta #6 Online: 26 de Maio de 2011, 07:05 »
Assim resolvi o meu problema acho que vai dar para resolver o de vocês.

Meu caso foi solucionado e ai vai a dica para quem ainda pode ter algum problema parecido com este:
Sistema>Administração>Gerenciador de pacotes synaptic>configuração>repositorios:
Baixar de: Servidor Principal.

Outro software: marcar: http://archive.canonical.com/ubuntu lucid (partner)

Atualizações:

Ir>Atualizações de lançamento>Versões normais.
Fechar.

No synaptic:
clicar no botão recarregar.

Pronto. Assim resolvi o meu problema de não conseguir instalar aplicativos no Ubuntu 10.04 Lucid Lynx.

Obrigado a todos pela excelente colaboração.

Dica extraída do site: http://hamacker.santhanna.net/?page_id=2205 Guia do Ubuntu Perfeito indicado pelo user platao.

Onde tem lucid, basta encontrar as mesmas configurações com nathy. E ai está o link de onde extrai todo o tutorial, hamacker.

Espero ter ajudado.

T+