Autor Tópico: rede sem fio não libera botão conectar  (Lida 13198 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #15 Online: 30 de Maio de 2011, 07:38 »
Anh-ham... Execute o comando abaixo para editar o arquivo interfaces:

gksudo gedit /etc/network/interfaces

Apague todas as linhas do arquivo, menos as duas primeiras ("auto lo/iface lo inet loopback").
Salve o arquivo, reinicie o computador, e teste novamente a wireless.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline RPGOULART

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #16 Online: 30 de Maio de 2011, 16:10 »
Valeu Zekkerj, após as alterações que você indicou o not voltou a reconhecer as redes wireless, e acabei descobrindo uma falha cruel minha, o problema de não liberar o botão conectar estava na senha, estava colocando uma senha padrão minha de 6 digitos e a que coloquei no roteador era de 8 digitos, digitei no campo senha por acaso varias coisas já com certa raiva ai botão liberou, depois foi só lembrar a senha e ficou tudo ok, agradeço muito o apoio, abraços amigão.

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #17 Online: 30 de Maio de 2011, 18:07 »
Pessoal também nao consigo me conectar com a rede wireless, para mim aqui ela nem mostra as redes, tenho um dual boot, com o win7 e o ubuntu 11.04
fiz varios topicos mas nada, gostaria de saber se voces podem me ajudar segue meus dados:


flavilton@BLK-PC:~$ sudo lshw -C network

[sudo] password for flavilton:

  *-network               

       description: Ethernet interface

       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller

       vendor: Realtek Semiconductor Co., Ltd.

       physical id: 0

       bus info: pci@0000:01:00.0

       logical name: eth0

       version: 02

       serial: 00:22:64:fd:dd:17

       size: 100Mbit/s

       capacity: 100Mbit/s

       width: 64 bits

       clock: 33MHz

       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation

       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.1.105 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s

       resources: irq:42 ioport:3000(size=256) memory:90410000-90410fff memory:90400000-9040ffff memory:90420000-9043ffff

  *-network DISABLED

       description: Wireless interface

       product: AR5001 Wireless Network Adapter

       vendor: Atheros Communications Inc.

       physical id: 0

       bus info: pci@0000:02:00.0

       logical name: wlan0

       version: 01

       serial: 00:22:69:4b:20:bf

       width: 64 bits

       clock: 33MHz

       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless

       configuration: broadcast=yes driver=ndiswrapper+net5211 driverversion=1.56+,07/26/2007,5.3.0.67 latency=0 link=no multicast=yes wireless=IEEE 802.11g

       resources: irq:17 memory:92600000-9260ffff




      iwconfig wlan0

flavilton@BLK-PC:~$ iwconfig wlan0

wlan0     IEEE 802.11g  ESSID:off/any 

          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   

          Bit Rate:54 Mb/s   

          Power Management:off

          Link Quality:0  Signal level:0  Noise level:0

          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0

          Tx excessive retries:0  Invalid misc:0   Missed beacon:0




      ifconfig -a


flavilton@BLK-PC:~$ ifconfig -a

eth0      Link encap:Ethernet  Endereço de HW 00:22:64:fd:dd:17 

          inet end.: 192.168.1.105  Bcast:192.168.1.255  Masc:255.255.255.0

          endereço inet6: fe80::222:64ff:fefd:dd17/64 Escopo:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1

          pacotes RX:15802 erros:0 descartados:0 excesso:0 quadro:0

          Pacotes TX:14576 erros:0 descartados:0 excesso:0 portadora:0

          colisões:0 txqueuelen:1000

          RX bytes:18096695 (18.0 MB) TX bytes:1574662 (1.5 MB)

          IRQ:42 Endereço de E/S:0x4000



lo        Link encap:Loopback Local 

          inet end.: 127.0.0.1  Masc:255.0.0.0

          endereço inet6: ::1/128 Escopo:Máquina

          UP LOOPBACK RUNNING  MTU:16436  Métrica:1

          pacotes RX:16 erros:0 descartados:0 excesso:0 quadro:0

          Pacotes TX:16 erros:0 descartados:0 excesso:0 portadora:0

          colisões:0 txqueuelen:0

          RX bytes:960 (960.0 B) TX bytes:960 (960.0 B)



wlan0     Link encap:Ethernet  Endereço de HW 00:22:69:4b:20:bf 

          BROADCAST MULTICAST  MTU:1500  Métrica:1

          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0

          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0

          colisões:0 txqueuelen:1000

          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

          IRQ:17 Memória:92600000-92610000


   nm-tool


flavilton@BLK-PC:~$ nm-tool



NetworkManager Tool



State: connected



- Device: eth0  [Auto eth0] ----------------------------------------------------

  Type:              Wired

  Driver:            r8169

  State:             connected

  Default:           yes

  HW Address:        00:22:64:FD:DD:17



  Capabilities:

    Carrier Detect:  yes

    Speed:           100 Mb/s



  Wired Properties

    Carrier:         on



  IPv4 Settings:

    Address:         xxx.xxx.xxx.xxx    (aqui esta tudo certo só troquei o IP, pelos 'X's)
    Prefix:          24 (255.255.255.0)

    Gateway:         xxx.xxx.xxx.xxx
   (aqui também)


    DNS:             xxx.xxx.xxx.xxx   (aqui também está ok)





- Device: wlan0 ----------------------------------------------------------------

  Type:              802.11 WiFi

  Driver:            ndiswrapper

  State:             unavailable

  Default:           no

  HW Address:        00:22:69:4B:20:BF



  Capabilities:



  Wireless Properties

    WEP Encryption:  yes

    WPA Encryption:  yes

    WPA2 Encryption: yes



  Wireless Access Points


         
         cat /etc/network/interfaces



flavilton@BLK-PC:~$ cat /etc/network/interfaces

auto lo

iface lo inet loopback


meu notebook é um Compaq Presario CQ50-113BR e no ubuntu 10.10 a rede pegou uma beleza, espero respostas
grato a todos

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #18 Online: 30 de Maio de 2011, 23:47 »
flavilton, já confirmou se o botão liga/desliga da wireless está na posição "Ligado"?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #19 Online: 31 de Maio de 2011, 10:50 »
flavilton, já confirmou se o botão liga/desliga da wireless está na posição "Ligado"?

sim,  ja o botão de liga/desliga eu preciono ele e nada, sempre fica na mesma, peguei o driver do win para a minha wifi e instalei, através do Gerenciador de drivers do windows mas nem mesmo assim funciona, ja tentei com varios drivrs para win, preciono o botão de liga e desliga e sempre fica na mesma, no win ele funciona bacana mas so no ubuntu 11.04 que deu esse erro.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #20 Online: 31 de Maio de 2011, 11:16 »
Execute o comando abaixo e cole o resultado aqui.

rfkill list all
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #21 Online: 31 de Maio de 2011, 12:13 »

Execute o comando abaixo e cole o resultado aqui.

rfkill list all

ok está ai o resultado

flavilton@BLK-PC:~$ rfkill list all
0: hp-wifi: Wireless LAN
   Soft blocked: yes
   Hard blocked: no

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #22 Online: 31 de Maio de 2011, 12:38 »
Citar
Soft blocked: yes
Sim... certo. Execute os comandos abaixo, cole o resultado aqui.

sudo rfkill unblock wifi

Depois disso teste o acesso.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #23 Online: 31 de Maio de 2011, 12:59 »

Citar
Soft blocked: yes
Sim... certo. Execute os comandos abaixo, cole o resultado aqui.

sudo rfkill unblock wifi

Depois disso teste o acesso.



Deu certo amigo, o meu deu certo agora posso usurfruir da comodidade de andar com meu notebook pelo escritorio sem ficar preso a um fio, muito obrigado

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #24 Online: 31 de Maio de 2011, 13:12 »
Reinicie a máquina e veja se o acesso continua funcionando.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #25 Online: 31 de Maio de 2011, 14:24 »

Reinicie a máquina e veja se o acesso continua funcionando.

Não amigo, estava alegre mas quando reinicia o pc ele nao continuar com a wifi

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #26 Online: 31 de Maio de 2011, 14:55 »
Execute o comando abaixo e cole o resultado aqui.

lsmod | grep wmi
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #27 Online: 31 de Maio de 2011, 17:25 »

Execute o comando abaixo e cole o resultado aqui.

lsmod | grep wmi


hp_wmi                 13418  0
sparse_keymap          13666  1 hp_wmi
snd_rawmidi            25269  1 snd_seq_midi
snd_seq_device         14110  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    55295  14 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #28 Online: 31 de Maio de 2011, 17:32 »
crie o arquivo "/etc/modprobe.d/block-wmi.conf" com o conteúdo abaixo:

Código: [Selecionar]
blacklist hp_wmi
Depois reinicie sua máquina novamente. Diga se depois disso a rede passa a ser ativada normalmente, e se não há efeitos colaterais.

Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #29 Online: 31 de Maio de 2011, 18:06 »
crie o arquivo "/etc/modprobe.d/block-wmi.conf" com o conteúdo abaixo:

Código: [Selecionar]
blacklist hp_wmi
Depois reinicie sua máquina novamente. Diga se depois disso a rede passa a ser ativada normalmente, e se não há efeitos colaterais.



ok, a rede ta ativada, mas nao consegue visualizar os redes sem fio, aqui onde eu estou tem no minimo 5 redes sem fio, mas nao consigo visualizar nenhuma, ta ativado mas nao visualizo as redes