Autor Tópico: rede sem fio não libera botão conectar  (Lida 13212 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #30 Online: 31 de Maio de 2011, 19:08 »
Não precisou usar o "rfkill unblock wifi" desta vez, né?

Mais alguns comandos.

iwconfig wlan0

nm-tool
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #31 Online: 01 de Junho de 2011, 08:38 »
Não precisou usar o "rfkill unblock wifi" desta vez, né?

Mais alguns comandos.

iwconfig wlan0

nm-tool


flavilton@BLK-PC:~$ iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:off/any 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate:54 Mb/s   
          Power Management max timeout:0us  mode:All packets received
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

flavilton@BLK-PC:~$ nm-tool

NetworkManager Tool

State: connected

- Device: eth0  [Auto eth0] ----------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        00:22:64:FD:DD:17

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         10.44.15.83
    Prefix:          16 (255.255.0.0)
    Gateway:         10.44.255.250

    DNS:             10.42.2.3
    DNS:             10.42.2.33
    DNS:             10.42.2.44
    DNS:             200.255.255.65
    DNS:             200.255.255.66
    DNS:             4.2.2.2


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ndiswrapper
  State:             disconnected
  Default:           no
  HW Address:        00:22:69:4B:20:BF

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points

ta ativado, mas nao esta encontrando as redes e nem mesmo as redes ocultas, ele nao encontra as redes wifi

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #32 Online: 01 de Junho de 2011, 08:51 »
Diga uma coisa, pq vc instalou o driver ndiswrapper? O driver nativo costuma funcionar bem. Que tal uma tentativa com ele?

sudo modprobe -r ndiswrapper
sudo modprobe -v ath5k
« Última modificação: 01 de Junho de 2011, 10:27 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #33 Online: 01 de Junho de 2011, 10:09 »

o driver ndiswrapper eu instalei observando outros foruns, e fiz o que você me pediu e o primeiro deu certo mas no segundo apareceu a seguinte mensagem

flavilton@BLK-PC:~$ sudo moprobe -v ath5k
sudo: moprobe: command not found

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #34 Online: 01 de Junho de 2011, 10:27 »
O comando é "modprobe", assim como o primeiro. Saiu errado aqui (corrigindo)
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #35 Online: 01 de Junho de 2011, 11:01 »
ok, foi feito mas agora está desabilitado as opções "Habilitar rede sem fio, redes sem fio" não estão acessivéis

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #36 Online: 01 de Junho de 2011, 11:59 »
repita os comandos de teste ("sudo lshw -C network", "iwconfig wlan0", etc) sem reiniciar a máquina.

Pra voltar ao modo anterior, basta reiniciar.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #37 Online: 02 de Junho de 2011, 13:52 »
olha ai o que aparece quando eu digitei os comandos que você pediu


flavilton@BLK-PC:~$ sudo lshw -C network
  *-network               
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 02
       serial: 00:22:64:fd:dd:17
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.1.101 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:42 ioport:3000(size=256) memory:90410000-90410fff memory:90400000-9040ffff memory:90420000-9043ffff
  *-network
       description: Wireless interface
       product: AR5001 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:22:69:4b:20:bf
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ndiswrapper+netathw driverversion=1.56+,04/01/2008,7.4.2.105 latency=0 link=no multicast=yes wireless=IEEE 802.11g
       resources: irq:17 memory:92600000-9260ffff
flavilton@BLK-PC:~$ iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:off/any 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate:54 Mb/s   
          Power Management max timeout:0us  mode:All packets received
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0



flavilton@BLK-PC:~$ ifconfig -a
eth0      Link encap:Ethernet  Endereço de HW 00:22:64:fd:dd:17 
          inet end.: 192.168.1.101  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: fe80::222:64ff:fefd:dd17/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:786 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:453 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:394625 (394.6 KB) TX bytes:64824 (64.8 KB)
          IRQ:42 Endereço de E/S:0x4000

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:64 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:64 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:4848 (4.8 KB) TX bytes:4848 (4.8 KB)

wlan0     Link encap:Ethernet  Endereço de HW 00:22:69:4b:20:bf 
          endereço inet6: fe80::222:69ff:fe4b:20bf/64 Escopo:Link
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:13 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          IRQ:17 Memória:92600000-92610000



flavilton@BLK-PC:~$ nm-tool

NetworkManager Tool

State: connected

- Device: eth0  [Auto eth0] ----------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        00:22:64:FD:DD:17

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.1.101
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ndiswrapper
  State:             disconnected
  Default:           no
  HW Address:        00:22:69:4B:20:BF

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #38 Online: 02 de Junho de 2011, 14:33 »
Você reiniciou a máquina e não executou os comandos que eu pedi, pra voltar ao driver nativo. Assim, você continua com o driver ndiswrapper.

Eu acredito que o problema está no driver windows que você usou. Aliás, não acho que seja necessário recorrer ao ndiswrapper para um adaptador Atheros, que funciona bem com o driver nativo.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #39 Online: 02 de Junho de 2011, 16:30 »
então o que voce me sugere, desativar o ndiswrapper e deixar o driver do win ou desativar os dois e deixar apenas o nativo ?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #40 Online: 02 de Junho de 2011, 20:54 »
Por enquanto, deixar apenas o driver nativo.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #41 Online: 03 de Junho de 2011, 10:19 »
Por enquanto, deixar apenas o driver nativo.

olha ai, fiz o que voce me pediu, desativei o ndiswrapper e o driver do win, como disse ficou desativado o wireless segue dados

flavilton@BLK-PC:~$ sudo lshw -C network
  *-network               
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 02
       serial: 00:22:64:fd:dd:17
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.1.100 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:42 ioport:3000(size=256) memory:90410000-90410fff memory:90400000-9040ffff memory:90420000-9043ffff
  *-network DISABLED
       description: Wireless interface
       product: AR5001 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:22:69:4b:20:bf
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=2.6.38-8-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bg
       resources: irq:17 memory:92600000-9260ffff
flavilton@BLK-PC:~$ iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
flavilton@BLK-PC:~$ iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
flavilton@BLK-PC:~$ nm-tool

NetworkManager Tool

State: connected

- Device: eth0  [Auto eth0] ----------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        00:22:64:FD:DD:17

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.1.100
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath5k
  State:             unavailable
  Default:           no
  HW Address:        00:22:69:4B:20:BF

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points



Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #42 Online: 03 de Junho de 2011, 10:27 »
Sim, continua bloqueado, o que é bem interessante.

Revendo teu caso, o que eu consigo ver é que há alguma coisa causando o bloqueio da wireless, um bloqueio de software. Enquanto eu escrevo, lembro de já ter visto um caso desses, mas há muito tempo, achava que era um bug resolvido.

Bem, não está indo por bem, vamos resolver "na marra"? Vamos colocar o comando de desbloqueio na inicialização do seu sistema. O inconveniente é que você não vai poder manter a rede wireless desabilitada ao reiniciar a máquina, mas acho que vc pode conviver com isso, não?

Edite o arquivo /etc/rc.local com o comando abaixo.

gksudo gedit /etc/rc.local

A última linha deve ser "exit 0". Antes dessa linha, adicione o comando "rfkill unblock wifi". Salve o arquivo, reinicie sua máquina, e teste a rede.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavilton

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: rede sem fio não libera botão conectar
« Resposta #43 Online: 03 de Junho de 2011, 10:52 »
nao estava conseguindo executar o comando que voce me passou, entaum fui vê-lo graficamente e vi que estava em branco, que nao tem nada escrito isso é normal, é normal o "rc.local" está em branco ?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: rede sem fio não libera botão conectar
« Resposta #44 Online: 03 de Junho de 2011, 11:13 »
Não, não é. Normalmente ele não tem nenhum comando em especial, apenas alguns comentários no início e um "exit 0" ao final.

Eis o meu:
Código: [Selecionar]
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D