Autor Tópico: problemas com squid!!!!!(resolvido)  (Lida 21271 vezes)

Offline Emmers

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
problemas com squid!!!!!(resolvido)
« Online: 07 de Julho de 2011, 11:47 »
ola pessoal!! estou com problemas serissimos no squid e é melhor nem comentar tanto. vou pro que interessa. ja tentei de tudo e nada!
primeiramente quando tento reiniciar o squid : sudo /etc/init.d/squid restart e aparece:
"rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service squid restart

since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the restart(8) utility, e.g. restart squid
squid start/running, process 1727"
.

uso o comando service squid restart e aparece:
"restart: rejected send message, 1 matched rules; type="method_call", sender=":1.55" (uid=1000 pid=1751 comm="restart) interface="com.ubuntu.Upstart0_6.Job" member="Restart" error name="(unset)" requested_reply=0 destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init"))".

uso o comando squid -NCd1 e aparece:

starting squid cache version 2.7.STABLE7 for i386-debian-linux-gnu...
2011/07/07 11:41:38| process ID 1806
2011/07/07 11:41:38| with 1024 file descriptors available
2011/07/07 11:41:38| using epoll for the IO loop
2011/07/07 11:41:38| performing DNS Tests...
2011/07/07 11:41:38| successful DNS name lookup tests...
2011/07/07 11:41:38| dns Socket created at 0.0.0.0, port 39950, FD 6
2011/07/07 11:41:38| adding nameserver 192.168.254.254 from /etc/resolv.conf
2011/07/07 11:41:38| user-Agent logging is disabled.
2011/07/07 11:41:38| referer logging is disabled.
2011/07/07 11:41:38| unlinkd pipe opened on FD 10
2011/07/07 11:41:38| swap maxSize 102400 + 102400 KB, estimated 15753 objects
2011/07/07 11:41:38| target number of buckets: 787
2011/07/07 11:41:38| using 8192 Store buckets
2011/07/07 11:41:38| max Mem  size: 102400 KB
2011/07/07 11:41:38| max Swap size: 102400 KB
2011/07/07 11:41:38| local cache digest enabled; rebuild/rewrite every 3600/3600 sec
2011/07/07 11:41:38| logfileOpen: opening log /var/log/squid/store.log
2011/07/07 11:41:38| rebuilding storage in /var/spool/squid (DIRTY)
2011/07/07 11:41:38| Using Least Load store dir selection
2011/07/07 11:41:38| current Directory is /home/servidor
2011/07/07 11:41:38| loaded Icons.
2011/07/07 11:41:38| accepting transparently proxied HTTP connections at 0.0.0.0, port 3131, FD 12.
2011/07/07 11:41:38| accepting ICP messages at 0.0.0.0, port 3130, FD 13.
2011/07/07 11:41:38| HTCP Disabled.
2011/07/07 11:41:38| WCCP Disabled.
2011/07/07 11:41:38| /var/run/squid.pid: (13) Permission denied
FATAL: Could not write pid file
Abortado


meu squid.conf

http_port 3131 transparent
visible_hostname servidor
cache_mem 100 MB
maximum_object_size_in_memory 128 KB
maximum_object_size 512 MB
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
acl Safe_ports port 80 21 280 443 488 563 591 777 1025-65535
acl purge method PURGE
acl CONNECT method CONNECT
http_access allow manager localhost
http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
acl redelocal src 192.168.1.0/30
http_access allow localhost
http_access allow redelocal
http_access deny all


Pra falar verdade ja tentei de tudo ou "quase".

Gostaria de ajuda de vcs pra superar isso. ja desinstalei o squid instalei de novo e nada!
« Última modificação: 13 de Julho de 2011, 17:03 por Emmers »

Offline ThalesWeb

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #1 Online: 07 de Julho de 2011, 14:12 »
Se não me engano o correto seria usar "restart squid". Eu tenho o mesmo erro que vc (segundo erro) quando o faço por usuário comum. Se for como root, funciona bem.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #2 Online: 07 de Julho de 2011, 14:34 »
tente

sudo service squid restart
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Emmers

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #3 Online: 07 de Julho de 2011, 14:53 »
tente

sudo service squid restart
Apareceu restart:unknow instance:
« Última modificação: 07 de Julho de 2011, 14:55 por Emmers »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #4 Online: 07 de Julho de 2011, 14:58 »
Agora use:

sudo service squid status

Cole o resultado aqui.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Emmers

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #5 Online: 07 de Julho de 2011, 15:01 »
Agora use:

sudo service squid status

Cole o resultado aqui.

squid stop/waiting

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #6 Online: 07 de Julho de 2011, 15:15 »
Tente acessar o serviço, veja se ele responde.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Emmers

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #7 Online: 07 de Julho de 2011, 15:27 »
Tente acessar o serviço, veja se ele responde.

como assim ??? vc quiz dizer reiniciar o serviço??
sudo service squid restart

se for isso o resultado foi

restart: unknown instance

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #8 Online: 07 de Julho de 2011, 15:47 »
Ué, você tem um servidor proxy, tente acessar a internet usando ele. Isso é acessar o serviço...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Emmers

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #9 Online: 07 de Julho de 2011, 16:04 »
Ué, você tem um servidor proxy, tente acessar a internet usando ele. Isso é acessar o serviço...

quando tento navegar na net por qualquer pc da rede, aparece a pagina de erro, aquela velha mensagem de erro de falha no carregamento da pagina.
nao adianta nem acessar por outro pc, pois o squid concerteza ta com problema.
« Última modificação: 07 de Julho de 2011, 16:11 por Emmers »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #10 Online: 07 de Julho de 2011, 16:11 »
Então vamos pela cartilha.

sudo service squid stop
sudo service squid start

tail -20 /var/log/squid/cache.log


Cole a saída dos comandos aqui.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Emmers

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #11 Online: 07 de Julho de 2011, 16:16 »
Então vamos pela cartilha.

sudo service squid stop
sudo service squid start

tail -20 /var/log/squid/cache.log


Cole a saída dos comandos aqui.

ta ai

servidor@servidor:~$ sudo service squid stop
[sudo] password for servidor:
stop: Unknown instance:
servidor@servidor:~$ sudo service squid start
squid start/running, process 1734
servidor@servidor:~$ tail -20 /var/log/squid/cache.log
2011/07/07 15:04:28| FD 13 Closing ICP connection
2011/07/07 15:04:28| Closing unlinkd pipe on FD 10
2011/07/07 15:04:28| storeDirWriteCleanLogs: Starting...
2011/07/07 15:04:28|   Finished.  Wrote 0 entries.
2011/07/07 15:04:28|   Took 0.0 seconds (   0.0 entries/sec).
CPU Usage: 0.172 seconds = 0.104 user + 0.068 sys
Maximum Resident Size: 19024 KB
Page faults with physical i/o: 0
Memory usage for squid via mallinfo():
   total space in arena:    2116 KB
   Ordinary blocks:         1984 KB      3 blks
   Small blocks:               0 KB      6 blks
   Holding blocks:           280 KB      1 blks
   Free Small blocks:          0 KB
   Free Ordinary blocks:     131 KB
   Total in use:            2264 KB 94%
   Total free:               131 KB 5%
2011/07/07 15:04:28| logfileClose: closing log /var/log/squid/store.log
2011/07/07 15:04:28| safeunlink: Couldn't delete /var/run/squid.pid: (2) No such file or directory
2011/07/07 15:04:28| Squid Cache (Version 2.7.STABLE7): Exiting normally.


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #12 Online: 07 de Julho de 2011, 18:34 »
Houve algum erro na inicialização antes dessas mensagens. Execute o comando abaixo e cole o resultado aqui (vai colar um pedaço maior do log do squid):

tail -50 /var/log/squid/cache.log
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Emmers

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #13 Online: 09 de Julho de 2011, 10:38 »
Houve algum erro na inicialização antes dessas mensagens. Execute o comando abaixo e cole o resultado aqui (vai colar um pedaço maior do log do squid):

tail -50 /var/log/squid/cache.log
servidor@servidor:~$ sudo tail -50 /var/log/squid/cache.log
2011/07/07 18:59:56| Starting Squid Cache version 2.7.STABLE7 for i386-debian-linux-gnu...
2011/07/07 18:59:56| Process ID 2218
2011/07/07 18:59:56| With 1024 file descriptors available
2011/07/07 18:59:56| Using epoll for the IO loop
2011/07/07 18:59:56| DNS Socket created at 0.0.0.0, port 57278, FD 6
2011/07/07 18:59:56| Adding nameserver 192.168.254.254 from /etc/resolv.conf
2011/07/07 18:59:56| User-Agent logging is disabled.
2011/07/07 18:59:56| Referer logging is disabled.
2011/07/07 18:59:56| logfileOpen: opening log /var/log/squid/access.log
2011/07/07 18:59:56| Unlinkd pipe opened on FD 11
2011/07/07 18:59:56| Swap maxSize 102400 + 8192 KB, estimated 8507 objects
2011/07/07 18:59:56| Target number of buckets: 425
2011/07/07 18:59:56| Using 8192 Store buckets
2011/07/07 18:59:56| Max Mem  size: 8192 KB
2011/07/07 18:59:56| Max Swap size: 102400 KB
2011/07/07 18:59:56| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
2011/07/07 18:59:56| logfileOpen: opening log /var/log/squid/store.log
2011/07/07 18:59:56| Rebuilding storage in /var/spool/squid (CLEAN)
2011/07/07 18:59:56| Using Least Load store dir selection
2011/07/07 18:59:56| Set Current Directory to /var/spool/squid
2011/07/07 18:59:56| Loaded Icons.
2011/07/07 18:59:56| Accepting proxy HTTP connections at 0.0.0.0, port 3128, FD 14.
2011/07/07 18:59:56| Accepting ICP messages at 0.0.0.0, port 3130, FD 15.
2011/07/07 18:59:56| HTCP Disabled.
2011/07/07 18:59:56| WCCP Disabled.
2011/07/07 18:59:56| Ready to serve requests.
2011/07/07 18:59:56| Done reading /var/spool/squid swaplog (619 entries)
2011/07/07 18:59:56| Finished rebuilding storage from disk.
2011/07/07 18:59:56|       619 Entries scanned
2011/07/07 18:59:56|         0 Invalid entries.
2011/07/07 18:59:56|         0 With invalid flags.
2011/07/07 18:59:56|       619 Objects loaded.
2011/07/07 18:59:56|         0 Objects expired.
2011/07/07 18:59:56|         0 Objects cancelled.
2011/07/07 18:59:56|         0 Duplicate URLs purged.
2011/07/07 18:59:56|         0 Swapfile clashes avoided.
2011/07/07 18:59:56|   Took 0.3 seconds (1961.2 objects/sec).
2011/07/07 18:59:56| Beginning Validation Procedure
2011/07/07 18:59:56|   Completed Validation Procedure
2011/07/07 18:59:56|   Validated 619 Entries
2011/07/07 18:59:56|   store_swap_size = 7160k
2011/07/07 18:59:57| storeLateRelease: released 0 objects
servidor@servidor:~$

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #14 Online: 09 de Julho de 2011, 10:48 »
Bem, nesse momento o squid parece estar em execução, sem erros no log. Confirme isso com o comando

squid -k check
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D