Autor Tópico: problemas com squid!!!!!(resolvido)  (Lida 21486 vezes)

Offline Emmers

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #15 Online: 09 de Julho de 2011, 10:59 »
Bem, nesse momento o squid parece estar em execução, sem erros no log. Confirme isso com o comando

squid -k check
servidor@servidor:~$ squid -k check
squid: ERROR: No running copy
servidor@servidor:~$

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #16 Online: 09 de Julho de 2011, 13:13 »
Cara, que coisa!!! Não tem nada impedindo teu squid de rodar, não tem nada no log dizendo pq ele não está rodando.

Vamos tentar refazer a preparação do squid pra funcionar.

sudo -s

service squid stop
squid -z
service squid start
squid -k check
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Aguilar

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #17 Online: 10 de Julho de 2011, 00:39 »
Boa Noite.

Qual a versão do seu Ubuntu?

se for a versão 10.10 acima (que são as que eu uso)

o Comando correto é:

# sudo squid start
# sudo squid stop
# sudo squid restart

Caso não de certo,
Você tem algum script para manipular o squid?

Mande um
ls -lh /var/log/squid/

Pode ser que seu cache.log esteja com mais de 2Gb.
"Vivendo e Aprendendo... e Compartilhando"

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #18 Online: 10 de Julho de 2011, 00:43 »
Citar
Pode ser que seu cache.log esteja com mais de 2Gb.
Qual seria o problema disso?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Aguilar

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #19 Online: 10 de Julho de 2011, 00:53 »
Porque quando o log do meu server chega a este tamanho ~2Gb, o squid pára.
quando tenta levantar, ele levanta e cai na hora (num Fedora 8).

E se não me engano, li aqui no fórum, quando o squid não se da bem com logs maiores que 2Gb (ubuntu) (mais ou menos nessas palavras que lí)

"Vivendo e Aprendendo... e Compartilhando"

Offline Aguilar

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #20 Online: 10 de Julho de 2011, 01:05 »

# sudo squid start
# sudo squid stop
# sudo squid restart


Vim aqui me corrigir...

Eu errei nesses comandos aí. ;D


O correto é:

platinum@platinum:~$ sudo service squid start
squid start/running, process 2690

platinum@platinum:~$ sudo service squid restart
squid start/running, process 2703

platinum@platinum:~$ sudo service squid status
squid start/running, process 2717

platinum@platinum:~$ sudo service squid stop
squid stop/waiting

platinum@platinum:~$ sudo service squid start
squid start/running, process 2960



desculpa aí... ;)
« Última modificação: 10 de Julho de 2011, 01:12 por Aguilar »
"Vivendo e Aprendendo... e Compartilhando"

Offline Aguilar

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #21 Online: 10 de Julho de 2011, 01:46 »
Boa noite,

primeiramente quando tento reiniciar o squid : sudo /etc/init.d/squid restart e aparece:
"rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service squid restart

since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the restart(8) utility, e.g. restart squid
squid start/running, process 1727"
.

É porque não usa mais o este comando, agora é:
$ sudo service squid start/stop/restart

E se você reparar, seu squid startou
""""squid start/running, process 1727""""

Citar
uso o comando service squid restart e aparece:
"restart: rejected send message, 1 matched rules; type="method_call", sender=":1.55" (uid=1000 pid=1751 comm="restart) interface="com.ubuntu.Upstart0_6.Job" member="Restart" error name="(unset)" requested_reply=0 destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init"))".

Apareceu isso porque você tentou executar o comando como usuário normal, sem privilégios nesta execução.
Tente:
$ sudo service squid start



Citar
como assim  vc quiz dizer reiniciar o serviço??
sudo service squid restart

se for isso o resultado foi

restart: unknown instance

Deu unknown instance, Porque você tentou dar um "restart" com o squid parado.
Tente:
$ sudo service squid start



Citar
servidor@servidor:~$ sudo service squid stop
[sudo] password for servidor:
stop: Unknown instance:
Foi porque o squid estava parado.

Citar
servidor@servidor:~$ sudo service squid start
squid start/running, process 1734
O squid iniciou


Tenta iniciar o squid
$ sudo service squid start

depois de 1 minuto veja se ainda está rodando

$ sudo service squid status.

e coloca os 2 resultados


(zekkerj, me corrige aí se eu errei ou falei demais... hehe)
"Vivendo e Aprendendo... e Compartilhando"

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #22 Online: 10 de Julho de 2011, 12:58 »
Porque quando o log do meu server chega a este tamanho ~2Gb, o squid pára.
quando tenta levantar, ele levanta e cai na hora (num Fedora 8).

E se não me engano, li aqui no fórum, quando o squid não se da bem com logs maiores que 2Gb (ubuntu) (mais ou menos nessas palavras que lí)
Só estranhei essa questão do tamanho dos logs. Por conta do sarg, eu sou obrigado a manter os logs lá do serviço sem rotacionar durante o mês, então eles crescem bem mais que isso --- chegam a mais de 4GiB. Não será alguma coisa do sistema de arquivos que você usa? Alguns, antigos, não conseguem mesmo usar arquivos de mais de 2GiB...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Aguilar

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #23 Online: 10 de Julho de 2011, 14:05 »
É um Fedora Core 8, com squid 2.6.STABLE16 , com sistema de arquivos ext3 e Kernel 2.6.23.1-42.fc8
logfile_rotate 1
#cache_dir ufs /media/sdb1/squidcache 900 16 256
cache_dir ufs /var/spool/squid 900 16 256


Descobri rápido esse problema de encher o log, pois esqueci um:

debug_options ALL,1 (ou era ALL,9 ??, era o que debugava tudo)
No squid.conf, que encheu rápido demais o log.
Mas mesmo assim, depois de desabilitar, quando o log chega a 2Gb, ele pára.

Mas como não preciso, ainda, de logs de acesso de usuários, rotaciono toda semana o squid. squid -k rotate

Agora, aproveitando esse assunto.

Tenho uma dúvida.

No crontab,
qual é melhor?

0 2 * * mon root squid -k rotate                       ou
0 2 * * mon root squid -k rotate &                    ou
0 2 * * mon root /bin/scripts/rotatesquid.sh        ou
0 2 * * mon root /bin/scripts/rotatesquid.sh &


Eu sempre fico em dúvida se precisa ou não, colocar o    &    no final da linha.

Você poderia me explicar a diferença?

Abraços.
"Vivendo e Aprendendo... e Compartilhando"

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #24 Online: 10 de Julho de 2011, 15:04 »
O que acontece, com certeza, é que se o espaço em disco acaba, o squid pára na mesma hora. Mas arquivo acima de 2GiB?... Queria uma prova mais consistente disso.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Aguilar

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #25 Online: 10 de Julho de 2011, 22:37 »
O que acontece, com certeza, é que se o espaço em disco acaba, o squid pára na mesma hora. Mas arquivo acima de 2GiB?... Queria uma prova mais consistente disso.

vou tentar explicar.

Segunda-feira, 07:40hs da manhã, meu celular toca... vamos para o que interessa...

Checo o squid, e diz que não está funcionando e o pid não existe.

Dramatização: em sequencia...

root@servidor:# service squid status
Mané, o seu squid parou, o pid não existe, checa lá...

root@servidor:# service squid start
aí maluko, o squid está rodando agora, pid 3322

root@servidor:# service squid status
Mané, o seu squid parou, o pid não existe, checa lá...

root@servidor:# ls -lh /var/log/squid
-rw-r----- 1 squid squid    25M 2011-07-10 14:03 access.log
-rw-r----- 1 squid squid    25M 2011-07-10 14:03 access.log.0
-rw-r----- 1 squid squid 2,13G 2011-07-10 22:21 cache.log
-rw-r----- 1 squid squid  12K 2011-07-10 14:03 cache.log.0
-rw-r--r-- 1 root  root  248K 2011-07-10 14:03 squid.out
-rw-r----- 1 squid squid 1,7K 2011-07-10 22:03 store.log
-rw-r----- 1 squid squid    0 2011-07-10 14:03 store.log.0

root@servidor:# rm /var/log/squid/*
Excluir   (Y/n) y    para todos....


roto@servidor:# service squid stop
xxxxxxxxxxxxxxxxxxxxx
root@servidor:# killall -9 squid
xxxxxxxxxxx

root@servidor:# service squid start
aí maluko, o squid está rodando agora, pid 3322

root@servidor# service squid status
squid (pid 18994) está rodando...

e não cai mais,
até parar denovo...
Os dados aí foram dramatizados, por eu não lembrar exatamente quais são as mensagens que aparecem.

e agora com este tópico, me atentei a outra coisa.

rotacionei hoje o squid, e conferi os logs, estavam pequenos.

agora estou conferindo os logs lá, e o   "/var/log/squid/cache.log" já está com 213M. mais tarde vou olhar novamente e ver se altera o tamanho.

Quando acontecer novamente este problema, irei salvar os dados e lhe passar, se for de seu interesse.

[]'s
"Vivendo e Aprendendo... e Compartilhando"

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com squid!!!!!
« Resposta #26 Online: 10 de Julho de 2011, 23:22 »
Observa o espaço livre no "/var/log" também. ;)
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Emmers

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re: problemas com squid!!!!!
« Resposta #27 Online: 13 de Julho de 2011, 17:02 »
resolvi esse problema desinstalando essa versao e instalando a versao 3.
obrigado mais uma vez pela ajuda de vcs parceiros do forum
abraços!!!