Autor Tópico: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"  (Lida 10464 vezes)

Offline Kursch

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Online: 26 de Dezembro de 2007, 01:51 »
É o seguinte: tava com problemas pra instalar os drivers da Lexmark 1200 Series. Segui este tutorial (https://help.ubuntu.com/community/HardwareSupportComponentsPrinters/LexmarkMultifuncPrinters) e durante o passo 7 apareceu uma mensagem de erro (no momento não lembro qual). Eu a ignorei e continuei o processo, mas ao chegar ao passo 10, não apareceu a mensagem que deveria aparecer (direct z600:/dev/usblp0 "Lexmark  Lexmark X1100 Series" "Lexmark Printer").

Vendo que não tive sucesso, optei por uma solução mais simples. Fui em Sistema -> Administração -> Impressão, e a Lexmark 1200 series apareceu por lá. Ok. Tornei ela com padrão. Apertei uns botões de next, next e next e tudo mais. Fiz o teste de impressão. Deu certo. ÓTIMO!

Só que quando eu vou ao gerenciador de atualizações, aparece a seguinte mensagem:

Não foi possível inicializar as informações do pacote
Um problema impossível de se resolver ocorreu enquanto inicializava as informações do pacote.
Por favor reporte esse erro do pacote 'update-manager' e inclua a seguinte mensagem de erro:
'E:O pacote z600cups precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.'




E agora? É impossível? Terei que desinstalar e instalar de novo? Não consigo mais fazer nenhuma atualização e consequentemente o pacote Synaptic e o Adicionar/Remover não processam nenhum download. E agora?


Offline Kursch

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #1 Online: 26 de Dezembro de 2007, 11:44 »
1) Tentei, no terminal, os seguintes comandos:

sudo apt-get -f update

 sudo apt-get -f upgrade


O primeiro funcionou tranqüilo, mas o segundo deu o mesmo erro que aparece nas janelas:

E: O pacote z600cups precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.

2) Então, tentei um auto-clean:

sudo apt-get -fm autoclean

E novamente um upgrade. Mas ficou na mesma.

3) Joguei a pasta Lexmark na lixeira e tentei o sudo apt-get check. Mesmo problema.
« Última modificação: 26 de Dezembro de 2007, 12:09 por Kursch »

Offline K-23

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #2 Online: 26 de Dezembro de 2007, 13:12 »
Tente assim:
Ponha o pacote que está a dar erro na sua pasta pessoal.
Vá a Aplicações --> Acessórios --> Terminal (ou consola)

Depois introduza o seguinte comando:

sudo dpkg -i pacote.deb

 onde pacote.deb deve ser substituído pelo nome do pacote. Este deverá estar na sua pasta pessoal, caso contrário o terminal não irá encontrar o pacote. Depois conte se funcionou.
Ajude os desenvolvedores e a comunidade do Ununtu. Teste o Hardy Heron e reporte os bugs.

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #3 Online: 26 de Dezembro de 2007, 15:50 »
Se o sistema esta falando que o pacote precisa ser reinstalado é porque instalado ele já foi. Experimente então executar o comando abaixo:

Código: [Selecionar]
sudo dpkg --remove --force-remove-reinstreq nome-do-pacote
Ele remove de forma forçada um pacote do sistema, e acho que pode resolver seu problema.

Esta dica eu tirei do tópico Instalação de Programas no Ubuntu criado pelo André (pinduvoz).

[]'s

Cristiano
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline K-23

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #4 Online: 26 de Dezembro de 2007, 19:08 »
Se o sistema esta falando que o pacote precisa ser reinstalado é porque instalado ele já foi. Experimente então executar o comando abaixo:

Código: [Selecionar]
sudo dpkg --remove --force-remove-reinstreq nome-do-pacote
Ele remove de forma forçada um pacote do sistema, e acho que pode resolver seu problema.

Esta dica eu tirei do tópico Instalação de Programas no Ubuntu criado pelo André (pinduvoz).

[]'s

Cristiano

Quando tive um problema igual, essa dica aparecia em todo o lado, porém comigo nunca funcionou. Mas se instalasse o pacote pelo terminal já deixava de dar erro no apt-get, por isso aconselhei a instalar desta maneira.
Ajude os desenvolvedores e a comunidade do Ununtu. Teste o Hardy Heron e reporte os bugs.

Offline Kursch

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #5 Online: 26 de Dezembro de 2007, 19:12 »
Tente assim:
Ponha o pacote que está a dar erro na sua pasta pessoal.
Vá a Aplicações --> Acessórios --> Terminal (ou consola)

Depois introduza o seguinte comando:

sudo dpkg -i pacote.deb

 onde pacote.deb deve ser substituído pelo nome do pacote. Este deverá estar na sua pasta pessoal, caso contrário o terminal não irá encontrar o pacote. Depois conte se funcionou.

kursch@kursch:~$ sudo dpkg -i lexmark/z600cups_1.0-2_i386.deb
(Lendo banco de dados ... 100627 arquivos e diretórios atualmente instalados.)
Preparando para substituir z600cups 1.0-2 (usando .../z600cups_1.0-2_i386.deb) ...
Descompactando substituto z600cups ...
/var/lib/dpkg/info/z600cups.postrm: 2: /etc/init.d/cups: not found
dpkg: aviso - antigo script post-removal retornou erro de estado de saída 127
dpkg - tentando script do novo pacote em vez disso ...
/var/lib/dpkg/tmp.ci/postrm: 2: /etc/init.d/cups: not found
dpkg: erro processando lexmark/z600cups_1.0-2_i386.deb (--install):
 subprocesso novo script post-removal retornou código de saída de error 127
/var/lib/dpkg/tmp.ci/postrm: 2: /etc/init.d/cups: not found
dpkg: erro enquanto efetuava-se a limpeza:
 subprocesso post-removal script retornou código de saída de error 127
Erros foram encontrados durante processamento de:
 lexmark/z600cups_1.0-2_i386.deb


Parece que não deu certo.

Se o sistema esta falando que o pacote precisa ser reinstalado é porque instalado ele já foi. Experimente então executar o comando abaixo:

Código: [Selecionar]
sudo dpkg --remove --force-remove-reinstreq nome-do-pacote
Ele remove de forma forçada um pacote do sistema, e acho que pode resolver seu problema.

Esta dica eu tirei do tópico Instalação de Programas no Ubuntu criado pelo André (pinduvoz).

[]'s

Cristiano

kursch@kursch:~$ sudo dpkg --remove --force-remove-reinstreq z600cups
[sudo] password for kursch:
dpkg - aviso, ignorando problema porque --force foi habilitado:
 O pacote está em um estado grave de inconsistência - você deve
 reinstalá-lo antes de tentar uma remoção.
(Lendo banco de dados ... 100626 arquivos e diretórios atualmente instalados.)
Removendo z600cups ...
/var/lib/dpkg/info/z600cups.postrm: 2: /etc/init.d/cups: not found
dpkg: erro processando z600cups (--remove):
 subprocesso post-removal script retornou código de saída de error 127
Erros foram encontrados durante processamento de:
 z600cups


Offline Kursch

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #6 Online: 26 de Dezembro de 2007, 20:46 »
root@kursch:/home/kursch/lexmark# alien -t z600cups-1.0-1.i386.rpm
Warning: Skipping conversion of scripts in package z600cups: postinst postrm preinst
Warning: Use the --scripts parameter to include the scripts.
z600cups-1.0.tgz generated

root@kursch:/home/kursch/lexmark# alien -t z600llpddk-2.0-1.i386.rpm
Warning: Skipping conversion of scripts in package z600llpddk: postinst postrm preinst prerm
Warning: Use the --scripts parameter to include the scripts.
z600llpddk-2.0.tgz generated

Estes foram os erro do passo 7. Mas como foram gerados os arquivos, deixei por isso mesmo.


Offline Kursch

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #7 Online: 28 de Dezembro de 2007, 00:38 »
Eu tô pensando em formatar, já que as respostas não solucionaram o problema e ficar sem atualizar o sistema é soda, mas não queria perder as coisas que já configurei. Quais arquivos do sistema devo salvar?

Offline K-23

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #8 Online: 28 de Dezembro de 2007, 12:39 »
Eu tô pensando em formatar, já que as respostas não solucionaram o problema e ficar sem atualizar o sistema é soda, mas não queria perder as coisas que já configurei. Quais arquivos do sistema devo salvar?
Abra a sua pasta pesssoal e presse Ctrl + H para ver os ficheiros ocultos. Vão aparecer pastas que têm um ponto final antes do nome, essas pastas guardam as suas configurações. Basta copiá-las par algum lado. Depois de formatar e reinstalar, basta voltar copiar esses ficheiros para a sua pasta pessoal.
Ajude os desenvolvedores e a comunidade do Ununtu. Teste o Hardy Heron e reporte os bugs.

Offline jamiro

  • Usuário Ubuntu
  • *
  • Mensagens: 124
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #9 Online: 21 de Janeiro de 2008, 23:48 »
Se o sistema esta falando que o pacote precisa ser reinstalado é porque instalado ele já foi. Experimente então executar o comando abaixo:

Código: [Selecionar]
sudo dpkg --remove --force-remove-reinstreq nome-do-pacote
Ele remove de forma forçada um pacote do sistema, e acho que pode resolver seu problema.

Esta dica eu tirei do tópico Instalação de Programas no Ubuntu criado pelo André (pinduvoz).

[]'s

Cristiano

Tive o mesmo problema e essa dica funcionou comigo. Valeu Cristiano e André(pinduvoz)!

Abraços,

Jamiro

P.S.: De onde André tirou esse nick?  :)

Offline Kamei Hyoga

  • Usuário Ubuntu
  • *
  • Mensagens: 1.095
  • Ubuntu 11.04
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #10 Online: 12 de MAR?O de 2008, 14:36 »
Estou revivendo o tópico, pq acabou de acontecer comigo. Também estava tentando instalar o mesmo pacote para minha impressora Lexmark.

Bem, já tentei todos os comandos possiveis e não gostaria mesmo de ter que reformatar todo o sistema.

Quando executo o comando sudo apt-get install -f, rebeco a seguinte msg:

Citar
Lendo lista de pacotes... Pronto
Construindo árvore de dependências       
Reading state information... Pronto
Os pacotes a seguir serão REMOVIDOS:
  z600cups
0 pacotes atualizados, 0 pacotes novos instalados, 1 a serem removidos e 2 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso fazer o download de 0B de arquivos.
Depois de desempacotar, 246kB de espaço em disco serão liberados.
Quer continuar [S/n]? y
(Lendo banco de dados ... 108934 arquivos e diretórios atualmente instalados.)
Removendo z600cups ...
/var/lib/dpkg/info/z600cups.postrm: 2: /etc/init.d/cups: not found
dpkg: erro processando z600cups (--remove):
 subprocesso post-removal script retornou código de saída de error 127
Erros foram encontrados durante processamento de:
 z600cups
E: Sub-process /usr/bin/dpkg returned an error code (1)

Olhei meu /etc/init.d/ e lá só exite um cupsys

Realmente preciso da ajuda de vcs, pq a última coisa que quero e posso é formatar tudo denovo.
« Última modificação: 12 de MAR?O de 2008, 14:38 por Kamei Hyoga »

Offline Kamei Hyoga

  • Usuário Ubuntu
  • *
  • Mensagens: 1.095
  • Ubuntu 11.04
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #11 Online: 12 de MAR?O de 2008, 14:46 »
Acabei de resolver sozinho KKKKKKKKK Coisa de doido mesmo heheheh

Foi só prestar atenção no erro. Ele dizia que o /var/lib/dpkg/info/z600cups.postrm não achava o /etc/init.d/cups, então editei o z600cups.postrm e mudei cups para cupsys. Executei o sudo apt-get install -f novamente e foi removido ^^

Aparentemente está tudo OK agora ^^

Offline bdmstyle

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Mais um erro de atualização: "Erro interno ao abrir o cache (1)"
« Resposta #12 Online: 21 de Julho de 2011, 10:33 »
Ola pessoal é meu primeiro post, tava apanhando deste erro consegui resolver de forma simples vai na pasta var/lib/dpkg/info e excluir nomedopacote.* depois mandar atualizar que resolve