Autor Tópico: Mais uma vez GRUUB,  (Lida 5867 vezes)

Ronald

  • Visitante
Mais uma vez GRUUB,
« Online: 24 de Julho de 2006, 23:02 »
Disk /dev/hda: 10.2 GB, 10202050560 bytes
255 heads, 63 sectors/track, 1240 cylinders
Units = cilindros of 16065 * 512 = 8225280 bytes
Dispositivo Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          31      248976   83  Linux
/dev/hda2              32        1240     9711292+   5  Estendida
/dev/hda5              32        1240     9711261   8e  Linux LVM

Disk /dev/hdb: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cilindros of 16065 * 512 = 8225280 bytes
Dispositivo Boot      Start         End      Blocks   Id  System
/dev/hdb1               1        4998    40146403+   7  HPFS ou NTFS

Srs. a configuração acima é do meu computador contando com dois HD. Já fiz todas as modificações dos tutoriais disponíveis para Ubuntu (5.10) porém não consigo ter duas opções de Boot uma para ubuntu e outra para Windows XP que está em outro HD.

Ronald

  • Visitante
Re: Mais uma vez GRUUB,
« Resposta #1 Online: 24 de Julho de 2006, 23:10 »
Como complemento coloco a confg. do Grub de meu computador:

title      Ubuntu, kernel 2.6.12-10-386
root      (hd0,0)
kernel      /vmlinuz-2.6.12-10-386 root=/dev/mapper/Ubuntu-root ro quiet splash
initrd      /initrd.img-2.6.12-10-386
savedefault
boot

title      Ubuntu, kernel 2.6.12-10-386 (recovery mode)
root      (hd0,0)
kernel      /vmlinuz-2.6.12-10-386 root=/dev/mapper/Ubuntu-root ro single
initrd      /initrd.img-2.6.12-10-386
boot

title      Ubuntu, kernel 2.6.12-9-386
root      (hd0,0)
kernel      /vmlinuz-2.6.12-9-386 root=/dev/mapper/Ubuntu-root ro quiet splash
initrd      /initrd.img-2.6.12-9-386
savedefault
boot

title      Ubuntu, kernel 2.6.12-9-386 (recovery mode)
root      (hd0,0)
kernel      /vmlinuz-2.6.12-9-386 root=/dev/mapper/Ubuntu-root ro single
initrd      /initrd.img-2.6.12-9-386
boot

title      Ubuntu, memtest86+
root      (hd0,0)
kernel      /memtest86+.bin 
boot


### END DEBIAN AUTOMAGIC KERNELS LIST
# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root

title Microsoft Windows
root(hd1,0)
savedefault
makeactive
chainloader   +1

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: Mais uma vez GRUUB,
« Resposta #2 Online: 25 de Julho de 2006, 04:49 »
Ronald,
se não estou em erro a partição de windows teria que ter a flag de "bootable", isto é visive pelo * na coluna de Boot do fdisk
Para colocar a partição "bootable" digita:
Código: [Selecionar]
sudo fdisk /dev/hdb1depois tecla "a"
depois tecla "w"
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu

Ronald

  • Visitante
Re: Mais uma vez GRUUB,
« Resposta #3 Online: 25 de Julho de 2006, 07:35 »
depois tecla "a"
depois tecla "w"

Caro Lamego tentei utilizar sua dica, mas parece que a opção "w" não foi aceita. Reiniciei o computador e tentei dar o boot e a mesma mensagem aparece:

"Booting "Microsoft Windows"

savedefault
makeactive
chainloader +1

Error 13: Invalid or unsupported format

Press any key to continue....." 

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: Mais uma vez GRUUB,
« Resposta #4 Online: 25 de Julho de 2006, 07:47 »
Ronald,
na entrada para o windows XP no seu menu.lst substitui "root" por "rootnoverify", o rootnoverify nao valida o formato da partiçao de que vai fazer boot.
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu

Ronald

  • Visitante
Re: Mais uma vez GRUUB,
« Resposta #5 Online: 25 de Julho de 2006, 08:10 »
Caro Lamego acabo de fazer esta alteração que vc. indicou; ficou "rootnoverify(hd1,0). Porém a mesma mensagem apareceu na hora do boot. Outra coisa, após utilizar as opções "a" e "w", entrei em "fdisk -l" para verificar se tinha assumido como boot e continuava desmarcada a posição de boot. Será que oproblema é porque o hdb1 está como Slave? De qq. forma continuo a não conseguir acessar o Windows Xp.
Sds.
Ronald

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: Mais uma vez GRUUB,
« Resposta #6 Online: 25 de Julho de 2006, 11:08 »
Estou ficando sem soluções, quando faz o "w" para a gravação o fdisk retorna algum erro ?
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu

Ronald

  • Visitante
Re: Mais uma vez GRUUB,
« Resposta #7 Online: 25 de Julho de 2006, 12:05 »
Caro Lamego qdo. coloco "a" ele mostra quant. de trilhas e clusters qdo. digito o "w" ele continua na mesma linha, como se não houvesse digitado nada. Estou pensando em desistir e voltar a usar o Windows.
Sds.
Ronald

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: Mais uma vez GRUUB,
« Resposta #8 Online: 25 de Julho de 2006, 12:08 »
Vamos experimentar com um fdisk mais agradável:
Código: [Selecionar]
sudo cfdisk /dev/hdb1Depois utiliza a opção que diz "Bootable" e grava.
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu

Ronald

  • Visitante
Re: Mais uma vez GRUUB,
« Resposta #9 Online: 25 de Julho de 2006, 12:23 »
Caro Lamego vou colar abaixo o que apareceu no terminal após utilizar o cfdisk:
Uso:
Mostrar versão:
        cfdisk -v
Mostrar tabela de partições:
        cfdisk -P {r|s|t} [opções] dispositivo
Uso interativo:
        cfdisk [opções] dispositivo

Opções:
-a: Usar seta em vez de realce.
-z: Iniciar com uma tabela de zero partições, em vez de ler a tabela do disco.
-c C -h H -s S: Sobrepor as suposições do kernel quanto a número de cilindros,
                número de cabeças e número de setores/trilha.

Copyright (C) 1994-2002 Kevin E. Martin & aeb
Desculpe pela ignorância, mas não visualisei nenhuma opção "bootable", será que utilizei o aplicatico corretamente?
Sds.
Ronald