Autor Tópico: ( resolvido ) - Servidor DNS nao encontrado  (Lida 9326 vezes)

Offline rafa_zan

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
( resolvido ) - Servidor DNS nao encontrado
« Online: 09 de Agosto de 2011, 19:12 »
Boa noite pessoal.

Preciso saber pq meu not recebe o ip mas acusa erro de servidor dns nao econtrado.
OBS: se eu configurar meu navegador com proxy funciona 100% .
Porem quero fazer ele funcionar sem precisar configurar o proxy no navegador.

1 - já instalei o dhcp3-server

2 - já instalei o bind9

Ai está minhas configurações:
etc/dhcp/dhcpd.conf

ddns-update-style none;
default-lease-time 600;
max-lease-time 7200;
log-facility local7;
subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.2 192.168.0.50;
option domain-name-servers 8.8.8.8,8.8.4.4;
option domain-name "rafael";
option routers 192.168.0.100;
option broadcast-address 192.168.0.255;
}
------------------------------------------------
SQUID3 - Configuração.

#       WELCOME TO SQUID 3.1.11

# Porta disponivel para funcionar o squid = IP Servidor + porta
http_port 3128 transparent

# Nome do Servidor Proxy
visible_hostname Proxy-Server

# Quantidade de memoria  RAM usada
cache_mem 512 MB
cache_dir ufs /var/spool/squid3 10000 16 256

# Local onde os registros de acesso ficam armazenados
cache_access_log /var/log/squid3/access.log

# Atualizacao da cache
refresh_pattern ^ftp:           15      20%     10080
refresh_pattern ^gopher:        15      0%      1440
refresh_pattern .               0       20%     4320

# ACLS = Politicas de Acesso
acl QUERY urlpath_regex cgi-bin \?
acl manager proto cache_object
acl localhost src 127.0.0.1/32
acl SSL_ports port 443
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443         # https
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl purge method PURGE
acl CONNECT method CONNECT

http_access allow  manager localhost
http_access deny manager
http_access allow  purge localhost
http_access deny  purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

#acl bloqueados url_regex "/etc/squid3/bloqueados.txt"
#http_access deny bloqueados

acl redelocal src 192.168.0.0/24
http_access allow localhost
http_access allow redelocal
http_access deny all

# Nao deixa consultar cache visinhos
hierarchy_stoplist cgi-bin ?
----------------------------------------------------------

interfaces de rede

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 10.1.1.100
netmask 255.0.0.0
gateway 10.1.1.1

#The secundary network interface
auto eth1
iface eth1 inet static
address 192.168.0.100
netmask 255.255.255.0

-----------------------------------------
meu firewall

#!bin/sh
iptables -F
iptables -t nat -F

modprobe iptable_nat

echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
iptables -t nat -A PREROUTING -s 192.168.0.100/255.255.255.0 -p tcp  --dport 80 -j REDIRECT --to-port 3128

--------------------------------------------
/etc/resolv.conf
nameserver 8.8.8.8
-----------------------------------------

Preciso de um help, pois quando ligo a rede no note, parece que ele vai funcionar, receb os ips tudo certinhos,  mas nao consegue resolver o erro de DNS.



« Última modificação: 12 de Agosto de 2011, 07:35 por rafa_zan »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.637
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor DNS nao encontrado
« Resposta #1 Online: 10 de Agosto de 2011, 10:38 »
Olá rafa_zan,

Seu note, qual o sistema operacional dele? Pq não tem erro grave nas configurações que vc passou (só algumas coisas que poderiam ser corrigidas), eu precisaria saber o SO pra passar os comandos que vc precisa passar pra testar o funcionamento do DNS.

Note que quando você configura o proxy no navegador do notebook, quem resolve o DNS é o servidor proxy; já quando você usa o proxy transparente, quem resolve o DNS é a própria estação de trabalho, no caso, o notebook, então a gente tem que testar o funcionamento do DNS nele.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline rafa_zan

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Servidor DNS nao encontrado
« Resposta #2 Online: 10 de Agosto de 2011, 20:11 »
Caro colega zekkerj

Tenho instalado no meu not o S.O. Windows Seven - Ultimate.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.637
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor DNS nao encontrado
« Resposta #3 Online: 10 de Agosto de 2011, 20:19 »
Abra um prompt de DOS em seu note, e execute os comandos abaixo. Depois, cole o resultado aqui.

ping 8.8.8.8

ping www.google.com

nslookup www.google.com
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline rafa_zan

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Servidor DNS nao encontrado
« Resposta #4 Online: 10 de Agosto de 2011, 20:56 »
Segue o resultado:

---------------------------------------------------------------------
C:\Users\Rafael>ping 8.8.8.8

Disparando 8.8.8.8 com 32 bytes de dados:
Esgotado o tempo limite do pedido.
Esgotado o tempo limite do pedido.
Esgotado o tempo limite do pedido.

Estatísticas do Ping para 8.8.8.8:
    Pacotes: Enviados = 3, Recebidos = 0, Perdidos = 3 (100% de
             perda),

-----------------------------------------------------------------------------------
C:\Users\Rafael>ping www.google.com
A solicitação ping não pôde encontrar o host www.google.com. Verifique o nome e
tente
novamente.

------------------------------------------------------------------------------------
Microsoft Windows [versão 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. Todos os direitos reservados.

C:\Users\Rafael>nslookup www.google.com.br
DNS request timed out.
    timeout was 2 seconds.
Servidor:  UnKnown
Address:  8.8.8.8

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** O tempo limite da solicitação para UnKnown expirou



o estranho foi como vc me disse, com o proxy funciona tudo certo, testei um ping do not para a placa de rede local do servidor, tudo ok, e vice -versa.
tem momentos que ele fica aguardando resposta do servidor mais nao vai.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.637
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor DNS nao encontrado
« Resposta #5 Online: 11 de Agosto de 2011, 01:17 »
Isso foi só pra confirmar o que eu estava pensando, você está sem conectividade com o servidor DNS nas estações.

Vamos rever o servidor, se ele está roteando corretamente. Execute os comandos abaixo no servidor Ubuntu, cole o resultado aqui.

sudo ufw status
sysctl net.ipv4.ip_forward
sudo iptables -L -v -n
sudo iptables -t nat -L -v -n
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline rafa_zan

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Servidor DNS nao encontrado
« Resposta #6 Online: 11 de Agosto de 2011, 19:49 »
Vamos lá:

-----------------------------------------------------------------------------------
root@server:~# ufw status
Estado: inativo

-----------------------------------------------------------------------------------

root@server:~# sysctl net.ipv4.ip_forward
net.ipv4.ip_forward = 0

------------------------------------------------------------------------------------

root@server:~# iptables -L -v -n
Chain INPUT (policy ACCEPT 402 packets, 34890 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain OUTPUT (policy ACCEPT 213 packets, 24701 bytes)
 pkts bytes target     prot opt in     out     source               destination

------------------------------------------------------------------------------------
root@server:~# iptables -t nat -L -v -n
Chain PREROUTING (policy ACCEPT 213 packets, 16160 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain INPUT (policy ACCEPT 7 packets, 1491 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain OUTPUT (policy ACCEPT 3 packets, 818 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain POSTROUTING (policy ACCEPT 3 packets, 818 bytes)
 pkts bytes target     prot opt in     out     source               destination
-----------------------------------------------------------------------------------


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.637
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor DNS nao encontrado
« Resposta #7 Online: 11 de Agosto de 2011, 22:09 »
Citar
root@server:~# sysctl net.ipv4.ip_forward
net.ipv4.ip_forward = 0

Teu script de firewall não está funcionando... vc colocou chamada pra ele no /etc/rc.local, ou o quê?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline rafa_zan

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Servidor DNS nao encontrado
« Resposta #8 Online: 11 de Agosto de 2011, 22:23 »
bem ai nesse caminho zekkerj

dentro do meu /etc/rc.local está assim:

/usr/local/bin/meu_firewall ( aqui é o arquivo que possui os scritps de firewall)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.637
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor DNS nao encontrado
« Resposta #9 Online: 11 de Agosto de 2011, 22:37 »
E vc lembrou de dar permissão de execução ao script?

O rc.local vem com uma linha "exit 0" no final, se vc for colocar algo pra rodar no boot, tem que colocar antes dessa linha.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline rafa_zan

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Servidor DNS nao encontrado
« Resposta #10 Online: 12 de Agosto de 2011, 07:34 »
meu irmão se matou a charada =]

era só porque não lembrei de dar a permissão para execução do script (heheheh)

Abraço, muito obrigado.