Autor Tópico: Modem HSP56MR  (Lida 9373 vezes)

AaroeiraA

  • Visitante
Modem HSP56MR
« Online: 15 de Abril de 2005, 13:07 »
Pessoal,

Beleza ? Eu estou precisando de uma ajuda com relação ao modem HSP56MR - SiS 7013. Eu consegui configurá-lo no Hoary com a ajuda do Marcelo Mendes que me mandou o driver slmodem-2.9.10 com um patch de correção para o kernel padrão na instalação do Hoary (2.6.10).

Na hora de usar o mesmo, com o WVDIAL, eu não consigo conexões maiores que 14400. Eu conecto a 4800, 7200, 9600 e tal.  :(

Alguém saberia me dizer o que é ?

Configuração da minha máquina:

PENTIUM 3 850MHZ
M755LMR PCCHIPS (Tudo onboard-Vídeo,Som,Rede,Fax)
512MB RAM
80 GBHD (2x40GB)
GRAVADOR LG

LINHA TELEFÔNICA DIGITAL.

Obrigado pessoal.  :wink:

Offline snooze

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Modem HSP56MR
« Resposta #1 Online: 24 de Abril de 2005, 13:17 »
Procure pela linha:

Baud = XXXXXX

no arquivo de configuração (/etc/wvdial.conf ou $HOME/.wvdial.conf) e troque o valor por 460800. Pode também tentar recriar o arquivo de configuração, digitando wvdialconf /etc/wvdial.conf (como root) ou wvdialconf $HOME/.wvdial.conf, basicamente para corrigir a string de inicialização do modem.

Se não for esse o caso, sugiro voltar a usar o slmodem-2.9.7 que pelo menos para mim, é a última versão que funciona sem nenhum problema.

Abaixo, exemplo do meu $HOME/.wvdial.conf

Código: [Selecionar]
[Dialer Defaults]
Modem = /dev/ttySL0
ISDN = off
Modem Type = Analog Modem
Baud = 460800
Init = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 =
Init4 =
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =
Phone = 15002442
Phone1 = 15002442
Phone2 =
Phone3 =
Phone4 =
Dial Prefix =
Dial Attempts = 10
Dial Command = ATM0L0DT
Ask Password = off
Password = minhasenha
Username = login@provedor.com.br
Auto Reconnect = off
Abort on Busy = on
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on
Ubuntu 8.04 Hardy Heron
MoBo Intel D102GGC2 | Processador Intel Celeron 3,06Ghz | Memória 512DDR2 533mhz | Video ATI Radeon XPRESS 200 | Audio Realtek ALC833 (HDA ATI SB) | Rede Realtek 8101L | Modem Agere V.92 56k

AaroeiraA

  • Visitante
HSP56MR
« Resposta #2 Online: 02 de Maio de 2005, 20:25 »
Snooze,

Muito obrigado. Vou verificar quando chegar em casa. Valeu mesmo cara.

 :wink:

Anonymous

  • Visitante
Modem HSP56MR
« Resposta #3 Online: 03 de Maio de 2005, 08:30 »
Snooze,

Eu tentei compilar o driver slmodem-2.9.7 para o Ubuntu Hoary mas eu não consegui. Vários problemas foram detectados.

Você conseguiu compilar em sua máquina ?

Offline snooze

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Modem HSP56MR
« Resposta #4 Online: 07 de Maio de 2005, 14:21 »
compilou sem problemas no Warty. Ainda não instalei o source do kernel do Hoary. Poste os erros pra ver se dá pra ajudar.
Ubuntu 8.04 Hardy Heron
MoBo Intel D102GGC2 | Processador Intel Celeron 3,06Ghz | Memória 512DDR2 533mhz | Video ATI Radeon XPRESS 200 | Audio Realtek ALC833 (HDA ATI SB) | Rede Realtek 8101L | Modem Agere V.92 56k