Autor Tópico: Gnome-Shell (3) + Ubuntu 11.10  (Lida 7928 vezes)

Offline renanpinto

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Gnome-Shell (3) + Ubuntu 11.10
« Online: 01 de Novembro de 2011, 15:07 »
Olá senhores,

Como minha primeira mensagem aqui no fórum, gosteria de solicitar ajuda sobre um problema que está me deixando muito insatisfeito nos últimos dias.

Fiquei muito ansioso para instalar o ubuntu 11.10, e assim que foi lançado fiz o download. Porém, ao instalar o Gnome-Shell, sempre aconteceu o problema como mostra a imagem:

http://i40.tinypic.com/23kw56w.jpg

Reparem a barra no topo..

Formatei a máquina e instalei em outro computador e o mesmo problema. Algumas vezes funcionava durante um tempo e dava esse problema. Mesmo assim que acabava de formatar e instalava o gnome eu entrava na sessão e dava isso. O engraçado é q o Unity funciona normalmente..

Já vi na internet sobre compatibilidade de plugins, conflito com o compiz, algo relacionada a placa de vídeo onboard etc.. mais nada referente a isso, é como só eu tivesse esse problema.. será?

E também as vezes está travando. Não consigo clicar em nada nem nada se meche, apenas o mouse.

Se alguém puder ajudar eu agradeço,

Abraços
« Última modificação: 01 de Novembro de 2011, 15:18 por platao »

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.370
  • @Ceará
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #1 Online: 01 de Novembro de 2011, 15:21 »
O maior problema de travamento do Gnome-Shell é a incompatibilidade de alguns temas.

Uma solução para remover o menu é:
Código: [Selecionar]
sudo apt-get autoremove appmenu-gtk appmenu-gtk3 appmenu-qt
Outra é instalar o gnome-tweak-tool e desabilitar o gerenciar na área de trabalho.
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline renanpinto

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #2 Online: 01 de Novembro de 2011, 18:21 »
Nadinha..

Consegui remover o menu, mais ai não fica nada ali. Ou seja, a interface do gnome-shell não volta..

O gnome-tweak-tool eu já tinha, o  que fiz agora foi deletar todas as extensões direto na pasta, pois ele não abre.

Tentei reinstalar o gnome-shell pela central de programas e nada..

O que devo fazer?

Abraços

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.370
  • @Ceará
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #3 Online: 01 de Novembro de 2011, 18:47 »
Você instalou algum tema?
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline renanpinto

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #4 Online: 01 de Novembro de 2011, 21:04 »
Não, não instalei nenhum tema.. Só cheguei a alterar entre os que já estão ali no gnome-tweak-tool.. Mais como eu disse, teve vezes que acabei de formatar e instalar o shell e o problema já aparecia..

Offline BrunoPT

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
    • Site Pessoal
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #5 Online: 01 de Novembro de 2011, 21:43 »
Alt+F2 - r - Enter

Offline renanpinto

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #6 Online: 01 de Novembro de 2011, 23:08 »
O alt+F2 bem como qualquer outro atalho do teclado não funciona...

Offline Micaro

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #7 Online: 02 de Novembro de 2011, 00:41 »
Renanpinto, meu gnome-shell estava apresentando erros também. Os menus haviam travado e o único comando que aceitava era Crtl+Alt+Del para encerrar a sessão, resolvi com esse procedimento:

1. Abra o terminal (Ctrl+Alt+t);
2. Mude para root (sudo su)
3. Navegue até a pasta /usr/share/gnome-shell/js/ui/
4. Abra o arquivo "dateMenu.js" (gedit dateMenu.js);
5. desça até a linha 214 e "comente" a linha this._date.set_text(displayDate.toLocaleFormat(dat eFormat));

Ficará assim: /* this._date.set_text(displayDate.toLocaleFormat(dat eFormat)); */

Os caracteres /* e */ servem para deixar o texto como comentário dentro do arquivo.

Espero ter ajudado.

Abç.



http://ubuntuforum-pt.org/index.php/topic,88304.0.html

Offline renanpinto

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #8 Online: 02 de Novembro de 2011, 02:34 »
Bom, realizei o procedimento que o Micaro indicou. Encerrei a sessão e entrei com o GNOME.
Para minha alegria, voltou a funcionar.

Fiquei em dúvida se foi o procedimento acima que deu certo, então editei novamente o arquivo e retirei o comentário. Reiniciei e continuou funcionando..

Sendo que eu já tinha deletado todas as extensões que havia instalado. Então resta saber se foi um conflito com alguma.. Fui reinstalando uma a uma, e até aqui está funcionando bem. Estou usando ele agora.

O que reparei, é que estou com o tema de janelas padrão, o adwaita. Qnd falei acima não foi o tema que troquei, e sim o tema das janelas. Vou manter ele para fazer um teste.

Por hora, não vou colocar o tópico como resolvido, pois da última vez demorou 2 dias para o problema voltar..

Se alguém tiver alguma informação a acrescentar, seria interessante.

Abraço a todos

Offline cygnusx-1

  • Usuário Ubuntu
  • *
  • Mensagens: 570
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #9 Online: 03 de Novembro de 2011, 19:39 »
Comigo também aconteceu isso durante um tempo, mas pra mim ficava só a barra de menus com o papel de parede, sem ícones, acontecia só às terças e aos sábados, tem alguma coisa a ver com caracteres diferentes (acentos e ç) na data, já resolvi com uma dica postada em outro tópico.

Offline renanpinto

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #10 Online: 05 de Novembro de 2011, 03:34 »
Pois é, o problema voltou.. O que o colega acima tem um certo sentido, poi notei que o relógio havia congelado. ele exibia a hora congelada no painel, porém quando fui vr as conf dele a hora estava certa.

O amigo poderia citar o link do tópico em que resolveu o problema..

Não parece haver um solução, ou ninguém teve esse problema. Já não sei mais o que fazer. Eu gostei muito do gnome-shell, ainda mais comparando ao unity. Acho que uma saída para que eu possa continuar usando essa interface é migrar para o fedora até os desenvolvedores do ubuntu identificarem e corrigirem esse problema. Talvez só na versão 12.04, pois já atualizei o 11.10 várias vezes e não resolveu o problema.

Se alguém puder dar uma força eu agradeço.

Abraços

Offline Ernesto

  • Usuário Ubuntu
  • *
  • Mensagens: 96
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #11 Online: 05 de Novembro de 2011, 09:56 »
Fiz o procedimento postado aqui e me parece que resolveu o problema.
sudo gedit /etc/default/locale
Apague tudo o que estiver no texto. Copie, cole e salve o texto abaixo

LANG="pt_BR.UTF-8"
LANGUAGE="pt_BR:en"
LC_MESSAGES="pt_BR.UTF-8"
LC_CTYPE="pt_BR.UTF-8"
LC_COLLATE="pt_BR.UTF-8"

Agora entre no terminal Ctrl+Alt+t e digite sudo update-grub para corrigir o grub dos erros de acentuação. Reinicie e pronto.
« Última modificação: 05 de Novembro de 2011, 10:04 por Ernesto »

Offline cygnusx-1

  • Usuário Ubuntu
  • *
  • Mensagens: 570
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #12 Online: 05 de Novembro de 2011, 12:37 »
Fiz o procedimento postado aqui e me parece que resolveu o problema.
sudo gedit /etc/default/locale
Apague tudo o que estiver no texto. Copie, cole e salve o texto abaixo

LANG="pt_BR.UTF-8"
LANGUAGE="pt_BR:en"
LC_MESSAGES="pt_BR.UTF-8"
LC_CTYPE="pt_BR.UTF-8"
LC_COLLATE="pt_BR.UTF-8"

Agora entre no terminal Ctrl+Alt+t e digite sudo update-grub para corrigir o grub dos erros de acentuação. Reinicie e pronto.

Reverti as alterações de outra dica q eu tinha seguido mas q não tinha dado totalmente certo (às terças o GS só entrava na segunda tentativa e apareciam caracteres estranhos no grub e na verificação do hd dutrante o boot) pra testar essa, funciona perfeitamente mesmo. Grande dica, Ernesto!
Abraço.

Offline Ioca100

  • Usuário Ubuntu
  • *
  • Mensagens: 2.848
  • Rio,Brasil
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #13 Online: 05 de Novembro de 2011, 12:51 »
Fiz o procedimento postado aqui e me parece que resolveu o problema.
sudo gedit /etc/default/locale
Apague tudo o que estiver no texto. Copie, cole e salve o texto abaixo

LANG="pt_BR.UTF-8"
LANGUAGE="pt_BR:en"
LC_MESSAGES="pt_BR.UTF-8"
LC_CTYPE="pt_BR.UTF-8"
LC_COLLATE="pt_BR.UTF-8"

Agora entre no terminal Ctrl+Alt+t e digite sudo update-grub para corrigir o grub dos erros de acentuação. Reinicie e pronto.

Reverti as alterações de outra dica q eu tinha seguido mas q não tinha dado totalmente certo (às terças o GS só entrava na segunda tentativa e apareciam caracteres estranhos no grub e na verificação do hd dutrante o boot) pra testar essa, funciona perfeitamente mesmo. Grande dica, Ernesto!
Abraço.

Engraçado colega, pois, também fiz a dica antiga e não notei esses caracteres estranhos e o GS entra numa boa no sábado, vou verificar na próxima terça e qualquer coisa , mudo aqui também.
Valeu a todos.
Usuário Linux- 449417

Offline cygnusx-1

  • Usuário Ubuntu
  • *
  • Mensagens: 570
    • Ver perfil
Re: Gnome-Shell (3) + Ubuntu 11.10
« Resposta #14 Online: 05 de Novembro de 2011, 12:54 »
Fiz o procedimento postado aqui e me parece que resolveu o problema.
sudo gedit /etc/default/locale
Apague tudo o que estiver no texto. Copie, cole e salve o texto abaixo

LANG="pt_BR.UTF-8"
LANGUAGE="pt_BR:en"
LC_MESSAGES="pt_BR.UTF-8"
LC_CTYPE="pt_BR.UTF-8"
LC_COLLATE="pt_BR.UTF-8"

Agora entre no terminal Ctrl+Alt+t e digite sudo update-grub para corrigir o grub dos erros de acentuação. Reinicie e pronto.

Reverti as alterações de outra dica q eu tinha seguido mas q não tinha dado totalmente certo (às terças o GS só entrava na segunda tentativa e apareciam caracteres estranhos no grub e na verificação do hd dutrante o boot) pra testar essa, funciona perfeitamente mesmo. Grande dica, Ernesto!
Abraço.

Engraçado colega, pois, também fiz a dica antiga e não notei esses caracteres estranhos e o GS entra numa boa no sábado, vou verificar na próxima terça e qualquer coisa , mudo aqui também.
Valeu a todos.

Aos sábados sempre entrava, só nas terças q na primeira vez ficava a tela vazia só com o papel de parede. Aí eu fazia logoff, tentava de novo e entrava.