Autor Tópico: Problemas na resolução  (Lida 4817 vezes)

Offline silvanoprof

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Problemas na resolução
« Online: 04 de Agosto de 2006, 02:21 »
Olá pessoal,

Instalei o ubuntu pela primeira vez , a título de conhecimento, (6.06) - Kubuntu - e todo o processo de instalação ocorreu de maneira satisfatória, porém quando tentei modificar a resolução do vídeo para 800x600 - uso programas que presisam dessa resolução, ao reiniciar o sistema a imagem apareceu deformada (com várias telas ilegíveis) impedindo o uso no modo gráfico....
Existe uma maneira de mudar a resolução usando o modo texto?
Help!

flaviofifa

  • Visitante
Re: Problemas na resolução
« Resposta #1 Online: 04 de Agosto de 2006, 09:16 »
Olá pessoal,

Instalei o ubuntu pela primeira vez , a título de conhecimento, (6.06) - Kubuntu - e todo o processo de instalação ocorreu de maneira satisfatória, porém quando tentei modificar a resolução do vídeo para 800x600 - uso programas que presisam dessa resolução, ao reiniciar o sistema a imagem apareceu deformada (com várias telas ilegíveis) impedindo o uso no modo gráfico....
Existe uma maneira de mudar a resolução usando o modo texto?
Help!


Tem sim cara!!! usa o comando # sudo xorgconf que ele re-detecta todo sobre video!!!

Abraço!

Flávio.
 ;)

Offline augustocmbrito

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: Problemas na resolução
« Resposta #2 Online: 07 de Agosto de 2006, 21:10 »
Boa noite,

e aonde encontro esse xorgconf? Procurei na minha máquina e não o encontrei...  ???

Olá pessoal,

Instalei o ubuntu pela primeira vez , a título de conhecimento, (6.06) - Kubuntu - e todo o processo de instalação ocorreu de maneira satisfatória, porém quando tentei modificar a resolução do vídeo para 800x600 - uso programas que presisam dessa resolução, ao reiniciar o sistema a imagem apareceu deformada (com várias telas ilegíveis) impedindo o uso no modo gráfico....
Existe uma maneira de mudar a resolução usando o modo texto?
Help!


Tem sim cara!!! usa o comando # sudo xorgconf que ele re-detecta todo sobre video!!!

Abraço!

Flávio.
 ;)

Offline arsolto

  • Usuário Ubuntu
  • *
  • Mensagens: 625
  • Alea Jacta Est
    • Ver perfil
    • Por Ofício
Re: Problemas na resolução
« Resposta #3 Online: 07 de Agosto de 2006, 22:14 »
Ei, augustocmbrito, você pode abrir e editá-lo, no Terminal, através do seguinte comando:

Código: [Selecionar]
sudo gedit /etc/X11/xorg.conf

Piras

  • Visitante
Re: Problemas na resolução
« Resposta #4 Online: 07 de Agosto de 2006, 23:21 »
Talvez seja mais fácil para você, iniciante, voltar a detectar o seu monitor e outros periféricos através do comando

sudo dpkg-reconfigure xserver-xorg

Depois disso, vá respondendo com calma cada uma das perguntas que o programa fizer a você. Na dúvida, tecle ENTER que o programa salvará as opções default (preferenciais). Quando chegar o momento do reconhecimento do monitor, use a tecla TAB para marcar com x as suas opções preferidas. Você pode manter somente a resolução de sua preferência. Concluída a configuração, você sairá do programa automaticamente. Para testar a nova resolução de vídeo aperte as teclas Ctrl+Alt+Backspace. Tenha paciência, pois a tela de prompt pode demorar alguns segundos antes de devolvê-lo ao GDM (gerenciador de login do Gnome). Agora, é conferir se a nova resolução já está funcionando. Se não for o caso, faça o ajuste em Sistema>Preferências>Resolução de Tela.

Offline augustocmbrito

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: Problemas na resolução
« Resposta #5 Online: 10 de Agosto de 2006, 21:08 »
Segue resultado do comando sugerido:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
   Option      "XkbVariant"   "abnt2"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Generic Video Card"
   Driver      "vesa"
   BusID      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-51
   VertRefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Generic Video Card"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

Ei, augustocmbrito, você pode abrir e editá-lo, no Terminal, através do seguinte comando:

Código: [Selecionar]
sudo gedit /etc/X11/xorg.conf

Offline augustocmbrito

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: Problemas na resolução
« Resposta #6 Online: 10 de Agosto de 2006, 21:10 »
Segue mensagem recebida ao executar o comando sugerido:

Nenhum servidor X é conhecido para seu hardware.
                                                                                                                       │
Ou você não possui hardware de vídeo instalado nesta máquina (somente console serial ?) ou o programa "discover" não foi capaz de determinar qual servidor X é apropriado para seu hardware de vídeo. Isto pode ser devido a informação incompleta na base de dados do discover ou pode ser que seu hardware de vídeo simplesmente não seja suportado por nenhum servidor X disponível.                                                                                       

Talvez seja mais fácil para você, iniciante, voltar a detectar o seu monitor e outros periféricos através do comando

sudo dpkg-reconfigure xserver-xorg

Depois disso, vá respondendo com calma cada uma das perguntas que o programa fizer a você. Na dúvida, tecle ENTER que o programa salvará as opções default (preferenciais). Quando chegar o momento do reconhecimento do monitor, use a tecla TAB para marcar com x as suas opções preferidas. Você pode manter somente a resolução de sua preferência. Concluída a configuração, você sairá do programa automaticamente. Para testar a nova resolução de vídeo aperte as teclas Ctrl+Alt+Backspace. Tenha paciência, pois a tela de prompt pode demorar alguns segundos antes de devolvê-lo ao GDM (gerenciador de login do Gnome). Agora, é conferir se a nova resolução já está funcionando. Se não for o caso, faça o ajuste em Sistema>Preferências>Resolução de Tela.

Offline augustocmbrito

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: Problemas na resolução
« Resposta #7 Online: 11 de Agosto de 2006, 22:32 »
Pessoal! Boas noticias!

Com relação ao meu problema com a resolução, eu segui os seguintes passos:

* adicionei as linhas abaixo na seção "Monitor" do meu xorg.conf:

        HorizSync       30-80
        VertRefresh     56-76


* incluí a resolução abaixo em todas as linhas Display da seção Screen, antes da resolução "1024x768", mantendo o espaço entre elas:

"1280x1024"


E agora tá tudo do jeito que eu gosto!  ;D

Caso tenham problemas com resolução, tentei estes passos (nem precisei configurar minha placa de vídeo!).

Abração à todos e um ótimo final de semana!

 :)

Offline carloslyrio

  • Usuário Ubuntu
  • *
  • Mensagens: 52
    • Ver perfil
Re: Problemas na resolução
« Resposta #8 Online: 13 de Novembro de 2006, 11:50 »
É Augusto, vou ver se estas modificações resolvem meus problemas por aqui...
carloslyrio