Autor Tópico: Área de Trabalho do 11.10 sumiu  (Lida 10589 vezes)

Offline Ioca100

  • Usuário Ubuntu
  • *
  • Mensagens: 2.848
  • Rio,Brasil
    • Ver perfil
Re: Área de Trabalho do 11.10 sumiu
« Resposta #15 Online: 12 de Novembro de 2011, 15:03 »
"utilizei o comando unity --replace"

Use   unity --reset.
Usuário Linux- 449417

Offline Kadu_tbj

  • Usuário Ubuntu
  • *
  • Mensagens: 226
  • Busque a DEUS enquanto se pode achar...
    • Ver perfil
    • Obedecendo ao Chamado do Mestre
Re: Área de Trabalho do 11.10 sumiu
« Resposta #16 Online: 26 de Novembro de 2011, 02:49 »
Será que terei de reinstalar o sistema!!!!!!!
Se alguém puder me ajudar!!!!!!!

Cara depois que vc der o comando unity --reset vc também deve dar o comando unity --reset-icon

Vou te passar aqui uma informacao para que o seu compiz fique 100%

leia abaixo:

Beleza galera? É o poder!

Muitas pessoas me perguntam no twitter como disponibilizar os mesmos recursos no Unity que funcionavam sem problemas no Gnome. Na verdade todos nós temos que enteder que o Compiz trabalha com recusos e plugins independentes do outro, e por isso que muitos podem prejudicar e conflitar alguns que ja se encontram ativos, conflitos que podem acontecer, e questoes como do Desktop Wall e Cubo.

Eu descobri que na verdade o que existe é um BUG para aplicar na sessão do compiz, existe algum problema na compilação desta versão que o mesmo quando sofre uma reinicialização do compiz, ele se perde. O que acontece é que o Unity possui as mesmas propriedades e base do compiz e do próprio Gnome, sendo baseado em ambos, pois ao aplicar cada plugin no compiz, ele sofre uma reinicialização e faz com que o gerenciador de janelas de fundos, que ja possui os seus próprios recursos, entram em conflitos com bibliotecas e ate mesmo com o binário que auto-executa o compiz.

O procedimento é assim, primeiramente o protocolo X11 é carregado, sendo disponibilizado o servidor X e todas as suas bibliotecas e recusos, depois é aplicado e inicializado o desktop padrão, quem antes era o gnome-session e agora é o unity, após, alguns outros recursos do systray como applets, gadges, plugins que podem ser aplicados no Unity e então o compiz, que sempre é carregado para ” decorar” todo o seu desktop. Eu cansei de nas primeiras versões do Ubuntu e ate mesmo no Debian, distro que usei durante anos e anos, carregar o compiz, manualmente com o comando compiz –replace, mesmo após o dekstop ser carregado, ou seja, o gnome-session. E isso tudo dentro de um gnome-terminal!!

Xorg -> gnome-session (ou) unity -> compiz -> compiz plugins

Mas e se habilitarmos então o Compiz no Unity no Ubuntu 11.04, o que vai acontecer? Sim, é isso ai, vai cag#$@% tudo! Sem problemas… é possível habilitar sim o compiz com todos os seus efeitos sem problemas nenhum, mesmo que vc veja temporariamente o seu unity ser destruído.

Vamos aos procedimentos:

RECOMENDO QUE VC CRIE UMA CONTA DE USUÁRIO SOMENTE PARA TESTE, LEMBRAMOS QUE ESSA CONTA DE USUÁRIO PRECISA ESTAR NO GRUPO admin, audio e cdrom, pois o que acontecer no Unity, vai ser naquela conta de usuário, pois cada user possui o seu ~HOME/.config.

1. Vamos verificar se o pacote do compiz esta instalado, se não, digite:

dpkg -l | grep compizconfig-settings-manager

Se não for encontrado, vamos instalar: sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra -y

Após isso, entre no seu Unity ou se vc ja estiver la, vá no Dash e procure por compiz e entre no seu Config Manager e faça exatamente o que esta abaixo e com calma, e LEMBRE-SE, QUALQUER COISA QUE ACONTEÇA COM A SUA JANELA E TELA, IGNORE, POR MAIS QUE DOA NO SEU CORAÇÃO:

Desabilite os plugins abaixo e ignore os erros:
1. Desabilite o Ubuntu Unity Plugin
2. Desabilite o Desktop Wall
3. Desabilite o OpenGL  (Quando escolher esta opção marque, selecione a sub-opção Disable these plugins)
4. Desabilite o Composite (e não se preocupe, não esqueça de manter a janela aberta mesmo que ela tenha sido completamente destruída).

Habilite os plugins abaixo novamente:
1. Habilite novamente o Composite
2. Habilite novamente o OpenGL
3. Habilite o Desktop Cube
4. Habilite o Rotate Cube
5. Habilite novamente o Animations
6. Habilite o Enhanced Zoom Desktop
7. Habilite o Expo
8. Habilite o Fading Windows
9. Habilite novamente o Ubuntu Unity Plugin (Ao habilitar esta opção, vai ser necessário habilitar sub-opções, recomendo que vc escolha ‘Resolve Conflicts’  na primeira janela, sendo que as opções de conflitos são ’Reveal Mode’ é para o  ’Ubuntu Unity Plugin’, a opção  ’Rotate Flip Left’  para o  ’Rotate Cube’ e  ’Disable Rotate Flip Left’ para o Unity em geral.).

Caramba! Ta tudo sem janela e virou tudo uma bagunça, calma, aquilo que eu te falei, o compiz esta aplicado mas o mesmo não reiniciou o Unity e é necessário que vc reinicie o GDM (Gerenciador de login do GNOME), para que vc garanta que o arquivo ~/.config/ seja novamente carregado junto com a sua sessão do Unity.

Para sair da interface gráfica faça: CONTROL + ALT + F1 (para ir para o terminal 1).

Faça o seu login e digite: sudo /etc/init.d/gdm restart OU sudo service gdm restart

Este comando vai reiniciar o GDM e consequetimente o servidor X, forçando a leitura de TODAS as bibliotecas gráficas novamente.

Seu compiz esta funcionando com o Cubo, pronto, vc pode usar.

È possível também, reiniciar a configuração do Unity com o comando #unity –reset, sendo que pode acontecer de que vc perca o desktop temporariamente, mas na verdade, ele esta zerando suas configurações. Talvez seja necessário vc voltar para o console com o comando CONTROL +  ALT + F1 ou F2 e se logar novamente e digitar sudo /etc/init.d/gdm restart para que o protocolo X e o seu gerenciador de login do GNOME seja novamente reiniciado e suas configurações reiniciadas ao padrão. Caso não aconteça de recuperar a sua interface, vc pode optar pelo procedimento abaixo.

E se o seu Unity for danificado, é possível voltar atras para o padrão de quando eu instalei? SIM! Para este procedimento basta vc remover com o comando rm- rf os diretórios ~/.config , ~/.gconf* , ~/.gnome* E o seu Unity esta lá novinho como se fosse a primeira vez que vc entrou no poderoso Ubuntu (somente em caso de danos e caso vc queira voltar atras)

#rm -rf ~/.config
#rm -rf ~/.gconf*
#rm -rf ~/.gnome*

fonte: http://www.aprigiosimoes.com.br/2011/05/05/compiz-no-unity-ubuntu-11-xx/

Kadu_tbj!Efeito fogo no Ubuntu (compiz)
Notebook Satellite Toshiba L635, UBUNTU 12.04 Unity 64Bits LTS, CORE i5 480M 2.70ghz, HD640, 6G DDR3, HDMI,Bluetooth, Bateria de 6 celulas
Obedecendo ao Chamado do Mestre

Offline rairo

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Área de Trabalho do 11.10 sumiu
« Resposta #17 Online: 28 de Novembro de 2011, 10:18 »
Cara eu estava com esse problema do menu do unity ficar atrás das janelas e isso estava me irritando pacas. Tentei fazer a solução indicada pelo Kadu_tbj, tbm não adiantou.  Então por curiosidade, quando eu tentava reiniciar o compiz pelo terminal aparecia a mensagem de erro
"pixel alguma coisa", sem querer abrir a configuração e pesquisei "pix" aí apareceu a opção "COPY TO TEXTURE" , ela estava desmarcada, marquei a opção e adivinhem? O menu do unity voltou ao normal...

Brodovisk

  • Visitante
Re: Área de Trabalho do 11.10 sumiu
« Resposta #18 Online: 28 de Novembro de 2011, 13:31 »
Caso errou as configurações do compiz você pode restaura-las como padrão excluindo as seguintes pastas dentro do seu usuário.
1º Dê um "ls -a" para mostrar os arquivos ocultos;
Dependendo da versão do ubuntu pode usar estes comandos(isso é se o arquivo da configuração existe no usuário ), caso falhar é pq não tem ,então olhe se tem antes de tentar exclui-lo;
rm -rf .config
rm -rf .gconf*
rm -rf .gnome*
rm -rf .gconf/apps/compiz*
rm -rf .cache/compizconfig-1/
rm -rf .config/compiz-1/
rm -rf .compiz*
Vai voltar ao padrão enh!
Abração.