Autor Tópico: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10  (Lida 16332 vezes)

Offline sugestivo

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Online: 21 de Novembro de 2011, 22:08 »
Pessoal,

Preciso da ajuda de vocês.
Estou usando uma versão do WOW que não precisa de instalação,
baixado por torrent, que já usava bastante na minha época de Windows, sem problemas
Eu até consegui executar algumas vezes o jogo, com gráficos satisfatórios até,
porém, em todas as vezes, o jogo trava de maneira inesperada (às vezes na tela de login),
e o Ubuntu trava junto, não consigo sair do jogo, e acabo reiniciando o sistema.
Só que agora nem isso tá funcionando, clico no executável do jogo e a tela fica cinza, e trava do mesmo jeito.
Já procurei tutoriais, aqui no fórum e em outros, de como configurar o Wine e o WOW pra rodar perfeitamente,
e nada funcionou. Já reescrevi o conf dentro da pasta WTF, mas nada... já adicionei o sufixo "-opengl" ao executável,
já configurei muitas coisas e nada.
Alguém sabe como fazer isso funcionar??


Abraço

Offline nomade

  • O negócio não tem alma
  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.186
  • O negócio não tem alma
    • Ver perfil
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #1 Online: 23 de Novembro de 2011, 03:37 »
Tenta instalar o WOW pelo palyonlinux com a versão oficial do jogo (lembre-se que deve ser de acordo com o idioma desse aí que você baixou EnGB, EnUs ou espanhol [geralmente EnGB funciona com qualquer versão em inglês]). quando ele começão a atualizar você para a atualização e subistitui todo o jogo do diretório onde está instalado por esse que você baixou.

Aqui funcionou na boa...
Debian 11 Bullseye KDE + Kernel Liquorix

Offline sugestivo

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #2 Online: 23 de Novembro de 2011, 22:51 »
Massa, gostei da ideia!
Vou tentar amanhã e depois posto aqui o resultado!
Não sabia que dava pra mudar o diretório e ludibriar o jogo assim, hehe

Offline Gabr1990

  • Usuário Ubuntu
  • *
  • Mensagens: 85
  • @Gabr1990
    • Ver perfil
    • Mente Abduzida
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #3 Online: 25 de Novembro de 2011, 12:49 »
É algum servidor private?

Se sim, tu pode fazer o seguinte:
Instalar o jogo original via wine/playonlinux, fazer as atualizações até a versão necessária para jogar no servidor private, fechar o launcher, e então abrir o arquivo localizado em:

/World of Warcraft/Data/enUS/realmlist.wtf

Então você pode abrir este arquivo,e remover o IP do jogo original, e colocando o IP do servidor em que você vai jogar no lugar dele.
Pronto! Lembrando que para jogar, no lugar de abrir o launcher do jogo, tu vai ter de abrir diretamente o client do jogo "wow.exe" quando quiser jogar.

No Ubuntu 11.10 ficou pesado rodar World of Warcraft no meu computador, agora que vai ser lançado o servidor oficial do World of Warcraft brasileiro, migrei de volta para o Ubuntu 10.04, onde a performance é bem superior para jogar o game, enquanto não sai o lançamento, estou relembrando o jogo jogando em um server private.

 ;)
Conteúdo interessante e bom humor: http://menteabduzida.net/ :D

Offline nomade

  • O negócio não tem alma
  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.186
  • O negócio não tem alma
    • Ver perfil
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #4 Online: 25 de Novembro de 2011, 17:01 »
Na verdade é justamente oq ue eu disse, só que em vez de esperar fazer o download de todo o jogo novamente é só substituir os arquivos do jogo pelo que ele já baixou... se além disso ele deixar atualizar, vai economizar tempo, pois o jogo funciona da mesma maneira.

Citar
É algum servidor private?

Se sim, tu pode fazer o seguinte:
Instalar o jogo original via wine/playonlinux, fazer as atualizações até a versão necessária para jogar no servidor private, fechar o launcher, e então abrir o arquivo localizado em:

/World of Warcraft/Data/enUS/realmlist.wtf?

Depende do server... alguns tem o próprio lançador como o "wowbeez", por exemplo, no qual não é necessário alterar a relmlist nem mesmo substituir o wow.exe, só executar pelo wowbezz.exe, que deve ser colocado dentro do diretório do jogo... o wowbeez  é um dos melhores servers privates e vai até o Cataclysm 4.2 (um dos poucos). Dessa forma você mantém o jogo "original".
Debian 11 Bullseye KDE + Kernel Liquorix

Offline sugestivo

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #5 Online: 26 de Novembro de 2011, 20:12 »
Então, ainda estou baixando um torrent com o instalador do WOW 3.3.5 (linch king)
mas estou jogando no molten, nem conhecia esse wowbee! Vou fazer um teste

Offline sugestivo

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #6 Online: 01 de Dezembro de 2011, 18:39 »
Po, como instala o WOW Lich King pelo "PlayonLinux"??
Eu tento instalar e ele pede pra eu instalar o Burning Crusade antes!
Já estou com o instalador, mas é o instalador do Lich King

Offline nomade

  • O negócio não tem alma
  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.186
  • O negócio não tem alma
    • Ver perfil
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #7 Online: 02 de Dezembro de 2011, 00:22 »
Você tem que baixar o "WoW-4.0.0-WoW-enUS-Installer.exe" (tem no site baixaki http://www.baixaki.com.br/download/world-of-warcraft.htm),  instale pelo playonlinux (não importa se no playonlinux não aparece o patch que você vai instalar, use o que estiver disponível), depois rode o lançador e deixar atualizar até o 4.2 (vai demorar), só isso... normal... você vai ter o Cataclysm, que tem muito mais coisas e é muito mais maneiro que o Lich King.
Para ter o Litch King, você vai ter que instalar o 4.0.0, dar um jeito de arrumar os arquivos do diretório para o patch Litch King (completos) e clicar em repair, que será feito o downgrade para corrigir o jogo e recomeçar o download da atualização, depois não deixe atualizar (não tenho certeza se isso ainda funciona). Porém eu acho melhor jogar o Cataclysm... sério, procure um server que suporte (já sugeri o wowbeez), é mais vantagem.
Debian 11 Bullseye KDE + Kernel Liquorix

Offline Gabr1990

  • Usuário Ubuntu
  • *
  • Mensagens: 85
  • @Gabr1990
    • Ver perfil
    • Mente Abduzida
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #8 Online: 02 de Dezembro de 2011, 13:22 »
Citar
Você tem que baixar o "WoW-4.0.0-WoW-enUS-Installer.exe" (tem no site baixaki http://www.baixaki.com.br/download/world-of-warcraft.htm),  instale pelo playonlinux (não importa se no playonlinux não aparece o patch que você vai instalar, use o que estiver disponível), depois rode o lançador e deixar atualizar até o 4.2 (vai demorar), só isso... normal... você vai ter o Cataclysm, que tem muito mais coisas e é muito mais maneiro que o Lich King.
Para ter o Litch King, você vai ter que instalar o 4.0.0, dar um jeito de arrumar os arquivos do diretório para o patch Litch King (completos) e clicar em repair, que será feito o downgrade para corrigir o jogo e recomeçar o download da atualização, depois não deixe atualizar (não tenho certeza se isso ainda funciona). Porém eu acho melhor jogar o Cataclysm... sério, procure um server que suporte (já sugeri o wowbeez), é mais vantagem.

Olá amigo. Bom, eu estava jogando em um servidor private na versão Lich King (3.3.5), e resolvi instalar o World of Warcraft Oficial, esse Starter Edition, a instalação correu sem problemas, mas quando vou atualizar, o launcher dá crash:

http://i43.tinypic.com/1r6ct0.png

Alguma sugestão para que eu consiga fazer a atualização via launcher?
Conteúdo interessante e bom humor: http://menteabduzida.net/ :D

Offline sugestivo

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #9 Online: 02 de Dezembro de 2011, 19:05 »
nomade, gostei da sua sugestão!
criei minha conta no wowbeez, e baixei o instalador no baixaki! brigado, cara!
só que tentei instalar pelo "PlayOnLinux" e rola uma coisa meio bizarra, eu uso o wine 1.3.28,
e o "PlayOnLinux" tenta fazer um downgrade do wine pra versão 1.2... até aí tudo bem,
mas quando começa a instalação, além de dizer que meu CPU não tem a velocidade necessária,
o instalador trava.

Vou tentar instalar pelo wine normal mesmo, com dois cliques no instalador, acho que não tem problema né!

Eu estou usando o ubuntu 11.10 num dell core i5, com 4096 de RAM e 640 de HD, com 2.3 Ghz de processador!
Isso é devagar? Ou é pála do wine?

Offline sugestivo

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #10 Online: 02 de Dezembro de 2011, 21:16 »
Gabr1990, mesma coisa aqui cara!
Fiz como o nomade disse, baixei o instalador no baixaki, comecei a instalar
e exatamente como na sua print, ocorre exatamente o mesmo erro... e nunca finaliza a atualização do jogo.

nomade, você teve esse problema?
como conseguiu contornar??

Offline RxDx

  • Usuário Ubuntu
  • *
  • Mensagens: 409
  • RxDx
    • Ver perfil
    • RxDx
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #11 Online: 04 de Dezembro de 2011, 11:02 »
Instala no Windows, dai é só copiar o diretório (pasta) e rodar pelo wow.exe.
Notebook: Dell Vostro 1320 | Core 2 Duo P8600 @ 2.4ghz | 4GB DDR2 | nVidia GeForce 9300m GS.

Offline Gabr1990

  • Usuário Ubuntu
  • *
  • Mensagens: 85
  • @Gabr1990
    • Ver perfil
    • Mente Abduzida
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #12 Online: 04 de Dezembro de 2011, 18:42 »
Citar
Instala no Windows, dai é só copiar o diretório (pasta) e rodar pelo wow.exe.

Foi a única solução que encontrei por enquanto, infelizmente tive que botar o VirtualBox pra funcionar.  :(
Conteúdo interessante e bom humor: http://menteabduzida.net/ :D

Offline nomade

  • O negócio não tem alma
  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.186
  • O negócio não tem alma
    • Ver perfil
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #13 Online: 04 de Dezembro de 2011, 21:01 »
sugestivo,

Citar
nomade, gostei da sua sugestão!
criei minha conta no wowbeez, e baixei o instalador no baixaki! brigado, cara!
só que tentei instalar pelo "PlayOnLinux" e rola uma coisa meio bizarra, eu uso o wine 1.3.28,
e o "PlayOnLinux" tenta fazer um downgrade do wine pra versão 1.2... até aí tudo bem,
mas quando começa a instalação, além de dizer que meu CPU não tem a velocidade necessária,
o instalador trava.

Realmente se há uma coisa que devemos estabelecer é que seu processador não é lento, rsrsrsrs... eu rodei o WOW Cataclysm no ubuntu 10.10 64-bits, com um celeron 430 (1.8 Ghz) e uma placa e video onboard GMA 950 da intel, só que não usei o playonlinux, fiz como você disse que iria tentar, instalei pelo wine direto e funcionou. só que para o lançador funcionar e funcionar a atualização, você tem que ir no diretório do jogo clicar com esquerda no laucher, ir na aba permissões e marcar a caixa permitir execução como programa e rodar o laucher direto por lá. Depois se quiser eu posto como criar atalhos para programas do wine na área de trabalho.

Acho que respondi a pergunta do Gabr1990 também, certo?
Qualquer dúvida, estamos aí!

Obs.: O ubuntu de vocês é 64 ou 32-bits? O sistema 64-bits dá um ganho de desempenho considerável em se tratando de usar o wine. Eu já fiz testes e constatei que faz muita diferença, tinham jogos que nem abriam no 32-bits e no 64-bits funcionaram tranquilamente. Observem isso. Se querem desempenho, 64-bits é mais recomendado.

Um abraço

« Última modificação: 04 de Dezembro de 2011, 21:09 por nomade »
Debian 11 Bullseye KDE + Kernel Liquorix

Offline sugestivo

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
Re: Frustração ao rodar WOW no Wine 1.3.28 do Ubuntu 11.10
« Resposta #14 Online: 05 de Dezembro de 2011, 13:19 »
Nomade, não funcionou cara!
Aqui estou usando o 11.10 64bits!
Eu fui na pasta e escolhi o arquivo "launcher.exe", fui na aba permissões
e já estava marcada a opção de "executar como programa"
vou fazer como falaram, com o virtualbox, mas me dá uma preguiça instalar o windows..


Abraço!
« Última modificação: 05 de Dezembro de 2011, 20:50 por sugestivo »