Autor Tópico: Script não inicia com o Ubuntu 10.04  (Lida 3705 vezes)

Offline maxsequeira

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Script não inicia com o Ubuntu 10.04
« Online: 27 de Maio de 2010, 09:53 »
Olá pessoal, instalei o ubuntu 10.04 em um pc, preciso rodar um script na inicialização, q roda 2 programas em java e inicia o tomcat.
Tenho o script pronto, pois ja fiz isso em outro micro com ubuntu 9.04, e ele roda tranquilo quando executo via terminal, porém não tem santo q faça ele executar junto com a inicialização do sistema.

Alguem pode me dar uma luz?


Offline jeflui

  • Usuário Ubuntu
  • *
  • Mensagens: 745
    • Ver perfil
Re: Script não inicia com o Ubuntu 10.04
« Resposta #1 Online: 27 de Maio de 2010, 20:30 »
Você poderia ter falado o que já fez e não deu certo.
Vai em Sistema > Preferências > Sessões
E adicione o script, lembre de deixar ele com permissão de execução

Offline maxsequeira

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Script não inicia com o Ubuntu 10.04
« Resposta #2 Online: 28 de Maio de 2010, 09:35 »
Eu ja fiz isso o/
Não rola!

E também ja tentei colocar no init.d e nada ...

Offline pedrotf

  • Usuário Ubuntu
  • *
  • Mensagens: 126
    • Ver perfil
Re: Script não inicia com o Ubuntu 10.04
« Resposta #3 Online: 28 de Maio de 2010, 09:44 »
Eu ja fiz isso o/
Não rola!

E também ja tentei colocar no init.d e nada ...

Veja se tem permissões para rodar o script.

Se não tiver permissões basta colocar

Código: [Selecionar]
sudo chmod +x script

Offline jeflui

  • Usuário Ubuntu
  • *
  • Mensagens: 745
    • Ver perfil
Re: Script não inicia com o Ubuntu 10.04
« Resposta #4 Online: 28 de Maio de 2010, 11:01 »
Depois de colocar no init.d com permissão de execução
Comando:
Código: [Selecionar]
update-rc.d /etc/init.d/seu_script defaults

Darcamo

  • Visitante
Re: Script não inicia com o Ubuntu 10.04
« Resposta #5 Online: 28 de Maio de 2010, 16:06 »
Interessante. Também tenho o mesmo problema, mas é um script que deve ser rodado após logar como usuário normal (é para mudar algumas coisas com xmodmap) então colocar no rc.local não serve. Funcionava perfeitamente no 9.10, mas depois que atualizei para a versão 10.04 ele parou de ser exevutado quando logo (está sim em "Aplicativos de Sessão" e tem permissão de execução).

Se executá-lo no terminal ele funciona normalmente.


Offline jeflui

  • Usuário Ubuntu
  • *
  • Mensagens: 745
    • Ver perfil
Re: Script não inicia com o Ubuntu 10.04
« Resposta #6 Online: 28 de Maio de 2010, 16:37 »
se colocar no .profile dele ou .bashrc não rola será?

Offline marceloeng

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Script não inicia com o Ubuntu 10.04
« Resposta #7 Online: 24 de Novembro de 2011, 13:29 »
Boa tarde...

Querendo aproveitar o tópico...

Estou desesperado, pois não consigo fazer inicair de forma automática um script que criei.

Já fiz de tudo e ele não inicializa...
sudo chmod +x script
update-rc.d /etc/init.d/seu_script defaults

Tenho sempre que fazer de forma manual (./script)

conteúdo do script:
Código: [Selecionar]
#! /bin/sh
### INICIAR SYBASE
dbsrv9 -c 4000M -n srvcontabil -ud -o /contabil/log/logservidor.txt /contabil/dados/contabil.db


Se alguém puder ajudar, agradeço muito.

Abraços,
Marcelo
« Última modificação: 05 de Dezembro de 2011, 11:52 por marceloeng »