Autor Tópico: Internet via rádio - criar conexão pppoe: nunca consegui  (Lida 17186 vezes)

Offline rangelsrn

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
    • @rangelsrn
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #15 Online: 19 de Dezembro de 2011, 00:18 »
É, mas eu precisava que vc mantivesse a conexão via pppoeconf, e repetisse os comandos que eu pedi lá em cima.

É assim que podemos avaliar se vc realmente está sem conexão, ou apenas a conexão não está configurada corretamente.
Certo. Como está a configuração do seu Ubuntu agora? Pode colar o resultado dos comandos abaixo?

cat /etc/network/interfaces

ifconfig -a

cat /etc/resolv.conf

route -n


Ah, foi mal... então eu vou fazer isso novamente e ver as configurações após configurar o pppoe. Mas após fazer isso, vou ter que devolver o arquivo pra forma anterior pra que eu volte a me conectar novamente e te responder aqui no tópico (aff... fui redundante agora. hehehe).
Não existe trabalho ruim. O ruim é ter que trabalhar.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #16 Online: 19 de Dezembro de 2011, 00:30 »
Vc já viu como se faz, quem faz um cesto faz um cento. ;)
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline rangelsrn

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
    • @rangelsrn
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #17 Online: 21 de Dezembro de 2011, 00:11 »
zekkerj, parceirão,

Refiz os comandos todos que você me pediu e, logo abaixo, estou colando o resultado. Lembrando que o arquivo /etc/network/interfaces, após todos os procedimentos, eu o restaurei para o original, pra voltar a conexão (outra vez eu sendo redundante. rsrs).

Segue o conteúdo:

servidor@servidor:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback


auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig wlan0 up # line maintained by pppoeconf
provider dsl-provider


auto wlan0
iface wlan0 inet manual

---------------------------

servidor@servidor:~$ ifconfig -a
eth0      Link encap:Ethernet  Endereço de HW 00:0f:ea:df:31:69 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          IRQ:23 Endereço de E/S:0x4000

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:20 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:20 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:1200 (1.2 KB) TX bytes:1200 (1.2 KB)

wlan0     Link encap:Ethernet  Endereço de HW 00:05:9e:83:54:2c 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

---------------------------

servidor@servidor:~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 171.10.2.1
nameserver 201.18.34.214
nameserver 201.18.34.213
# NOTE: the libc resolver may not support more than 3 nameservers.
# The nameservers listed below may not be recognized.
nameserver 8.8.8.8

---------------------------

servidor@servidor:~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 171.10.2.1
nameserver 201.18.34.214
nameserver 201.18.34.213
# NOTE: the libc resolver may not support more than 3 nameservers.
# The nameservers listed below may not be recognized.
nameserver 8.8.8.8
servidor@servidor:~$ route -n
Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface

---------------------------

Estarei aguardando o seu auxílio novamente. Mais uma vez, obrigado.
Não existe trabalho ruim. O ruim é ter que trabalhar.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #18 Online: 21 de Dezembro de 2011, 08:50 »
OK. Conecte-se da forma que consegue, execute os comandos abaixo e cole o resultado aqui.

iwconfig wlan0
nm-tool


Passou-me uma coisa pela cabeça agora; pode ser que o que vc tenha no Windows não seja um discador, e sim um cliente VPN. Isso explicaria o motivo da gente não conseguir reproduzir a conexão pppoe.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline rangelsrn

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
    • @rangelsrn
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #19 Online: 22 de Dezembro de 2011, 01:32 »
OK. Conecte-se da forma que consegue, execute os comandos abaixo e cole o resultado aqui.

iwconfig wlan0
nm-tool


Passou-me uma coisa pela cabeça agora; pode ser que o que vc tenha no Windows não seja um discador, e sim um cliente VPN. Isso explicaria o motivo da gente não conseguir reproduzir a conexão pppoe.

Parceiro, aqui está o resultado dos comandos:

servidor@servidor:~$ iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"solarnet-SC" 
          Mode:Managed  Frequency:2.417 GHz  Access Point: 00:02:6F:4D:B6:06   
          Bit Rate=48 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-38 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

servidor@servidor:~$ nm-tool

NetworkManager Tool

State: connected

- Device: wlan0  [Auto solarnet-SC] --------------------------------------------
  Type:              802.11 WiFi
  Driver:            rt61pci
  State:             connected
  Default:           yes
  HW Address:        00:05:9E:83:54:2C

  Capabilities:
    Speed:           48 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    solar-03:        Infra, 00:15:6D:7E:C5:B0, Freq 2462 MHz, Rate 11 Mb/s, Strength 37
    SANRANET-D:      Infra, 00:15:6D:67:AB:71, Freq 2437 MHz, Rate 54 Mb/s, Strength 40
    solarnet-SC2:    Infra, 00:0C:42:1F:A5:13, Freq 2432 MHz, Rate 11 Mb/s, Strength 68
    *solarnet-SC:    Infra, 00:02:6F:4D:B6:06, Freq 2417 MHz, Rate 54 Mb/s, Strength 100

  IPv4 Settings:
    Address:         171.10.2.80
    Prefix:          24 (255.255.255.0)
    Gateway:         171.10.2.1

    DNS:             171.10.2.1
    DNS:             201.18.34.214
    DNS:             201.18.34.213
    DNS:             8.8.8.8


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            via-rhine
  State:             unavailable
  Default:           no
  HW Address:        00:0F:EA:DF:31:69

  Capabilities:
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Properties
    Carrier:         off

Como seria uma conexão VPN? Lembro que, no ruindows, eu criava a conexão pppoe.

Abraços.
Não existe trabalho ruim. O ruim é ter que trabalhar.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #20 Online: 22 de Dezembro de 2011, 03:09 »
É, mas não há conexão, não estamos conseguindo ativar o pppoe. Seria bom confirmar com o provedor o procedimento pra Linux.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline rangelsrn

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
    • @rangelsrn
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #21 Online: 22 de Dezembro de 2011, 22:55 »
É, mas não há conexão, não estamos conseguindo ativar o pppoe. Seria bom confirmar com o provedor o procedimento pra Linux.

Ih, ferrou então! Os caras são péssimos, eles mal sabem se virar com o ruindows, veja lá com o Linux. Certa vez até os questionei, e eles afirmaram que não sabiam mexer com o Linux e não tinham suporte pro sistema.

Agora lascou? Eu não quero voltar esse pc aqui pro Ruindows nem a pau. Outras pessoas usam o micro e a dor de cabeça que eu voltarei a ter deixando o pc com ruindows dando pau o tempo inteiro, é de lascar. :S

E agora? Que encruzilhada. rsrs
Não existe trabalho ruim. O ruim é ter que trabalhar.

Offline phaleixo

  • Usuário Ubuntu
  • *
  • Mensagens: 369
  • No meio da dificuldade encontra-se a oportunidade.
    • Ver perfil
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #22 Online: 22 de Dezembro de 2011, 23:09 »
tente desta forma:http://ubuntuforum-br.org/index.php?topic=70087.0
aqui nunca falhou
No meio da dificuldade encontra-se a oportunidade.

Offline rangelsrn

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
    • @rangelsrn
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #23 Online: 23 de Dezembro de 2011, 00:21 »
tente desta forma:http://ubuntuforum-br.org/index.php?topic=70087.0
aqui nunca falhou

phaleixo, valeu pelo toque. Vou testar aqui e depois posto o resultado. Valeu!
Não existe trabalho ruim. O ruim é ter que trabalhar.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #24 Online: 23 de Dezembro de 2011, 11:34 »
::) não esqueça o galho de arruda.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline phaleixo

  • Usuário Ubuntu
  • *
  • Mensagens: 369
  • No meio da dificuldade encontra-se a oportunidade.
    • Ver perfil
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #25 Online: 25 de Dezembro de 2011, 10:12 »
::) não esqueça o galho de arruda.
Cara,voce é estranho...
No meio da dificuldade encontra-se a oportunidade.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #26 Online: 25 de Dezembro de 2011, 12:25 »
Você nem faz idéia do quanto... pq eu ainda não entendo como apagar o arquivo e configurar de novo, com os mesmos comandos, pode resolver a questão.

Há uma frase atribuída a Einstein que diz que "Loucura é esperar resultados diferentes, quando você fez tudo exatamente igual".

Como na informática há poucas coisas impossíveis, eu não duvido que vc tenha conseguido por sua interface a rádio pra funcionar com essa mandinga. Tenho até uma explicação pra isso. Aliás, uma não, duas. A primeira, sorte. Por isso recomendei o galho de arruda, ele aumenta a sorte. Quem sabe com ele você não consegue por sua interface pra funcionar com menos repetições do mantra "apaga, reconfigura, apaga, reconfigura"?

A outra, de que o configurador tem um bug que faz com que ele interrompa a configuração antes de estar completa. Assim, quando você repete a configuração, ele prossegue do ponto onde parou (ou algum efeito colateral faz com que o erro não se repita, ou pior, o erro não é determinístico, e por isso, a repetição das tentativas faz com que em uma das vezes o processo consiga ir até o fim).

Se for esta a explicação, então tenho más notícias para você: os bugs não permanecem para sempre, mais cedo ou mais tarde são corrigidos, mas muitas vezes a correção de um bug cria novos bugs. E qualquer procedimento que era baseado num comportamento imprevisto causado por um bug torna-se, ele também, um bug.

Eu não quero ser e não sou o dono da verdade. Mas isso não me impede de procurar incansavelmente por ela.
« Última modificação: 25 de Dezembro de 2011, 12:41 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline rangelsrn

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
    • @rangelsrn
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #27 Online: 27 de Dezembro de 2011, 00:29 »
tente desta forma:http://ubuntuforum-br.org/index.php?topic=70087.0
aqui nunca falhou



Cara, que tipo de bruxaria é essa? hauahauahauahuahauahauahauahauahauahua

Fiz todo o procedimento. No final, o arquivo /etc/network/interfaces ficou totalmente em branco. Lembrando que, no tutorial que você me pediu, pede pra configuar o sudo normalmente ao reiniciar o pc após a exclusão do arquivo interfaces, eu não usei o comando sudo pppoeconfig e sim o comando que o zakkerj me sugeriu: sudo pppoeconf wlan0. Depois de configurado o pppoe e excluído outra vez o arquivo interfaces, reiniciei o pc, selecionei a minha rede (nunca inicia com a rede correta) e me conectei através do comando sudo pon -dsl provider. Minha conexão voou. Fiz o teste ao acessar um site de vídeos, e um mesmo vídeo de 13mb, conectado pelo comando que citei anteriormente, baixei em 10min numa velocidade que variava entre 50 e 100kbps, não menos ou mais. Desconectei com o comando sudo poff e me conectei como fazia antes, através da página inicial do ip da minha rede, digitando login e senha. Fui fazer o download do mesmo vídeo. A página demorou bem mais pra processar (no download rápido, quando eu abria a página, ela já iniciava com o vídeo executando... hehehe) e quando, enfim, pude fazer o download dele, a velocidade variava entre 14 e 15kbps (ô triste realidade esta minha... hauahauahaua) e marcava que demoraria uns 35min. Daí pra mais.

Beleza, por mim, ótimo. Não me incomodo em conectar usando o comando sudo pon -dsl provider. Mas não há um jeito deste comando "se auto-executar" quando o Ubuntu inicia com os outros usuários? Apenas eu sou usuário administrativo, e os outros usuários não poderão utilizar este comando por ser sudo e não terem a senha deste pc, que é servidor. Tá, o comando se auto-exectuar já é demais, exagerei nisso, hehehe, mas não há como o pc iniciar conectado com esta conecção maravilhosa e abençoada que nem parece a que eu sempre tive? Seria ótimo, porque eu distribuo internet deste pc para outros micros clientes.

Por conta disso, não vou colocar o tópico como [resolvido], pois não vou desistir de conseguir botar esta conexão pra iniciar automaticamente com o Ubuntu. hehehe

Ah, e antes que eu me esqueça, eu já sabia que o Linux faz maravilhas com a internet. Mas isto que ele fez com a minha conexão, que é uma droga aqui na cidade inteira, não foi maravilha não, foi milagre. Mais uma vez repito: Que raio de bruxaria é essa? hauahauahauahua

Abração. E obrigado também, é claro!
Não existe trabalho ruim. O ruim é ter que trabalhar.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #28 Online: 27 de Dezembro de 2011, 03:27 »
Agora eu pergunto: o que resolveu? Essa punh... desculpem. Ladainha... de configurar e apagar de novo, ou simplesmente usar o comando "sudo pon dsl-provider"?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline phaleixo

  • Usuário Ubuntu
  • *
  • Mensagens: 369
  • No meio da dificuldade encontra-se a oportunidade.
    • Ver perfil
Re: Internet via rádio - criar conexão pppoe: nunca consegui
« Resposta #29 Online: 27 de Dezembro de 2011, 11:51 »
rangelsrn que bom que funcionou para conectar automaticamente
abra o gedit e cole isto
Código: [Selecionar]
sleep 30 && gksudo pon dsl-provider salve como qualquer_nome  na sua pasta pessoal
clique com botao direito no arquivo va em propriedades>permissoes  e marque como executavel
va em configuracoes de sistema>aplicativos de sessão>adicionar e escolha este arquivo que voce criou
o comando sleep serve para atrasar(neste caso 30 segundos) a conexão e voce pode adequar conforme necessario
é só mudar e tempo para 20,10 etc
sem senha é um pouco mais complicado
« Última modificação: 27 de Dezembro de 2011, 15:13 por phaleixo »
No meio da dificuldade encontra-se a oportunidade.