Autor Tópico: Erro de caracter no pacote .deb [RESOLVIDO]  (Lida 1563 vezes)

Offline kitoeag

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Erro de caracter no pacote .deb [RESOLVIDO]
« Online: 13 de Janeiro de 2012, 13:28 »
Boa tarde a todos.

Estou tentando instalar um pacote .deb que baixei do site: http://kproxy.com/servlet/redirect.srv/syku/snqcassrhlgl/p1/projects/piclinux/files/GcBasic-PL/

Quando tendo instalar aparece o seguinte erro:

Código: [Selecionar]
dpkg: erro processando /home/edivaldo/Downloads/gcbasic-pl_0.9_25-11-09-2.deb (--install):
 analisando arquivo '/var/lib/dpkg/tmp.ci/control' prximo  linha 2 pacote 'gcbasic-pl':
 erro na string Verso '0.9_25-11-09-2': caractere invlido no nmero de verso

Já até reinstalei meu Ubuntu 11.04 e nao deu certo. Nao entendo muito, mais acho que tenho que converter os caracteres para o linux. Será? Tem como fazer isso?

Desde já agradeço a atençao de todos.
Obrigado.
« Última modificação: 13 de Janeiro de 2012, 16:24 por kitoeag »

Offline kitoeag

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Erro de caracter no pacote .deb
« Resposta #1 Online: 13 de Janeiro de 2012, 13:41 »

Pessoal, qualquer resposta é bem vinda, estou tentando instalar esse pacote ha duas semanas.
Se alguém souber o caminho que tenho que percorrer, como estudar tal coisa, pode postar ai...

Offline kitoeag

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Erro de caracter no pacote .deb
« Resposta #2 Online: 13 de Janeiro de 2012, 16:05 »
Tentei fazer o seguinte:

Instalei o "Instalador de Pacotes (gdebi)"

Abri o gdebi-gtk e pedi para instalar o pacote. Porém, o mesmo erro apareceu.

Acho que tenho que converter novamente para .deb o arquivo para que a tabela de caracteres sejam compatíveis.

Offline kitoeag

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Erro de caracter no pacote .deb
« Resposta #3 Online: 13 de Janeiro de 2012, 16:17 »
Consegui!  ;D  ;D

Pessoal, consegui resolver o problema.

Instalei um programa chamado "alien" com os seguintes complementos: lintian, lsb-rpm, lzma.

Depois abri o terminal e fiz o seguinte:

1 - Converti o arquivo gcbasic-pl_0.9_25-11-09-2.deb para o formato .tgz. Para isso, usei o comando:
Código: [Selecionar]
sudo alien gcbasic-pl_0.9_25-11-09-2.deb

2 - Deletei o arquivo gcbasic-pl_0.9_25-11-09-2.deb e converti o gcbasic-pl_0.9_25-11-09-2.tgz para .deb novamente. Veja o comando:
Código: [Selecionar]
sudo alien --to-deb gcbasic-pl-0.9_25-11-09.tgz

Depois instalei o arquivo .deb normalmente e tudo funcionou.

Mais informaçoes sobre o aplicativo "Alien" podem ser encontradas no endereço: http://www.vivaolinux.com.br/artigo/Utilizando-o-alien-para-a-conversao-de-pacotes

Gostaria de agradecer a todos pela atençao e até a próxima pessoal.

« Última modificação: 13 de Janeiro de 2012, 16:23 por kitoeag »