Autor Tópico: Como fazer o teclado funcionar em PT-BR ?  (Lida 17806 vezes)

Offline edurm

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Online: 05 de Outubro de 2005, 19:13 »
instalei o Ubuntu aqui, meu teclado eh o americano padrao, detectou perfeitamente. O problema eh que nao consigo fazer as teclas de acento funcinar corretamente


quando eu aperto o acento ele sai automaticamente, nao da para acentuar nada.


Eu instalei o ubuntu em Ingles, serah que so passando para o portugues para resolver isso ?



Obrigado a quem puder me ajudar

Offline edurm

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #1 Online: 05 de Outubro de 2005, 19:26 »
ao usar a pesquisa do forum coloquei meu teclado em US padrao com dead keys


o é o ã ô í


agora está aparentemente certo exceto o  CEDILHA que fica assim:


ć  


ALGUém tem alguma dica ?

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #2 Online: 06 de Outubro de 2005, 14:08 »
Qual a versão do ubuntu que estás utilizando? 5.04?

Tente por este modelo de teclado.
Generic 105-key (Intl) PC

e o layout
US padrao com dead keys
Egg

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #3 Online: 07 de Outubro de 2005, 10:12 »
Tentei a sugestão do .geo. As acentuacões funcionam todas, menos a cedilha, que fica ć. Mais alguma dica? Já tentei várias configuracões, mas sem resultado. :?

Tenho um micro$oft natural; não uso configuracão abnt. Tanto no Kurumin como o rwindow$ uso layout english international, que não existe no Ubuntu.

Qualquer dica será bem-vinda.
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #4 Online: 07 de Outubro de 2005, 12:58 »
procura este layout
U.S. English w/ dead keys

Eu acho que em portugues fica
US padrao sem dead keys (não tenho certeza).

Se não funcionar, copia e cola o texto do arquivo em /etc/X11/xorg.conf
que fica entre de

Section "InputDevice"
...
...
EndSection

E manda pra cá.
Egg

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #5 Online: 07 de Outubro de 2005, 16:36 »
.geo, estou usando, como modelo, generic 105-key (intl) pc, e como layout o que você indica, us english w/ dead keys. Resultado? ć

O trecho do xorg.conf que você pediu é este:

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "keyboard"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us"
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline edurm

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #6 Online: 07 de Outubro de 2005, 21:27 »
cara, sem cedilha fica difícil, vamos ver se algum expert ajuda a gente ae  :wink:

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #7 Online: 18 de Outubro de 2005, 14:30 »
Pessoal, continuo com o mesmo problema: ć!
Alguém, por favor, pode me dizer como fazer c com cedilha?  :?

Abracos!
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #8 Online: 18 de Outubro de 2005, 18:03 »
Perícope,

Faça o seguinte altere o seu xorg.conf

Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us-intl"

Vamos ver o que dá.

Acho estranho uma coisa, aqui no meu micro o xorg está assim:
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "keyboard"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
   Option      "XkbVariant"   "abnt2"
   Option      "XkbOptions"   "abnt2"
EndSection

Não faz muito sentido sendo o meu teclado um us-intl, mas funciona.
O meu layout é U.S. English w/ dead keys
e o modelo é generic 105-key (intl) pc
no configurador do gnome.
Egg

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #9 Online: 19 de Outubro de 2005, 12:15 »
.geo, depois de fazer a alteracão preciso fazer alguma coisa como reiniciar a máquina ou algo assim? Se não precisar, então, a dica não funcionou: ć. Meu layout e teclado são iguais aos seus.

Grato.
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #10 Online: 19 de Outubro de 2005, 13:06 »
Períco,

Tem que reiniciar o X (crtl + alt + backspace).

Pois é, eu já estou ficando sem dicas para lhe dar, vamos ver se aparece alguém com a solução.

Abaixo segue as telas com as configurações do meu teclado.

http://www.integrarerh.com.br/wagner/tela1.png
http://www.integrarerh.com.br/wagner/tela2.png
Egg

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #11 Online: 19 de Outubro de 2005, 14:00 »
Reiniciei, com tudo aberto  :x
Bem, ao reiniciar, a mensagem era que havia diferenca entre a configuracão do gnome e do x; perguntou qual eu escolhia, preferi a do x. Resultado? ććć

Minhas configuracões estavam iguais as suas. Agora o layout é us-intl. Mudei-o para english com teclas mortas, mas nada mudou.

Ao mudar o layout, recebi essa mensagem:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
60802000

If you report this situation as a bug, please include:
- The result of <b>xprop -root | grep XKB</b>
- The result of <b>gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd</b>

Que negócio complicado, sô!
 :cry:
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #12 Online: 19 de Outubro de 2005, 16:24 »
No xorg tu colocou essa configuração?

Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us-intl"

ou essa?

Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
Option "XkbVariant" "abnt2"
Option "XkbOptions" "abnt2"

Se vc tentou essa última, tenta novamente a de cima e faça exatamente o que você fez quando reiniciar e ele dizer que as configurações estão diferentes.

Escolha a do X

Tenta aí, vamos ver.
Egg

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #13 Online: 20 de Outubro de 2005, 11:05 »
Eu coloquei a primeira. Aí aconteceu tudo o que descrevi: aquela mensagem, escolhi a do X, e ććć.
Depois foi que mudei o layout do teclado, para ver se resolvia, mas continua tudo na mesma: ćććć

Mais alguma dica?  :|
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
Como fazer o teclado funcionar em PT-BR ?
« Resposta #14 Online: 20 de Outubro de 2005, 17:47 »
Bom, essa dica não vai falhar.

Faz o seguinte, vira o seu monitor de cabeça para baixo assim o ć vai parecer um pouco com um ç.

To brincando. eheheheh.

A última coisa que eu lembre que você possa fazer é ao invés de escolher a configuraçào do X escolha a do gnome e veja o que acontece.

Depois dessa acho que não tenho mais dicas para lhe dar. Vamos torcer que apareça alguém com alguma dica extra que não conheço.
Egg