Autor Tópico: Problemas com rede sem fio  (Lida 7423 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com rede sem fio
« Resposta #15 Online: 09 de MAR?O de 2012, 12:41 »
Sem problema, é um erro menor que pode ser consertado depois.

Execute os comandos abaixo e cole o resultado aqui.

sudo modprobe -rv b43
sudo modprobe -v b43

dmesg |  tail
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline quantumech

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Problemas com rede sem fio
« Resposta #16 Online: 09 de MAR?O de 2012, 15:17 »

Então... Aí vai:

sudo modprobe -rv b43

Citar
lucas@ubuntu:~$ sudo modprobe -rv b43
[sudo] password for lucas:
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/net/wireless/b43/b43.ko
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/ssb/ssb.ko
rmmod /lib/modules/2.6.32-36-generic/kernel/net/mac80211/mac80211.ko
rmmod /lib/modules/2.6.32-36-generic/kernel/net/wireless/cfg80211.ko
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/leds/led-class.ko
lucas@ubuntu:~$ ^C
lucas@ubuntu:~$

sudo modprobe -v b43

Citar
lucas@ubuntu:~$ sudo modprobe -v b43
insmod /lib/modules/2.6.32-36-generic/kernel/drivers/leds/led-class.ko
insmod /lib/modules/2.6.32-36-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/2.6.32-36-generic/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/2.6.32-36-generic/kernel/drivers/ssb/ssb.ko
insmod /lib/modules/2.6.32-36-generic/kernel/drivers/net/wireless/b43/b43.ko

dmesg |  tail

Citar
lucas@ubuntu:~$ dmesg |  tail
[  217.728280] r8169: eth0: link up
[  260.191469] cfg80211: Calling CRDA to update world regulatory domain
[  260.196669] cfg80211: World regulatory domain updated:
[  260.196674]    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  260.196678]    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  260.196683]    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  260.196686]    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  260.196690]    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  260.196694]    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  260.218636] Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]
lucas@ubuntu:~$

Lucas

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com rede sem fio
« Resposta #17 Online: 09 de MAR?O de 2012, 15:48 »
Certo. Aparentemente sua rede foi ativada; isso deve durar até sua máquina ser reiniciada. Antes de reiniciar a máquina, execute os comandos de teste:

sudo lshw -C network
iwconfig wlan0
ifconfig wlan0
nm-tool
rfkill list wifi


Teste também sua conexão. Depois reinicie sua máquina, e confirme se a rede continua funcionando.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline quantumech

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Problemas com rede sem fio
« Resposta #18 Online: 09 de MAR?O de 2012, 16:06 »

Veja abaixo:

sudo lshw -C network

Citar
lucas@ubuntu:~$ sudo lshw -C network
[sudo] password for lucas:
  *-network UNCLAIMED     
       description: Network controller
       product: Broadcom Corporation
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:12:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:fbc00000-fbc03fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:13:00.0
       logical name: eth0
       version: 02
       serial: b8:ac:6f:e7:90:10
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=187.64.169.100 latency=0 link=yes multicast=yes port=MII speed=100MB/s
       resources: irq:28 ioport:e000(size=256) memory:d0b10000-d0b10fff(prefetchable) memory:d0b00000-d0b0ffff(prefetchable) memory:fb200000-fb21ffff(prefetchable)

iwconfig wlan0

Citar
lucas@ubuntu:~$ iwconfig wlan0
wlan0     No such device


ifconfig wlan0

Citar
lucas@ubuntu:~$ ifconfig wlan0
wlan0: erro obtendo informações da interface: %s: dispositivo não encontrado

nm-tool

Citar
lucas@ubuntu:~$ nm-tool

NetworkManager Tool

State: connected

- Device: eth0  [Auto eth0] ----------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        B8:AC:6F:E7:90:10

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         187.64.169.100
    Prefix:          20 (255.255.240.0)
    Gateway:         187.64.160.1

    DNS:             187.36.192.15
    DNS:             187.36.192.16


rfkill list wifi

Citar
lucas@ubuntu:~$ rfkill list wifi
lucas@ubuntu:~$

Vou reiniciar...

Offline quantumech

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Problemas com rede sem fio
« Resposta #19 Online: 09 de MAR?O de 2012, 16:09 »

Ainda há problemas.

Não funcionou.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com rede sem fio
« Resposta #20 Online: 09 de MAR?O de 2012, 16:23 »
É, está bem estranho. O módulo estava carregado, e indicava ter reconhecido o hardware...

Diga uma coisa, sua máquina é Dell, certo? Um dos passos que eu te passei era pra bloquear um módulo que atrapalha a rede wireless no Ubuntu 10.04 nas máquinas Dell. Vamos verificar se isso funcionou.

lsmod | grep -i dell

modprobe -rv dell-laptop
modprobe -rv dell-wmi
modprobe -rv acer-wmi
modprobe -rv b43
modprobe -v b43
dmesg | tail -20
sudo lshw -C network


Tudo bem se alguns dos comandos derem erro, pode ser que os módulos que a gente mandou descarregar não existam ou não estejam carregados.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline quantumech

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Problemas com rede sem fio
« Resposta #21 Online: 09 de MAR?O de 2012, 16:52 »

Acompanhe:

Citar
lucas@ubuntu:~$ lsmod | grep -i dell
dell_wmi                2177  0
lucas@ubuntu:~$ modprobe -rv dell-laptop
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/firmware/dcdbas.ko
WARNING: Error removing dcdbas (/lib/modules/2.6.32-36-generic/kernel/drivers/firmware/dcdbas.ko): Operation not permitted
lucas@ubuntu:~$ modprobe -rv dell-wmi
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/platform/x86/dell-wmi.ko
FATAL: Error removing dell_wmi (/lib/modules/2.6.32-36-generic/kernel/drivers/platform/x86/dell-wmi.ko): Operation not permitted
lucas@ubuntu:~$ modprobe -rv acer-wmi
lucas@ubuntu:~$ modprobe -rv b43
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/net/wireless/b43/b43.ko
FATAL: Error removing b43 (/lib/modules/2.6.32-36-generic/kernel/drivers/net/wireless/b43/b43.ko): Operation not permitted
lucas@ubuntu:~$ modprobe -v b43
lucas@ubuntu:~$ dmesg | tail -20
[   23.505589]  domain 0: span 0,2 level SIBLING
[   23.505593]   groups: 0 (cpu_power = 589) 2 (cpu_power = 589)
[   23.505605]   domain 1: span 0-3 level MC
[   23.505606]    groups: 0,2 (cpu_power = 1178) 1,3 (cpu_power = 1178)
[   23.505612] CPU1 attaching sched-domain:
[   23.505613]  domain 0: span 1,3 level SIBLING
[   23.505615]   groups: 1 (cpu_power = 589) 3 (cpu_power = 589)
[   23.505618]   domain 1: span 0-3 level MC
[   23.505619]    groups: 1,3 (cpu_power = 1178) 0,2 (cpu_power = 1178)
[   23.505623] CPU2 attaching sched-domain:
[   23.505624]  domain 0: span 0,2 level SIBLING
[   23.505625]   groups: 2 (cpu_power = 589) 0 (cpu_power = 589)
[   23.505628]   domain 1: span 0-3 level MC
[   23.505630]    groups: 0,2 (cpu_power = 1178) 1,3 (cpu_power = 1178)
[   23.505633] CPU3 attaching sched-domain:
[   23.505634]  domain 0: span 1,3 level SIBLING
[   23.505636]   groups: 3 (cpu_power = 589) 1 (cpu_power = 589)
[   23.505639]   domain 1: span 0-3 level MC
[   23.505640]    groups: 1,3 (cpu_power = 1178) 0,2 (cpu_power = 1178)
[   31.393704] eth0: no IPv6 routers present
lucas@ubuntu:~$ sudo lshw -C network
[sudo] password for lucas:
  *-network UNCLAIMED     
       description: Network controller
       product: Broadcom Corporation
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:12:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:fbc00000-fbc03fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:13:00.0
       logical name: eth0
       version: 02
       serial: b8:ac:6f:e7:90:10
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=187.64.169.100 latency=0 link=yes multicast=yes port=MII speed=100MB/s
       resources: irq:28 ioport:e000(size=256) memory:d0b10000-d0b10fff(prefetchable) memory:d0b00000-d0b0ffff(prefetchable) memory:fb200000-fb21ffff(prefetchable)
lucas@ubuntu:~$

Vou reiniciar.

Offline quantumech

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Problemas com rede sem fio
« Resposta #22 Online: 09 de MAR?O de 2012, 17:04 »

Nada!

No ícone do painel relacionado a rede nem aparece nenhuma opção de rede sem fio:(

No Windowns a internet wireless  funciona normalmente.



Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com rede sem fio
« Resposta #23 Online: 09 de MAR?O de 2012, 18:19 »
Desculpe, na mensagem anterior esqueci de dizer que todos os comandos "modprobe" devem ser executados com "sudo", assim:

lsmod | grep -i dell

sudo modprobe -rv dell-laptop
sudo modprobe -rv dell-wmi
sudo modprobe -rv acer-wmi
sudo modprobe -rv b43
sudo modprobe -v b43

dmesg | tail -20

sudo lshw -C network
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline quantumech

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Problemas com rede sem fio
« Resposta #24 Online: 10 de MAR?O de 2012, 19:00 »

Novamente:

Citar
lucas@ubuntu:~$ lsmod | grep -i dell
dell_wmi                2177  0
lucas@ubuntu:~$
lucas@ubuntu:~$ sudo modprobe -rv dell-laptop
[sudo] password for lucas:
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/firmware/dcdbas.ko
lucas@ubuntu:~$ sudo modprobe -rv dell-wmi
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/platform/x86/dell-wmi.ko
lucas@ubuntu:~$ sudo modprobe -rv acer-wmi
lucas@ubuntu:~$ sudo modprobe -rv b43
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/net/wireless/b43/b43.ko
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/ssb/ssb.ko
rmmod /lib/modules/2.6.32-36-generic/kernel/net/mac80211/mac80211.ko
rmmod /lib/modules/2.6.32-36-generic/kernel/net/wireless/cfg80211.ko
rmmod /lib/modules/2.6.32-36-generic/kernel/drivers/leds/led-class.ko
lucas@ubuntu:~$ sudo modprobe -v b43
insmod /lib/modules/2.6.32-36-generic/kernel/drivers/leds/led-class.ko
insmod /lib/modules/2.6.32-36-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/2.6.32-36-generic/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/2.6.32-36-generic/kernel/drivers/ssb/ssb.ko
insmod /lib/modules/2.6.32-36-generic/kernel/drivers/net/wireless/b43/b43.ko
lucas@ubuntu:~$ dmesg | tail -20
[   23.811754]    groups: 1,3 (cpu_power = 1178) 0,2 (cpu_power = 1178)
[   23.811758] CPU2 attaching sched-domain:
[   23.811759]  domain 0: span 0,2 level SIBLING
[   23.811760]   groups: 2 (cpu_power = 589) 0 (cpu_power = 589)
[   23.811763]   domain 1: span 0-3 level MC
[   23.811764]    groups: 0,2 (cpu_power = 1178) 1,3 (cpu_power = 1178)
[   23.811768] CPU3 attaching sched-domain:
[   23.811769]  domain 0: span 1,3 level SIBLING
[   23.811770]   groups: 3 (cpu_power = 589) 1 (cpu_power = 589)
[   23.811773]   domain 1: span 0-3 level MC
[   23.811775]    groups: 1,3 (cpu_power = 1178) 0,2 (cpu_power = 1178)
[  120.954082] cfg80211: Calling CRDA to update world regulatory domain
[  120.960870] cfg80211: World regulatory domain updated:
[  120.960876]    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  120.960884]    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  120.960891]    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  120.960898]    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  120.960905]    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  120.960911]    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  120.982677] Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]
lucas@ubuntu:~$
lucas@ubuntu:~$ sudo lshw -C network
  *-network UNCLAIMED     
       description: Network controller
       product: Broadcom Corporation
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:12:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:fbc00000-fbc03fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:13:00.0
       logical name: eth0
       version: 02
       serial: b8:ac:6f:e7:90:10
       size: 10MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10MB/s
       resources: irq:29 ioport:e000(size=256) memory:d0b10000-d0b10fff(prefetchable) memory:d0b00000-d0b0ffff(prefetchable) memory:fb200000-fb21ffff(prefetchable)
lucas@ubuntu:~$

Reiniciei o computador, mas não resolveu o problema.



Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com rede sem fio
« Resposta #25 Online: 10 de MAR?O de 2012, 19:31 »
Tá faltando algum detalhezinho... execute o comando abaixo e cole o resultado aqui.

sudo lspci -v -s 12:00.0
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline quantumech

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Problemas com rede sem fio
« Resposta #26 Online: 10 de MAR?O de 2012, 23:27 »

Confira:

sudo lspci -v -s 12:00.0

Citar
lucas@ubuntu:~$ sudo lspci -v -s 12:00.0
[sudo] password for lucas:
12:00.0 Network controller: Broadcom Corporation Device 4727 (rev 01)
   Subsystem: Dell Device 0010
   Flags: bus master, fast devsel, latency 0, IRQ 5
   Memory at fbc00000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [40] Power Management version 3
   Capabilities: [58] Vendor Specific Information <?>
   Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
   Capabilities: [d0] Express Endpoint, MSI 00
   Capabilities: [100] Advanced Error Reporting <?>
   Capabilities: [13c] Virtual Channel <?>
   Capabilities: [160] Device Serial Number 65-1c-82-ff-ff-9d-00-00
   Capabilities: [16c] Power Budgeting <?>


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com rede sem fio
« Resposta #27 Online: 11 de MAR?O de 2012, 10:55 »
Bem, eu consegui achar alguns resultados no google.

Parece que é um problema específico do Kernel do Ubuntu 10.04 (2.6.32) com esse controlador Broadcomm 4727. Parece que o driver que funciona com essa placa é o "wl", mesmo, que é instalado pelo pacote "bcmwl-kernel-source" [Referência].

Mas o histórico de problemas da sala sugere que isso seria resolvido de forma mais simples usando uma versão mais nova do Ubuntu --- por exemplo a 11.10, que é a versão atual. Inclusive, estamos já em cima da pinta pro lançamento do Ubuntu 12.04, no final do mês que vem.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline quantumech

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Problemas com rede sem fio
« Resposta #28 Online: 11 de MAR?O de 2012, 12:27 »
Por ora obrigado!

Vou tentando aqui! Vou ver no que dá!


Offline quantumech

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Problemas com rede sem fio
« Resposta #29 Online: 14 de MAR?O de 2012, 17:51 »

Resolvido!

Realmente é só instalar o bcmwl-kernel-source executando os seguintes comandos:

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

E... reiniciar o computador.

Obrigado  :)