Autor Tópico: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)  (Lida 11622 vezes)

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
O Gnome alsamixer não permite mudar o "input source".
E outras limitações do alsamixer.

Este post está baseado na solução do tópico em...
http://itbubbles.wordpress.com/2011/04/29/ubuntu-11-04-fight-for-microphone/#comment-102

1)
Instale gamix
2)
Mude InputSource de FrontMic para RearMic
Mude InputSource1 para Line
(ou faça as mudanças necessárias no seu caso)
3)
Salve as configurações ALSA com sudo alsactl store
4)
Restaure as configurações a cada inicialização assim:
No meu sistema Ubuntu 10.04, tive que colocar o seguinte em...
Sistema > Preferencias > Aplicativos de sessão

Nome: delayed alsactl restore
Comando: sh -c "sleep 20; alsactl restore" &
Comentário: deixe em branco

Isso é porque mais ou menos nos 3 segundos iniciais do início da sessão,
o som alsa está sendo inicializado, e então ele restaura sua configuração default,
matando assim o resultado do nosso alsactl restore se não colocamos "sleep 20" como acima.

keywords:
make input source show up alsamixer ubuntu
input source não aparece no alsamixer
« Última modificação: 01 de Junho de 2012, 09:25 por boladegude »
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #1 Online: 31 de Maio de 2012, 20:13 »
Olá,

No Ubuntu 12.04 Precise Pangolin complicou um pouco pois não tem gamix.

Uma solução boa que apresento aqui é utilizar este script para inicializar o seu microfone com captura ligada e volume de captura alto ao iniciar a sessão do Ubuntu.
Neste caso inicializei o microfone traseiro.
Mude o script como for mais conveniente para você.

Nomeie esse script como init_capture e de permissão para execução.
Crie a pasta ~/bin e coloque o script dentro.
Dê reboot.
As instruções de como utilizar e como instalar o script estão dentro do próprio código dele abaixo:
Código: [Selecionar]
#!/bin/bash
# nome desse script: init_capture
# inicializa a captura do microfone em seu sistema

# Coloque em Sistema > Preferências > Aplicativos de sessão
# No Ubuntu 12.04 digite no menu dash... Aplicativos de sessão
# Nome: init_capture
# Comando: init_capture
# Comentário: inicializa o microfone na sessão


# Está automatizado abaixo mas,
# para saber os numid da sua placa de som
# e saber os nomes corretos dos controles, digite:
# amixer -c 0 controls
# amixer contents
# e procure por algo como
# 'Captura Source ou Input Source',
# 'Capture Volume',
# e 'Capture Switch'
# ... procure encontrar os nomes corretos em seu sistema,
# e adapte a este script.


capture_source=`amixer -c 0 controls | grep "Input Source"`
capture_source=${capture_source:6:2}

capture_volume=`amixer -c 0 controls | grep "Capture Volume"`
capture_volume=${capture_volume:6:2}

capture_switch=`amixer -c 0 controls | grep "Capture Switch"`
capture_switch=${capture_switch:6:2}


# espera a conclusão da inicialização do som na sessão:
sleep 20

# quando chamado, no inicio da sessão,
# passa a fonte da captura (input source) para "rear mic",
# coloca o volume da captura em 90%, e
# liga a captura de som
#
# set capture source mic
amixer cset numid=$capture_source 0 # microfone traseiro 'no meu sistema'
# set capture volume
amixer cset numid=$capture_volume 90%
# set capture off
amixer cset numid=$capture_switch on
« Última modificação: 20 de Junho de 2012, 18:52 por boladegude »
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline rengav

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #2 Online: 11 de Agosto de 2012, 19:53 »
Para ficar como sugestão para quem estiver pesquisando sobre o assunto:
  *** tente instalar o gnome-alsamixer
  *** depois execute gnome-alsamixer e altere os controles

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #3 Online: 11 de Agosto de 2012, 20:21 »
Para ficar como sugestão para quem estiver pesquisando sobre o assunto:
  *** tente instalar o gnome-alsamixer
  *** depois execute gnome-alsamixer e altere os controles

Olá rengav,

O problema é justamente no gnome-alsamixer!
Mas deixo então uma alternativa que realmente dá acesso a todos os controles...
Abra um terminal...
ctrl+alt+t
... e digite...
alsamixer <enter>
(não digite gnome-alsamixer)
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline xluisfernando

  • Usuário Ubuntu
  • *
  • Mensagens: 848
  • Linux user #532810
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #4 Online: 26 de Agosto de 2012, 14:55 »
Esse problema com o micorfone interno dos notebooks é geral ou só aparece em alguns modelos? Tenho pesquisado sobre esse problema no Asus Eee PC 1000HA e tenho lido tópicos que citam o problema para notebooks Dell e Acer.
Samsung Ativ Book i3 - Ubuntu 20.04LTS

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #5 Online: 26 de Agosto de 2012, 17:22 »
Esse problema com o micorfone interno dos notebooks é geral ou só aparece em alguns modelos? Tenho pesquisado sobre esse problema no Asus Eee PC 1000HA e tenho lido tópicos que citam o problema para notebooks Dell e Acer.

Oi xluisfernando,
Tenho esse problema em um desktop PC com placa mãe da Asus e um microfone externo.
A placa mãe é a M4A88TD-M/USB3.
Então o problema não é só com os notebooks.
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline xluisfernando

  • Usuário Ubuntu
  • *
  • Mensagens: 848
  • Linux user #532810
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #6 Online: 26 de Agosto de 2012, 17:31 »
No meu desktop o microfone externo funciona e no notebook, se conecto um microfone externo ele também funciona.

vou tentar o script. Devo apenas salvá-lo como em /bin/init_capture , com permissão de execução ou preciso modificar alguma configuração para o Eee PC?
Samsung Ativ Book i3 - Ubuntu 20.04LTS

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #7 Online: 26 de Agosto de 2012, 17:47 »
No meu desktop o microfone externo funciona e no notebook, se conecto um microfone externo ele também funciona.

vou tentar o script. Devo apenas salvá-lo como em /bin/init_capture , com permissão de execução ou preciso modificar alguma configuração para o Eee PC?


Oi, além de salvá-lo da forma que mencionou, não esqueça de seguir as instruções que estão dentro do próprio script para saber os nomes corretos dos controles em sua máquina, e também para colocar uma chamada para o script nos Aplicativos de Sessão.
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline xluisfernando

  • Usuário Ubuntu
  • *
  • Mensagens: 848
  • Linux user #532810
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #8 Online: 26 de Agosto de 2012, 18:45 »
No meu caso
Citar
xluisfernando@xluisfernando-1000H:~$ amixer -c 0 controls
numid=15,iface=CARD,name='Headphone Jack'
numid=16,iface=CARD,name='Mic Jack'
numid=14,iface=MIXER,name='Master Playback Switch'
numid=13,iface=MIXER,name='Master Playback Volume'
numid=2,iface=MIXER,name='Headphone Playback Switch'
numid=1,iface=MIXER,name='Headphone Playback Volume'
numid=17,iface=MIXER,name='PCM Playback Volume'
numid=8,iface=MIXER,name='Mic Boost Volume'
numid=6,iface=MIXER,name='Mic Playback Switch'
numid=5,iface=MIXER,name='Mic Playback Volume'
numid=9,iface=MIXER,name='Capture Switch'
numid=10,iface=MIXER,name='Capture Volume'
numid=7,iface=MIXER,name='Auto-Mute Mode'
numid=12,iface=MIXER,name='Beep Playback Switch'
numid=11,iface=MIXER,name='Beep Playback Volume'
numid=4,iface=MIXER,name='Speaker Playback Switch'
numid=3,iface=MIXER,name='Speaker Playback Volume'
O que faço com a referência "Input Source", que não aparece listada entre os numid? A resposta do comando, para o meu hardware, exibe apenas o capture switch e o capture volume, sem fazer referência ao input ou capture source.
Samsung Ativ Book i3 - Ubuntu 20.04LTS

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #9 Online: 26 de Agosto de 2012, 19:10 »
No meu caso [ listado acima ]
O que faço com a referência "Input Source", que não aparece listada entre os numid? A resposta do comando, para o meu hardware, exibe apenas o capture switch e o capture volume, sem fazer referência ao input ou capture source.

Mhhmmm, essa listagem é do seu notebook?
Pensei na possibilidade de haver apenas uma "Input Source", mas geralmente há pelo menos mais a entrada "Line In".
Ou seja, pelo menos duas: "Mic" e "Line In".

Você tem essas duas entradas?
Se você às tem aí realmente estamos diante de um problema.
Se só há uma fonte de entrada, "Mic" por exemplo, talvez seja o caso de apenas remover a parte de "Input Source" do script. Mas estou achando estranho.
Mais provável que o Alsa não esteja listando de forma correta seus dispositivos de entrada.
Veja o que ocorre retirando a parte de "Input Source", dando certo ou não de um retorno!
« Última modificação: 26 de Agosto de 2012, 19:12 por boladegude »
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline xluisfernando

  • Usuário Ubuntu
  • *
  • Mensagens: 848
  • Linux user #532810
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #10 Online: 27 de Agosto de 2012, 20:58 »
No meu sistema são listados o Microfone Interno, definido como Mic, e o Microfone definido como Mic Boss, que acredito que seja a entrada p2 rosa. Fisicamente, existem duas entradas do microfone, direita e esquerda, definidas como Áudio Interno Estéreo Analógico.

Depois da colocação /bin/init_capture , sem modificações, percebi que ele foi ativado pelo fato do volume do microfone, que antes ficava em 100%, passou para 90%, seguindo o script. No entanto, ainda não capta sons.

A resposta ao comando amixer:
Citar
xluisfernando@xluisfernando-1000H:~$ alsamixer
xluisfernando@xluisfernando-1000H:~$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 62 [97%] [-2.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 63 [98%] [0.00dB] [on]
  Front Right: Playback 63 [98%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 63 [98%] [0.00dB] [on]
  Front Right: Playback 63 [98%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 253 [99%] [0.40dB]
  Front Right: Playback 253 [99%] [0.40dB]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [12.00dB] [on]
  Front Right: Playback 31 [100%] [12.00dB] [on]
Simple mixer control 'Mic Boost',0
  Capabilities: volume penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [0.00dB] [on]
  Front Right: Playback 23 [74%] [0.00dB] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 42 [91%] [25.00dB] [on]
  Front Right: Capture 42 [91%] [25.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
xluisfernando@xluisfernando-1000H:~$
a resposta do comando lspci
Citar
xluisfernando@xluisfernando-1000H:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GSE Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] (rev 02)
01:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Atheros Communications Inc. AR8121/AR8113/AR8114 Gigabit or Fast Ethernet (rev b0)
xluisfernando@xluisfernando-1000H:~$
Samsung Ativ Book i3 - Ubuntu 20.04LTS

Offline xluisfernando

  • Usuário Ubuntu
  • *
  • Mensagens: 848
  • Linux user #532810
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #11 Online: 27 de Agosto de 2012, 21:26 »
Apenas por curiosidade, resolvei testar esse microfone por live-CD do lubuntu 12.04 e vi que também não funciona. Verifiquei que o mesmo é reconhecido como HDA Intel Mic, de tipo desconhecido, conectado por ALSA.

Acredito que esse problema se deva à compatibilidade do kernel com essa placa de audio. Vou experimentar uma outra distro, por live-CD para ver isso.
Samsung Ativ Book i3 - Ubuntu 20.04LTS

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #12 Online: 27 de Agosto de 2012, 21:49 »
Oi xluisfernando,

As entradas relacionadas a microfone que aparecem na sua listagem de amixer são
1)
Mic
Aparentemente você só tem um microfone mesmo, e talvez seja unicamente externo pela entrada P2 rosa.
Não fala nada tipo Mic 0 e Mic 1 ou Front Mic e Rear Mic.

2)
Mic Boost (e não Boss)
Que é o controle de amplificação do (possivelmente) único microfone disponível.
Coloque esse valor em 20% para teste.

Experimente 2 coisas:
1)
Retirar do script do post "Responder #1" acima a parte relacionada com "Input Source" em ambos os locais que aparecem no script, pois parece que você não tem uma seleção de "fonte de input" por possivelmente ter apenas um microfone e possivelmente apenas externo.
E certifique-se com o comando "amixer contents" que a opção para seu "capture switch" não seja outra diferente de on off, pois poderia também ser 0 e 1.
2)
Conecte um microfone externo (que tenha certeza que está funcionando)

E não esqueça de ligar o playback do microfone para poder ouvir o que está falando.
Isso você pode fazer com o gnome-alsamixer.

E veja se assim consegue ouvir algum som.
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #13 Online: 27 de Agosto de 2012, 21:54 »
Não havia lido sua resposta anterior, pois foi enquanto eu estava lhe escrevendo.

Você deu essa nova informação...
Citar
Verifiquei que o mesmo é reconhecido como HDA Intel Mic, de tipo desconhecido, conectado por ALSA.
Se for esse o caso então realmente era o Alsa que não reconhecia como desconfie acima.

Tente a ideia do microfone externo do meu post anterior para ver, pelo menos, se seu mic externo funciona!
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline xluisfernando

  • Usuário Ubuntu
  • *
  • Mensagens: 848
  • Linux user #532810
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #14 Online: 27 de Agosto de 2012, 22:12 »
Não tenho um microfone externo aqui, mas pluguei o fone de ouvido na entrada rosa do microfone e percebi que dessa forma o alsa capta o som.

Aparentemente, o jeito seria usar um microfone externo.

Pensei em fazer um teste, com o 10.04.4LTS e copiar os arquivos de configuração do 10.04
/usr/share/pulseaudio/alsa-mixer/paths/analog-input-rear-mic.conf
/etc/modprobe.d/alsa-base.conf

Para usá-los no 12.04 e ver no que dá. Tem algum outro arquivo ou procedimento que poderia funcionar?
Samsung Ativ Book i3 - Ubuntu 20.04LTS