Autor Tópico: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)  (Lida 10578 vezes)

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #15 Online: 28 de Agosto de 2012, 14:28 »
Mhhmmm,
Copiar os arquivos de configuração do Lucid...
Pode ser que dê certo.
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline xluisfernando

  • Usuário Ubuntu
  • *
  • Mensagens: 848
  • Linux user #532810
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #16 Online: 29 de Agosto de 2012, 21:48 »
Na sessão live-CD do Ubuntu 10.04 o microfone também apresentou o mesmo problema. Verifiquei as opções alsamixer e verifiquei que na sessão live-CD aparecem menos opções de configuração. Não sei se na sessão live-CD os módulos necessários para o funcionamento do microfone interno são carregados.

O alsa-base.conf do 10.04 é praticamente idêntico ao do 12.04, com a exceção de ser mais enxuto, com a falta de algumas linhas. Em /usr/share/pulseaudio/alsa-mixer/patch do 10.04 não existe o arquivo analog-input-rear-mic.conf
Samsung Ativ Book i3 - Ubuntu 20.04LTS

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #17 Online: 29 de Agosto de 2012, 22:07 »
Oi xluisfernando,

Aparentemente a única solução para o problema é mesmo um kernel mais atualizado, como você havia mencionado acima.
Veja o seguinte link...
http://askubuntu.com/questions/150215/my-sound-is-not-working-in-ubuntu-12-04

Não é a solução mais recomendável, e fica por sua conta testar (faça backup), mas parece que funcionou.

Caso resolva seu problema poste aí!
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline xluisfernando

  • Usuário Ubuntu
  • *
  • Mensagens: 848
  • Linux user #532810
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #18 Online: 30 de Agosto de 2012, 21:19 »
Testei o kernel 3.4 e o 3.5, mas em nenhum deles o microfone funcionou. Não sei se é normal, mas desde a versão 10.04, as vezes o notebook inicia com um chiado em volume alto, que só desaparece com o rufar dos tambores do anúncio da tela de login. Isso acontecia o 10.04, no 11.10 e no 12.04, com menor intensidade.
Estava tentando me lembrar, mas acho que me recordo de ter testado esse microfone interno no 10.04. Como eu disse, no live-CD do 10.04 netbook edition o microfone interno não responde e o externo, plugado na entrada rosa, capta normalmente os sinais.

Verifiquei também no alsa-project.org e percebi que a versão que tenho no meu sistema é a última versão do alsa-drive citada no site, lançada em 25 de janeiro deste ano.
Na parte de debug do site da alsa existe uma referência para hda-intel, mas o link aponta para a documentação em pdf, que é bem complexa.
Samsung Ativ Book i3 - Ubuntu 20.04LTS

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #19 Online: 31 de Agosto de 2012, 12:14 »
É... parece que complicou!
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] input source não aparece no alsamixer (Ubuntu 12.04 no post #1)
« Resposta #20 Online: 14 de Setembro de 2012, 18:14 »
xluisfernando,

Lembrei que a última vez que tive um problema parecido com o seu.
Ou seja... faltarem controles do meu driver de som...
Eu resolvi compilando a versão mais recente do Alsa.
Isso foi no Ubuntu 10.04.

Ocorre que a versão do Ubuntu 12.04 já é a 1.0.25

E aparentemente a versão 1.0.25 já é a versão mais recente.
Dê uma conferida, mas se for mesmo esse o caso, você terá que esperar a versão 1.0.26, se é que já não foi lançada pelo menos em beta.

(Lembre. Antes de fazer qualquer procedimento alterando seu sistema padrão faça backup da imagem com o clonezilla!)

Para compilar uma nova versão do Alsa, oriente-se pelo link...
[ Editado 14/10/2012: esse link expirou...
http://monespaceperso.org/blog-en/2010/05/02/upgrade-alsa-1-0-23-on-ubuntu-lucid-lynx-10-04/
... faça download da cópia em
http://www.divshare.com/download/19801994-b1b
]

... mas ao invés de baixar os wgets indicados...
vá no
Código: [Selecionar]
ftp://ftp.alsa-project.org/pub ou
Código: [Selecionar]
http://mirrors.zerg.biz/alsa... e baixe as versões mais recentes dos arquivos dentro das pastas
driver
lib e
utils

Além disso, ao invés de utilizar makeinstall, faça o seguinte...
Código: [Selecionar]
sudo checkinstall -D
sudo dpkg -i --force-overwrite pacote_gerado_pelo_checkinstall.deb
... para evitar falha na instalação.
« Última modificação: 14 de Outubro de 2012, 19:25 por boladegude »
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.