Autor Tópico: kvm e qemu  (Lida 2149 vezes)

Offline _ubuntu_

  • Usuário Ubuntu
  • *
  • Mensagens: 304
    • Ver perfil
kvm e qemu
« Online: 03 de Maio de 2012, 21:42 »
galera...seuinte... estou usando o ubuntu 12.04 server e instalei grafico gnome para poder usar a virtualizacao..


estou apenas fazendo para aprender num momento..pois vou precisar no futuro nao muito distante.....

o problema é o seguinte..
instalei o kvm e qemu td belezinha.....ai rodo o comando "kvm -boot d -snapshot -m 512 -hda imagem.img -cdrom wxp.iso" para poder instalar o windows xp na imagem.img, porem nao sei pq ao certo...mas ele formata td certo..instala...reinicia e entra no windows normalmente, despois de tudo certinho...se eu desligar....nao consigo entrar mais...

vou explicar por que...
a imagem.img que deveria ficar com aproximadamente 3GB que é o tamanho do windows, fica com 136kb, ai na hora de dar boot nao inicia...boot failed...
suspeitei q estivesse rodando o sistema na memoria ram, entao usei o htop para verificar...e constatei que nao...até mesmo por que toda vez que crio um arquivo dentro da vm windows, o tamanho do hd /dev/sda1 aumenta, entao logicamente esta gravando no hd e nao na memoria...mas nao esta gravando como eu mando atravez do comando -->> kvm -boot d -snapshot -m 512 -hda imagem.img -cdrom wxp.iso,,, na imagem.img por que sera ??


para iniciar o sistema uso o comando kvm -boot d -snapshot -m 512 -hda imagem.img... mas como a imagem.img aparentemente nao esta com sistema operacional nem nada...entao sei la...



obs: na hora da formatacao aparece hd de 10GB ou seja..o tamanho que defini para a imagem.img.....mas ta muito estranho..se alguem tiver alguma luz...



ahh só aproveitando...existe algum comando na hora de dar boot para que utilize mais de um nucleo do processsador ?? pois esta utilizando apenas 1 nucleo...e eu gostaria de usar 4 deles...
obs: tenho 1 FX8120 8 nucleos...
« Última modificação: 03 de Maio de 2012, 21:46 por _ubuntu_ »

Offline _ubuntu_

  • Usuário Ubuntu
  • *
  • Mensagens: 304
    • Ver perfil
Re: kvm e qemu
« Resposta #1 Online: 03 de Maio de 2012, 22:19 »
olhando no 'man kvm' parece que a opção snapshot serve para instalar o sistema mas em temporario..após delisgar é apagado tudo...ou seja..nada é gravado na imagem.img..


entao até ai td blza =]


vou testar mais e posto o resultado..
« Última modificação: 03 de Maio de 2012, 22:27 por _ubuntu_ »