Autor Tópico: Eu não entendi isso... Alguém pode ajudar?  (Lida 1024 vezes)

Offline Lucioo12421

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Eu não entendi isso... Alguém pode ajudar?
« Online: 30 de Maio de 2012, 12:39 »
Eu vi umas notícias de que a Oracle não ia mais deixar que usassem o Java no Ubuntu, e que tinha umas falhas na segurança... algo assim (não sei se entendi direito) então me veio a pergunta:
Agora eu não poderei usar programas que usam Java? Ou eu entendi errado?
Se eu tiver entendido errado, por favor alguém me fale o que realmente a notícia quis dizer, e como eu posso instalar pelo site oficial da Oracle (não queria usar códigos no terminal porque eu ainda sou novato no Linux).

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Eu não entendi isso... Alguém pode ajudar?
« Resposta #1 Online: 30 de Maio de 2012, 12:57 »
Movido para => Café com Ubuntu

eliseu_carvalho

  • Visitante
Re: Eu não entendi isso... Alguém pode ajudar?
« Resposta #2 Online: 30 de Maio de 2012, 13:11 »
Instala o OpenJDK ou o IcedTea e seja feliz  ;D

Offline Julian Fernandes

  • Usuário Ubuntu
  • *
  • Mensagens: 20
  • Ubuntu-BR-SC LoCo Team Leader
    • Ver perfil
    • Ubuntu-BR-SC
Re: Eu não entendi isso... Alguém pode ajudar?
« Resposta #3 Online: 30 de Maio de 2012, 14:20 »
A Oracle mudou a licença do Java, de forma que não é mais possível para o Ubuntu trazer o Oracle Java nos seus repositórios oficiais. Isso não quer dizer que não podemos instalar no Ubuntu, só que precisamos instalar direto do site da Oracle :)

Se quiser instalar o Oracle Java 7 no Ubuntu, basta utilizar este tutorial que ensina a instalar via PPA: http://www.ubuntubrsc.com/instalando-oracle-java-7-ubuntu-ppa.html

Você também pode usar o OpenJDK, que é uma implementação open source do Java. Ela funciona muito bem para a maioria dos casos, mas alguns sites são incompatíveis. Para instalar basta seguir este tutorial: http://www.ubuntubrsc.com/multimidia-ubuntu-12-04-precise-pangolin.html

Espero ter ajudado :)

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.337
  • Ubuntu Member
    • Ver perfil
Re: Eu não entendi isso... Alguém pode ajudar?
« Resposta #4 Online: 30 de Maio de 2012, 15:44 »
O mais fácil de todos.

Abra a Central de Programas do Ubuntu e digite na caixa de pesquisa: IcedTea, manda instalar, digite a senha, de <Enter> e seja feliz em 99,99999% dos casos que necessitam de Java... :D ;)
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Eu não entendi isso... Alguém pode ajudar?
« Resposta #5 Online: 30 de Maio de 2012, 15:54 »
Ola

Ao se cadastrar no forum voce leu e aceitou as regras do forum.

Ao postar sua mensagem voce leu e aceitou as regras de postagem presentes em sua tela

Citar
Da forma de publicação das mensagens

8. Não são permitidas mensagens/títulos:

I - Que tenham como escopo assuntos como: a) esportes, b) religião e c) política.
II - Em caixa-alta (maiúsculas).
III - Com solicitações como "ajuda", "socorro", "help", etc.
IV - Publicidade, compra, venda, ou prestação de qualquer outro serviço.
V - Com o único objetivo de manipular a visibilidade do tópico.
VI - Má-educação, insultos, ataques pessoais, violência ou qualquer conteúdo considerado incendiário ou provocador.
VII - Contendo material que possa causar danos a usuários e terceiros
VIII - Qualquer tópico ou mensagem que promova actividades ilícitas, criminais, ou violações de propriedade intelectual.
IX - Que não estejam de acordo com a descrição dos assuntos da seção.
X - Que contenham imagem maior do que 40 Kb.
XI - Com SPAM ou correntes.
XII - Que possuam título que não esclareçam o contexto da mensagem.
XIII - Pornografia, nudez explícita ou qualquer outro material passível de ferir susceptibilidades pelo seu conteúdo.
XIV - Racismo, xenofobia ou qualquer outra ofensa à condição humana.
XV - Mensagens sem sentido ou de conteúdo manifestamente vazio.
XVI - Com conteúdo duplicado.


Topico trancado - se desejar, refaça seu tópico dentro das regras do fórum

[]'s