Autor Tópico: Mencoder nao grava som :S - RESOLVIDO  (Lida 9378 vezes)

Offline dudu_ubuntun

  • Usuário Ubuntu
  • *
  • Mensagens: 507
    • Ver perfil
    • O Tempo do Mundo
Mencoder nao grava som :S - RESOLVIDO
« Online: 28 de Agosto de 2006, 01:02 »
Ola
tnho uma placa de tv playtv mpeg2 funcionando perfeitamente, inclusive com som. Mas quando vou gravar usando o mencoder nao grava o som, alguma dica?
valeu
« Última modificação: 02 de Setembro de 2006, 14:46 por dudu_ubuntun »

Offline naldin

  • Usuário Ubuntu
  • *
  • Mensagens: 143
    • Ver perfil
Re: Mencoder nao grava som :S
« Resposta #1 Online: 28 de Agosto de 2006, 01:50 »
Eu so consegui gravar, pegando o audio pela placa de som do pc, se for captura de video externo ligue o audio na entrada da placa de som do pc, se for audio de tv, tem que ligar um cabo da saida de audio da placa de video/tv para a entrada da placa de som do pc.  Mas não fiz o teste com tv, somente com video externo. Um detalhe que não consegui gravar esse audio em estereo, nem usando o 2 no parametro -e 44100,16,2
-Notebook Dell Vostro 1400 | Video Intel GM965
-HD250Gb | 4Gb DDR600 | HD500Gb de bolso
+ LCD 19" Samsung

Offline dudu_ubuntun

  • Usuário Ubuntu
  • *
  • Mensagens: 507
    • Ver perfil
    • O Tempo do Mundo
Re: Mencoder nao grava som :S
« Resposta #2 Online: 29 de Agosto de 2006, 00:24 »
O som funciona tanto pela placa de tv quanto pela placa do pc, vc poderia colocar o comando inteiro para eu analizar?

Offline naldin

  • Usuário Ubuntu
  • *
  • Mensagens: 143
    • Ver perfil
Re: Mencoder nao grava som :S
« Resposta #3 Online: 29 de Agosto de 2006, 17:09 »
Agora que percebi, voce está usando o mencoder e eu uso o transcode. Os comandos seguem abaixo, e no link tem mais informações.

Para a gravação do canal de TV, onde em 0,3 o 3 é o canal 3
$ transcode -H 0 -i /dev/video0 -p /dev/dsp -g 352x240 -f 0,4 -y ffmpeg -F msmpeg4 --import_v4l 0,3 -x v4l -o video-1.avi -w 800 -b 64 -s 0 -J pv -e 44100,16,2 -Z 352x240 -j 6,16

Para gravação pela captura do video, onde o 1 indica captura, o 0 indica tv:
$ transcode -H 0 -i /dev/video0 -p /dev/dsp -g 352x240 -f 0,4 -y ffmpeg -F msmpeg4 --import_v4l 1 -x v4l -o video-1.avi -w 800 -b 64 -s 0 -J pv -e 44100,16,2 -Z 352x240 -j 6,16

http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=3903
-Notebook Dell Vostro 1400 | Video Intel GM965
-HD250Gb | 4Gb DDR600 | HD500Gb de bolso
+ LCD 19" Samsung

Offline dudu_ubuntun

  • Usuário Ubuntu
  • *
  • Mensagens: 507
    • Ver perfil
    • O Tempo do Mundo
Re: Mencoder nao grava som :S
« Resposta #4 Online: 02 de Setembro de 2006, 14:39 »
Valeu camarada,
Baixei o transcode e funcionou certinho
t+

Offline naldin

  • Usuário Ubuntu
  • *
  • Mensagens: 143
    • Ver perfil
Re: Mencoder nao grava som :S
« Resposta #5 Online: 02 de Setembro de 2006, 14:45 »
Valeu camarada,
Baixei o transcode e funcionou certinho
t+
Aproveitando que voce conseguiu, com voce gravou em estereo?
-Notebook Dell Vostro 1400 | Video Intel GM965
-HD250Gb | 4Gb DDR600 | HD500Gb de bolso
+ LCD 19" Samsung

Offline dudu_ubuntun

  • Usuário Ubuntu
  • *
  • Mensagens: 507
    • Ver perfil
    • O Tempo do Mundo
Re: Mencoder nao grava som :S - RESOLVIDO
« Resposta #6 Online: 02 de Setembro de 2006, 14:57 »
Aqui grava estéreo usando a linha de comando que vc passou, as vezes a imagem nao aparece, a tela fica preta, mas o som grava estereo sim :S
+

Offline naldin

  • Usuário Ubuntu
  • *
  • Mensagens: 143
    • Ver perfil
Re: Mencoder nao grava som :S - RESOLVIDO
« Resposta #7 Online: 02 de Setembro de 2006, 15:01 »
Blz, acho que é algo com minha placa de som, estranho que ouço o som que está entrando em estereo, e na hora de gravar so grava o esquerdo. Sobre a imagem nao aparecer, fica assim mesmo tem hora, mas grava normal.
-Notebook Dell Vostro 1400 | Video Intel GM965
-HD250Gb | 4Gb DDR600 | HD500Gb de bolso
+ LCD 19" Samsung

Offline botinha

  • Usuário Ubuntu
  • *
  • Mensagens: 106
  • Debian7 Brasil
    • Ver perfil
Re: Mencoder nao grava som :S - RESOLVIDO
« Resposta #8 Online: 13 de Setembro de 2006, 22:56 »
Caros amigos estou com o mesmo problema, de não conseguir capturar o som usando o mencoder. Alguém poderia me dar uma ajuda?


Valeu...

PS aproveitando o tópico para deixar p fórum limpo
"o suor poupa o sangue"

Offline dudu_ubuntun

  • Usuário Ubuntu
  • *
  • Mensagens: 507
    • Ver perfil
    • O Tempo do Mundo
Re: Mencoder nao grava som :S - RESOLVIDO
« Resposta #9 Online: 14 de Setembro de 2006, 01:34 »
nao entendo muito, mas vamo tenta :P

1) qual a sua placa de tv?
2) vc cosnegue ouvir o som quando a placa esta funcionando?


t+

Offline botinha

  • Usuário Ubuntu
  • *
  • Mensagens: 106
  • Debian7 Brasil
    • Ver perfil
Re: Mencoder nao grava som :S - RESOLVIDO
« Resposta #10 Online: 15 de Setembro de 2006, 16:24 »
Caro amigo a minha Placa eh a Playtv MPEG 2 da PixelView. Quando eu ligo o pc tem som se problemas, porém as veze uso o gnomeradio para ouvir o som que entra pela placa, junot com a imagem.


Valeu....
"o suor poupa o sangue"

Offline dudu_ubuntun

  • Usuário Ubuntu
  • *
  • Mensagens: 507
    • Ver perfil
    • O Tempo do Mundo
Re: Mencoder nao grava som :S - RESOLVIDO
« Resposta #11 Online: 15 de Setembro de 2006, 17:41 »
a minha placa é igual a sua :D
o gnomeradio é para ouvir radio fm, correto? eu nunca cosnegui ouvir nada além de estática :S
tente trocar o /dev/dsp por /dev/dsp1 se vc tiver mais de uma entrada de som

Veja bem, estamos usando o TRANSCODE e nao o mencoder, com o mencoder eu também nao consegui e trocando para o TRANSCODE deu certinho conforme a dica do camarada naldin
« Última modificação: 15 de Setembro de 2006, 17:43 por dudu_ubuntun »

Offline botinha

  • Usuário Ubuntu
  • *
  • Mensagens: 106
  • Debian7 Brasil
    • Ver perfil
Re: Mencoder nao grava som :S - RESOLVIDO
« Resposta #12 Online: 16 de Setembro de 2006, 10:41 »
Olha amigo eu fiquei com receio de instalar o transcode pois no synaptic aparecia uma mensagem dizendo que o mesmo não era autenticado e eu poderia ter a máquina invadida.
E agora..

Valeu....
"o suor poupa o sangue"

Offline dudu_ubuntun

  • Usuário Ubuntu
  • *
  • Mensagens: 507
    • Ver perfil
    • O Tempo do Mundo
Re: Mencoder nao grava som :S - RESOLVIDO
« Resposta #13 Online: 16 de Setembro de 2006, 13:09 »
Bom, concordo com tua preocupação, seria interessante vc abrir uma dicussão sobre os pacotes não autenticados.
Naldin dá sua opinião ai camarada!

Offline naldin

  • Usuário Ubuntu
  • *
  • Mensagens: 143
    • Ver perfil
Re: Mencoder nao grava som :S - RESOLVIDO
« Resposta #14 Online: 16 de Setembro de 2006, 13:32 »
Maquina invadida acho muito dificil, afinal o transcode nao é nenhum servidor.  A melhor opção é mesmo o Transcode, já que não achamos uma forma de fazer o Mencoder funcionar.
-Notebook Dell Vostro 1400 | Video Intel GM965
-HD250Gb | 4Gb DDR600 | HD500Gb de bolso
+ LCD 19" Samsung