Autor Tópico: LibreOffice - Instalação do Language Pack [Resolvido]  (Lida 14746 vezes)

Offline NelsonRodrigues

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
LibreOffice - Instalação do Language Pack [Resolvido]
« Online: 27 de Novembro de 2012, 14:30 »
Alguém me ajuda a instalar o Language Pack do LibreOffice? Preciso passar o corretor ortográfico em um texto.
Já tentei instalá-lo de várias formas, mas sempre dá erro. Segui os passos seguintes:
1) Abro o pacote libobasis3.6-pt-br-writer_3.6.3.2-2_i386.deb no Terminal
2) Coloco o comando: sudo dpkg -i *.deb
3) Então aparece o seguinte:

(Lendo banco de dados ... 263614 ficheiros e directórios actualmente instalados.)
Preparando para substituir libobasis3.6-pt-br 3.6.3.2-2 (usando libobasis3.6-pt-br_3.6.3.2-2_i386.deb) ...
Desempacotando substituto libobasis3.6-pt-br ...
Preparando para substituir libobasis3.6-pt-br-base 3.6.3.2-2 (usando libobasis3.6-pt-br-base_3.6.3.2-2_i386.deb) ...
Desempacotando substituto libobasis3.6-pt-br-base ...
Preparando para substituir libobasis3.6-pt-br-calc 3.6.3.2-2 (usando libobasis3.6-pt-br-calc_3.6.3.2-2_i386.deb) ...
Desempacotando substituto libobasis3.6-pt-br-calc ...
Preparando para substituir libobasis3.6-pt-br-math 3.6.3.2-2 (usando libobasis3.6-pt-br-math_3.6.3.2-2_i386.deb) ...
Desempacotando substituto libobasis3.6-pt-br-math ...
Preparando para substituir libobasis3.6-pt-br-res 3.6.3.2-2 (usando libobasis3.6-pt-br-res_3.6.3.2-2_i386.deb) ...
Desempacotando substituto libobasis3.6-pt-br-res ...
Preparando para substituir libobasis3.6-pt-br-writer 3.6.3.2-2 (usando libobasis3.6-pt-br-writer_3.6.3.2-2_i386.deb) ...
Desempacotando substituto libobasis3.6-pt-br-writer ...
Preparando para substituir libreoffice3.6-dict-pt-br 3.6.3.2-2 (usando libreoffice3.6-dict-pt-br_3.6.3.2-2_i386.deb) ...
Desempacotando substituto libreoffice3.6-dict-pt-br ...
Preparando para substituir libreoffice3.6-pt-br 3.6.3.2-2 (usando libreoffice3.6-pt-br_3.6.3.2-2_i386.deb) ...
Desempacotando substituto libreoffice3.6-pt-br ...
dpkg: problemas de dependência impedem a configuração de libobasis3.6-pt-br:
 libobasis3.6-pt-br depende de libobasis3.6-core01; porém:
  Pacote libobasis3.6-core01 não está instalado.
dpkg: erro processando libobasis3.6-pt-br (--install):
 problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de libobasis3.6-pt-br-base:
 libobasis3.6-pt-br-base depende de libobasis3.6-pt-br; porém:
  Pacote libobasis3.6-pt-br não está configurado ainda.
dpkg: erro processando libobasis3.6-pt-br-base (--install):
 problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de libobasis3.6-pt-br-calc:
 libobasis3.6-pt-br-calc depende de libobasis3.6-pt-br; porém:
  Pacote libobasis3.6-pt-br não está configurado ainda.
dpkg: erro processando libobasis3.6-pt-br-calc (--install):
 problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de libobasis3.6-pt-br-math:
 libobasis3.6-pt-br-math depende de libobasis3.6-pt-br; porém:
  Pacote libobasis3.6-pt-br não está configurado ainda.
dpkg: erro processando libobasis3.6-pt-br-math (--install):
 problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de libobasis3.6-pt-br-res:
 libobasis3.6-pt-br-res depende de libobasis3.6-pt-br; porém:
  Pacote libobasis3.6-pt-br não está configurado ainda.
dpkg: erro processando libobasis3.6-pt-br-res (--install):
 problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de libobasis3.6-pt-br-writer:
 libobasis3.6-pt-br-writer depende de libobasis3.6-pt-br; porém:
  Pacote libobasis3.6-pt-br não está configurado ainda.
dpkg: erro processando libobasis3.6-pt-br-writer (--install):
 problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de libreoffice3.6-dict-pt-br:
 libreoffice3.6-dict-pt-br depende de libreoffice3.6-ure; porém:
  Pacote libreoffice3.6-ure não está instalado.
 libreoffice3.6-dict-pt-br depende de libobasis3.6-core01; porém:
  Pacote libobasis3.6-core01 não está instalado.
 libreoffice3.6-dict-pt-br depende de libobasis3.6-core02; porém:
  Pacote libobasis3.6-core02 não está instalado.
 libreoffice3.6-dict-pt-br depende de libobasis3.6-core03; porém:
  Pacote libobasis3.6-core03 não está instalado.
 libreoffice3.6-dict-pt-br depende de libobasis3.6-core04; porém:
  Pacote libobasis3.6-core04 não está instalado.
 libreoffice3.6-dict-pt-br depende de libobasis3.6-core05; porém:
  Pacote libobasis3.6-core05 não está instalado.
 libreoffice3.6-dict-pt-br depende de libobasis3.6-core06; porém:
  Pacote libobasis3.6-core06 não está instalado.
 libreoffice3.6-dict-pt-br depende de libobasis3.6-core07; porém:
  Pacote libobasis3.6-core07 não está instalado.
 libreoffice3.6-dict-pt-br depende de libreoffice3.6; porém:
  Pacote libreoffice3.6 não está instalado.
dpkg: erro processando libreoffice3.6-dict-pt-br (--install):
 problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de libreoffice3.6-pt-br:
 libreoffice3.6-pt-br depende de libreoffice3.6; porém:
  Pacote libreoffice3.6 não está instalado.
 libreoffice3.6-pt-br depende de libobasis3.6-pt-br; porém:
  Pacote libobasis3.6-pt-br não está configurado ainda.
 libreoffice3.6-pt-br depende de libobasis3.6-pt-br-base; porém:
  Pacote libobasis3.6-pt-br-base não está configurado ainda.
 libreoffice3.6-pt-br depende de libobasis3.6-pt-br-calc; porém:
  Pacote libobasis3.6-pt-br-calc não está configurado ainda.
 libreoffice3.6-pt-br depende de libobasis3.6-pt-br-math; porém:
  Pacote libobasis3.6-pt-br-math não está configurado ainda.
 libreoffice3.6-pt-br depende de libobasis3.6-pt-br-res; porém:
  Pacote libobasis3.6-pt-br-res não está configurado ainda.
 libreoffice3.6-pt-br depende de libobasis3.6-pt-br-writer; porém:
  Pacote libobasis3.6-pt-br-writer não está configurado ainda.
dpkg: erro processando libreoffice3.6-pt-br (--install):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 libobasis3.6-pt-br
 libobasis3.6-pt-br-base
 libobasis3.6-pt-br-calc
 libobasis3.6-pt-br-math
 libobasis3.6-pt-br-res
 libobasis3.6-pt-br-writer
 libreoffice3.6-dict-pt-br
 libreoffice3.6-pt-br

Se alguém puder me ajudar, tô precisando muito!
« Última modificação: 27 de Novembro de 2012, 19:02 por NelsonRodrigues »

Offline NelsonRodrigues

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #1 Online: 27 de Novembro de 2012, 15:32 »
Antes de uma das tentativas, fiz a atualização do LibreOffice com os seguintes comandos:

    sudo add-apt-repository ppa:libreoffice/ppa
    sudo apt-get update
    sudo apt-get install libreoffice libreoffice-gnome

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #2 Online: 27 de Novembro de 2012, 16:41 »
Não é mais fácil instalar pela Central de Programas do Ubuntu?

Basta digitar na caixa de pesquisa LibreOffice, clique no pacote LibreOffice (puro e simples mesmo) em instalar, digite a senha e pronto...!!!
« Última modificação: 27 de Novembro de 2012, 16:43 por jkmsjq »
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #3 Online: 27 de Novembro de 2012, 16:47 »
Você quer atualizar para a 3.6 certo..?

Siga isso, comigo funcionou:

1. Abra um terminal e remova a versão instalada:

Código: [Selecionar]
sudo apt-get purge libreoffice-core
2. Adicione o PPA:

Código: [Selecionar]
sudo add-apt-repository ppa:libreoffice/libreoffice-prereleases -y
3. Atualize as fontes e instale a nova versão:

Código: [Selecionar]
sudo apt-get update
sudo apt-get install libreoffice

4. Instale os pacotes de ajuda e tradução, em nosso idioma, além da integração com o GTK:

Código: [Selecionar]
sudo apt-get install libreoffice-l10n-pt-br libreoffice-help-pt-br libreoffice-gtk libreoffice-gtk3

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #4 Online: 27 de Novembro de 2012, 16:55 »
Você quer atualizar para a 3.6 certo..?

Siga isso, comigo funcionou:

1. Abra um terminal e remova a versão instalada:

Código: [Selecionar]
sudo apt-get purge libreoffice-core
2. Adicione o PPA:

Código: [Selecionar]
sudo add-apt-repository ppa:libreoffice/libreoffice-prereleases -y
3. Atualize as fontes e instale a nova versão:

Código: [Selecionar]
sudo apt-get update
sudo apt-get install libreoffice

4. Instale os pacotes de ajuda e tradução, em nosso idioma, além da integração com o GTK:

Código: [Selecionar]
sudo apt-get install libreoffice-l10n-pt-br libreoffice-help-pt-br libreoffice-gtk libreoffice-gtk3

Tem essa alternativa.

Mas como sou contra a utilização de PPA, prefiro instalar o pacote baixado do site diretamente e seguir as dicas desse post aqui do fórum mesmo (apenas adaptando para a versão atual do LibreOffice)
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #5 Online: 27 de Novembro de 2012, 16:58 »
Bom.. Agora depende da escolha do usuário..!  :)

Offline NelsonRodrigues

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #6 Online: 27 de Novembro de 2012, 18:22 »
jkmsjq e Artur Bernardes, valeu a ajuda.
Artur, segui seus comandos, mas o corretor ortográfico continua sem funcionar.
Já tentei de várias formas. Mas até agora nada... :(

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #7 Online: 27 de Novembro de 2012, 18:25 »
Você removeu a versão instalada..? Comigo funciona normal...

Veja esse link, a respeito do Corretor Ortográfico

Offline NelsonRodrigues

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #8 Online: 27 de Novembro de 2012, 18:27 »
Removi. Coloquei todos os comandos.

Offline NelsonRodrigues

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #9 Online: 27 de Novembro de 2012, 18:29 »
Um amigo também me sugeriu esse CoGrOO. Instalei-o aqui, mas ele é apenas gramatical. Não detecta os erros ortográficos.

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #10 Online: 27 de Novembro de 2012, 18:31 »

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #11 Online: 27 de Novembro de 2012, 18:35 »
Tem certeza que não funciona..? No meu 3.6 funciona perfeitamente.. Qual versão do Ubuntu usa..?

Corretor Ortográfico até LibreOffice 3.5

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #12 Online: 27 de Novembro de 2012, 18:36 »
Mas a demonstração dos erros ortográficos são automáticos.

Estou digitando do Linux Mint 14 recém instalado, fazendo ainda as atualizações via terminal e a detecção de erros ortográficos no LibreOffice já é demonstrado de primeira.

O ícone no menu de ferrramentas está ativado para Autoverificação Ortográfica no LibreOffice?

A versão instalada é que veio no Ubuntu padrão ou você instalou posteriormente?
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline NelsonRodrigues

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #13 Online: 27 de Novembro de 2012, 18:38 »
Uso o Ubuntu 12.04. É muito estranho mesmo, já tentei vários caminhos. Mas aqui não tá rolando.

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: LibreOffice - Instalação do Language Pack
« Resposta #14 Online: 27 de Novembro de 2012, 18:40 »
Mas a demonstração dos erros ortográficos são automáticos.

Estou digitando do Linux Mint 14 recém instalado, fazendo ainda as atualizações via terminal e a detecção de erros ortográficos no LibreOffice já é demonstrado de primeira.

O ícone no menu de ferrramentas está ativado para Autoverificação Ortográfica no LibreOffice?

A versão instalada é que veio no Ubuntu padrão ou você instalou posteriormente?

Ele instalou posteriormente. E comigo funciona perfeito..!