Autor Tópico: [Resolvido]Desempenho muito baixo!  (Lida 6419 vezes)

Offline Maicon Costa

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
[Resolvido]Desempenho muito baixo!
« Online: 30 de Julho de 2013, 23:52 »
Olá pessoal! Sou novo no ubuntu (já mexi com ele há 7 anos atrás, e nesse meio tempo já configurei servidores através do terminal) e agora resolvi migrar de vez pra ele, estou usando a versão 13.04, bom até agora tem sido uma beleza, em menos de uma semana consegui me adequar a ele, instalei todos os programas semelhantes aos que eu usava no windows 7... porém resolvi procurar alguns jogos para linux, até achei alguns: Alien Arena, Urban Terror, SuperTuxKart dizem ser uns dos melhores, mas os gráficos não são grande coisa... tudo bem, sei que meu Hardware é meio ruim ainda;
Memória: 2GB
Placa de vídeo: Intel 945g 256 mb Onboard
Processador: Intel Celeron 1,8 ghz

não é bom, mas poxa, quando eu usava windows até então conseguia jogar alguns jogos com gráficos razoáveis, tipo:
Need For Speed Underground 1 e 2
Resident Evil 4
Gta San Andreas (Tinha que baixar um pouco a qualidade pra rodar legal)
Crossfire
Pointblank

E tipo, a maioria diz que o linux é muito mais rápido que o windows, então obviamente deveria ser melhor também com jogos, então gostaria de ter algumas dicas (Que não seja atualizar o hardware, isso é obvio e to sem dinheiro por enquanto rs..) Também dispenso ter que trocar o ambiente de trabalho para ter que jogar, eu gosto de usar o unity e se for preciso trocar então prefiro ficar sem jogar mesmo, pois só queria jogar para distrair um pouco, já que sou Desenvolvedor Web...

Desde já agradeço a atenção de todos!
« Última modificação: 01 de Agosto de 2013, 15:42 por Maicon Costa »

Offline Renan Rischiotto

  • Usuário Ubuntu
  • *
  • Mensagens: 2.888
    • Ver perfil
Re: Desempenho muito baixo!
« Resposta #1 Online: 31 de Julho de 2013, 00:08 »
Instala o Steam aí e divirta-se =)

Offline haereticus

  • Usuário Ubuntu
  • *
  • Mensagens: 975
  • Xubuntu 12.04.2 x64
    • Ver perfil
Re: Desempenho muito baixo!
« Resposta #2 Online: 31 de Julho de 2013, 08:34 »
Cara tenta usar o 12.04 Lts.
Notebook: Samsung 305E4A-BD1 - AMD A6-3420M (Quad Core) @2.4GHz - Radeon™ 6520G 512MB - 8GB - HD 500GB - 14” LED HD - HDMI - Bluetooth - Webcam 1.3 HD - Base CoolerMaster Notepal Ergostand - Mouse X7 Oscar 750bk 3200dpi.

Sony Xperia L - Android 4.1.2

Offline pylm69

  • Usuário Ubuntu
  • *
  • Mensagens: 476
    • Ver perfil
Re: Desempenho muito baixo!
« Resposta #3 Online: 31 de Julho de 2013, 11:07 »
 Team Fortress  deve rodar de boa ai e é de grátis ;D
Rolling Release é o máximo \o/

Offline snell

  • Usuário Ubuntu
  • *
  • Mensagens: 231
  • Labor improbus omnia vincit
    • Ver perfil
    • Canal 8 - Uma homenagem à Chespirito!
Re: Desempenho muito baixo!
« Resposta #4 Online: 31 de Julho de 2013, 11:20 »
Vamos tentar resolver seu problema :)

Será que o drive do vídeo esta instalado corretamente? o que aparece quando você executa:

Citar
glxgears

no terminal? As engrenagens estão travando? Você executa o Compiz corretamente? Você consegue jogar, mas esta travando o jogo?

Já tentou mexer nas próprias configurações dos jogos?

[]'s
Notebook
Intel Core i7 2620, 4Gb RAM, 750 Gb HD
Ubuntu 14.04

Offline Maicon Costa

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Desempenho muito baixo!
« Resposta #5 Online: 31 de Julho de 2013, 12:18 »
Vamos tentar resolver seu problema :)

Será que o drive do vídeo esta instalado corretamente? o que aparece quando você executa:

Citar
glxgears

no terminal? As engrenagens estão travando? Você executa o Compiz corretamente? Você consegue jogar, mas esta travando o jogo?

Já tentou mexer nas próprias configurações dos jogos?

[]'s

Bom, eu creio que meu driver de vídeo está instalado corretamente...
Código: [Selecionar]
maicon@ubuntu:~$ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
302 frames in 5.0 seconds = 60.345 FPS
300 frames in 5.0 seconds = 59.819 FPS
300 frames in 5.0 seconds = 59.819 FPS
300 frames in 5.0 seconds = 59.819 FPS
302 frames in 5.0 seconds = 60.218 FPS
300 frames in 5.0 seconds = 59.819 FPS
300 frames in 5.0 seconds = 59.818 FPS
300 frames in 5.0 seconds = 59.820 FPS
300 frames in 5.0 seconds = 59.819 FPS
300 frames in 5.0 seconds = 59.819 FPS
300 frames in 5.0 seconds = 59.816 FPS
300 frames in 5.0 seconds = 59.822 FPS
300 frames in 5.0 seconds = 59.820 FPS

Também já mexi nas configurações de alguns jogos reduzindo um pouco e ainda tem travado, o SuperTuxKart é o mais lerdo, não consegui nem iniciar a partida de tão lerdo que ele fica pra iniciar, porém a navegação no menu dele é super rápida...

Offline pylm69

  • Usuário Ubuntu
  • *
  • Mensagens: 476
    • Ver perfil
Re: Desempenho muito baixo!
« Resposta #6 Online: 31 de Julho de 2013, 14:36 »
 Eu já tive essa placa, fiquei uns 2 anos e meio com ela, é tensa mesmo, coisas no wine vão ficar horríveis ok? Eu tentei rodar o GTA SA e ficou a 10 FPS, mas os nativos deveriam rodar de boa, a intel tem um instalador próprio de drivers para linux e vc ainda pode usar o xorg-edgers que são drivers "quentes" que provem uma boa melhora de desempenho, mas lembre-se de que, eles são drivers em testes, ou seja, podem ser instáveis...
Rolling Release é o máximo \o/

Offline Maicon Costa

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Desempenho muito baixo!
« Resposta #7 Online: 31 de Julho de 2013, 18:20 »
Mexi nas configurações do jogo e ficou bom. Eu ia até postar que foi resolvido...

Mas aí fui tentar seguir a última dica instalando os xorg-edgers e agora o sistema todo ficou lento, alguém pode me ajudar a resolver? :S

Offline pylm69

  • Usuário Ubuntu
  • *
  • Mensagens: 476
    • Ver perfil
Re: Desempenho muito baixo!
« Resposta #8 Online: 01 de Agosto de 2013, 12:47 »
http://hackedbellini.org/applications/ppa-purge-the-best-friend-for-people-who-lives-on-bleeding-edge/
 Nem precisa saber muito sobre inglês, só rodar os comandos, segundo o PPA que vc usou e ta na mão, mas eu avisei que era instável... é sua conta e risco ;D
Rolling Release é o máximo \o/

Offline Maicon Costa

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Desempenho muito baixo!
« Resposta #9 Online: 01 de Agosto de 2013, 15:41 »
http://hackedbellini.org/applications/ppa-purge-the-best-friend-for-people-who-lives-on-bleeding-edge/
 Nem precisa saber muito sobre inglês, só rodar os comandos, segundo o PPA que vc usou e ta na mão, mas eu avisei que era instável... é sua conta e risco ;D

Valeu cara, tudo voltou ao normal! Obrigado a todos que me ajudaram!