Autor Tópico: (Resolvido) [Video] Configuração de rede/internet  (Lida 2848 vezes)

Offline BrunoGom3s

  • Usuário Ubuntu
  • *
  • Mensagens: 69
  • Ubuntu 11.04 ♥
    • Ver perfil
(Resolvido) [Video] Configuração de rede/internet
« Online: 13 de MAR?O de 2014, 16:02 »
Olá pessoal, eu volto mais uma vez aqui pra tentar sanar um problema que me persegue em todas as distribuições Linux. Minha rede nunca inicia automaticamente, sempre preciso executar um comando para a mesma funcione, vejam no vídeo.

*Assistam em 720p*

http://www.youtube.com/watch?v=YpXArD4u4OM


PS: Desculpem pelo áudio estourado, eu fiz o vídeo em um horário apertado e não deu pra deixar um ajuste fino.

Meu problema é esse, o comando que utilizo é esse abaixo:

Código: [Selecionar]
sudo ethtool -s eth0 speed 100 duplex full autoneg on
Abaixo informações do meu sistema.

Código: [Selecionar]
cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Código: [Selecionar]
cat /var/lib/NetworkManager/NetworkManager.state
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

Código: [Selecionar]
cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

Código: [Selecionar]
cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
search home

Código: [Selecionar]
lspci -nnk | grep -iA2 net
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
Subsystem: Gigabyte Technology Co., Ltd Motherboard [1458:e000]
Kernel driver in use: r8169

Código: [Selecionar]
lsmod
Module Size Used by
parport_pc 31981 0
ppdev 17391 0
bnep 18893 2
rfcomm 53664 0
bluetooth 323534 10 bnep,rfcomm
binfmt_misc 13140 1
x86_pkg_temp_thermal 13810 0
intel_powerclamp 14239 0
coretemp 13195 0
kvm 364766 0
crc32_pclmul 12967 0
snd_hda_codec_hdmi 40508 1
snd_hda_codec_realtek 45473 1
snd_hda_intel 42658 5
dm_multipath 22402 0
scsi_dh 14458 1 dm_multipath
snd_hda_codec 164003 3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep 13272 1 snd_hda_codec
snd_pcm 89488 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc 14230 2 snd_pcm,snd_hda_intel
snd_seq_midi 13132 0
snd_seq_midi_event 14475 1 snd_seq_midi
snd_rawmidi 25094 1 snd_seq_midi
microcode 18830 0
snd_seq 55383 2 snd_seq_midi_event,snd_seq_midi
uvcvideo 71309 0
snd_seq_device 14137 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 24447 2 snd_pcm,snd_seq
videobuf2_vmalloc 13048 1 uvcvideo
videobuf2_memops 13170 1 videobuf2_vmalloc
psmouse 90642 0
serio_raw 13189 0
videobuf2_core 39125 1 uvcvideo
joydev 17097 0
lpc_ich 16864 0
videodev 107508 2 uvcvideo,videobuf2_core
snd 60790 21 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
lp 13299 0
parport 40795 3 lp,ppdev,parport_pc
soundcore 12600 1 snd
mac_hid 13037 0
dm_mirror 21715 0
dm_region_hash 15984 1 dm_mirror
dm_log 18072 2 dm_region_hash,dm_mirror
radeon 1307301 3
hid_generic 12492 0
i2c_algo_bit 13197 1 radeon
ttm 71886 1 radeon
drm_kms_helper 46867 1 radeon
usbhid 47361 0
drm 242354 5 ttm,drm_kms_helper,radeon
usb_storage 48294 0
hid 87192 2 hid_generic,usbhid
r8169 61434 0
mii 13654 1 r8169
video 18777 0

Código: [Selecionar]
ifconfig -a
eth0 Link encap:Ethernet Endereço de HW 90:2b:34:f1:33:0b
inet end.: 192.168.25.26 Bcast:192.168.25.255 Masc:255.255.255.0
endereço inet6: fe80::922b:34ff:fef1:330b/64 Escopo:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
pacotes RX:148761 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:108091 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:162801531 (162.8 MB) TX bytes:20365034 (20.3 MB)

lo Link encap:Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACK RUNNING MTU:65536 Métrica:1
pacotes RX:2639 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:2639 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:0
RX bytes:285488 (285.4 KB) TX bytes:285488 (285.4 KB)

Agradeço desde já a ajuda de vocês.
« Última modificação: 14 de MAR?O de 2014, 17:09 por BrunoGom3s »
Vivendo e aprendendo.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: [Video] Configuração de rede/internet
« Resposta #1 Online: 13 de MAR?O de 2014, 21:34 »
Cara, se sua interface só sobe quando vc desativa a negociação, vc tem um problema de cabeamento. Experimente trocar os cabos, ou talvez até mesmo seu switch.

Tem como configurar pra esse comando ser executado automaticamente na inicialização, inclusive pelo NetworkManager; mas eu só sei de cabeça como fazer isso no arquivo /etc/network/interfaces:

Código: [Selecionar]
auto eth0
iface eth0 inet dhcp
    pre-up /usr/local/bin/pre-up-eth0

No arquivo /etc/local/bin/pre-up-eth0 vc adiciona seus comandos:
Código: [Selecionar]
#!/bin/bash

/sbin/ethtool -s eth0 speed 100 duplex full autoneg on

Não esqueça de tornar esse arquivo executável:

sudo chmod +x /usr/local/bin/pre-up-eth0
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline BrunoGom3s

  • Usuário Ubuntu
  • *
  • Mensagens: 69
  • Ubuntu 11.04 ♥
    • Ver perfil
Re: [Video] Configuração de rede/internet
« Resposta #2 Online: 14 de MAR?O de 2014, 17:01 »
Segui o que você me passou e brickou o sistema, não inicializava mais, tive que reinstalar. Continuo com o mesmo problema, sempre que inicia preciso executar esse mesmo comando.

Alguém me ajuda.   :'(
Vivendo e aprendendo.

Offline BrunoGom3s

  • Usuário Ubuntu
  • *
  • Mensagens: 69
  • Ubuntu 11.04 ♥
    • Ver perfil
Re: [Video] Configuração de rede/internet
« Resposta #3 Online: 14 de MAR?O de 2014, 17:09 »
Solução:

Acesse esse arquivo como root.

etc/rc.local.sh

Coloquei o comando lá e deu tudo certo!

Agradeço pelo seu esforço zekkerJ!
Vivendo e aprendendo.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: (Resolvido) [Video] Configuração de rede/internet
« Resposta #4 Online: 14 de MAR?O de 2014, 18:47 »
Em uma palavra: impossível. Havia outro problema qualquer.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D