Autor Tópico: Solução para o FrostWire (não inicia)!  (Lida 8125 vezes)

Offline thiago e. de oliveira

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Solução para o FrostWire (não inicia)!
« Online: 01 de Novembro de 2006, 17:57 »
Achei no fórum gringo e não custa nada compartilhar, pois tenho certeza que existem várias pessoas nessa situação: instala o FrostWire, instala o Java, nenhum mensagem de erro durante as instalações e nada do FrostWire iniciar!

Se o Java estiver corretamente instalado, tente isso (no terminal):

Código: [Selecionar]
sudo gedit /usr/bin/frostwire

Altere a linha que contém "sh runFrost.sh" para "bash runFrost.sh". Tente carregar o FrostWire!  ;)

Comigo foi de primeira! ;D

Para se certificar de que o java está devidamente configurado, use esse comando (no terminal):

Código: [Selecionar]
update-alternatives --config java

Em seguida, aparecerá um menu como esse:

Código: [Selecionar]
Existem 2 alternativas que provêem`java'.

  Escolha de alternativa
-----------------------------------------------
          1    /usr/bin/gij-wrapper-4.1
*+        2    /usr/lib/jvm/java-1.5.0-sun/jre/bin/java

Pressione ENTER para manter o padrão[*], ou digite o número escolhido:

No meu caso, eu digitei "2" para usar a segunda opção como Java padrão.

Ah! Estou usando o Edgy, mas acredito que essa dica seja válida para o Dapper também, pois eu tinha o mesmo problema quando o usava. :)

Athlon XP 2600+ / MB ASUS A7N8X-DELUXE
Nvidia GeForce FX 5200 128MB/64bits
RAM 1.28 GB (Samsung)
HL-DT-ST DVDRAM GSA-4081B (gravador DVD)
Fonte Superflower (TTGI) 450W reais
HDD Samsung 160GB 7200 RPM SATA
Modem ADSL D.Link DSL-500T (Speedy)
Registered Linux User # 423742
Registered Ubuntu User # 4182

arlei

  • Visitante
Re: Solução para o FrostWire (não inicia)!
« Resposta #1 Online: 01 de Novembro de 2006, 21:36 »
thiago e. de oliveira,

baixei e instalei o frostwire, porém não rodava devido a erro com o java. Achei seu post e vi a dica para configurar o java com o comando update-alternatives --config java, escolhi a opção desejada e agora ta funcionando, porém estou com problema no firewall do meu roteador, ou seja, tenho que liberar nele a porta necessária para poder conectar corretamente.
Pergunto, vc sabe qual porta ou portas TCP/UDP o frostwire utiliza?

Valeu pela dica.  ;)
T+
Arlei