Autor Tópico: VLC se perde nas legendas [resolvido]  (Lida 6834 vezes)

Offline Hawker Hurricane AII

  • Usuário Ubuntu
  • *
  • Mensagens: 153
    • Ver perfil
    • Software Livre Vale do Sinos
VLC se perde nas legendas [resolvido]
« Online: 09 de Dezembro de 2006, 19:34 »
Olá

Utilizo o VLC para reproduzir vídeos e filmes aqui em casa. Ele funciona muito bem, diga-se de passagem. No entanto de uns tempos pra cá reparei que um problema começou a ocorrer. Ele se perde nas legendas. Ou seja, eu abro um filme com legendas em formato srt e ambos os arquivos, tanto o vídeo como a legenda com o mesmo nome. O que acontece é que ele não exibe a legenda às vezes. Por exemplo: Ele abre o filme e começa tudo certo, as legandas aparecendo e tudo mais. Do nada as legendas param de aparecer, voltando a aparecer logo em seguida. E isso fica o filme todo.

Sei que não é problema nas legendas, pois já havia assistido o mesmo filme com o mesmo arquivo de legenda antes e tudo funcionava 100%. E se eu abro o arquivo com outro player, as legendas aparecem perfeitamente. Só que prefiro usar o VLC, que é bem rápido e muito bom.

Alguém tem alguma idéia?

Valeu
« Última modificação: 09 de Dezembro de 2006, 22:09 por Hawker Hurricane AII »
Luftwaffe Flugzeugführer

Data Storage @ sda2 80GB
Ubuntu Edgy Eft 6.10 @ sdb1 250GB
Linux User #401658 @ counter.li.org

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.068
    • Ver perfil
    • Alexsandro Felix
Re: VLC se perde nas legendas
« Resposta #1 Online: 09 de Dezembro de 2006, 19:37 »
Eu estava com um problema parecido, daí percebi que os nomes dos arquivos não estavam iguais, quer dizer, para antigo usuário windows como eu era, eles estavam ok, mas o linux é "case sensitive", ou seja, uma letra maiúscula ou minúscula faz toda a diferença. Depois que eu deixei tudo realmente igual, mudando apenas as extensões, o VLC voltou a funcionar corretamente.

Offline Hawker Hurricane AII

  • Usuário Ubuntu
  • *
  • Mensagens: 153
    • Ver perfil
    • Software Livre Vale do Sinos
Re: VLC se perde nas legendas
« Resposta #2 Online: 09 de Dezembro de 2006, 20:27 »
Pois é Felix. Sei disso, no entanto não é esta a causa do problema. Posso garantir, pois agora mesmo verifiquei os nomes, e pra ter certeza ainda selecionei o arquivo do vídeo e dei um F2. Ele seleciona apenas o nome do arquivo (sem a extensão) e renomeei o arquivo. O filme roda beleza, mas as legandas continuam aparecendo e desaparecendo. Segue um trecho da legenda:
Citar
1
00:00:05,000 --> 00:00:12,000

2
00:00:12,001 --> 00:00:18,001

3
00:00:19,183 --> 00:00:21,342
Chapeuzinho vermelho.

4
00:00:21,394 --> 00:00:23,427
Você deve conhecer a história.

5
00:00:23,479 --> 00:00:26,482
Mas todo conto é muito mais
do que apenas aquilo que se vê.

6
00:00:26,534 --> 00:00:28,432
É como sempre dizem:

7
00:00:28,484 --> 00:00:30,987
Não dá para julgar
um livro por sua capa.

8
00:00:31,039 --> 00:00:33,281
Se quiser saber a verdade.

9
00:00:33,333 --> 00:00:36,617
Tem que folhear.

Então não sei o que pode estar havendo. Obrigado pela ajuda.
Luftwaffe Flugzeugführer

Data Storage @ sda2 80GB
Ubuntu Edgy Eft 6.10 @ sdb1 250GB
Linux User #401658 @ counter.li.org

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.068
    • Ver perfil
    • Alexsandro Felix
Re: VLC se perde nas legendas
« Resposta #3 Online: 09 de Dezembro de 2006, 20:33 »
Infelizmente não tenho idéia, pois o meu problema foi solucionado dessa forma mesmo, pelo nome dos arquivos, claro que para não ter nenhuma dúvida eu não os digitei, fiz como vc disse, "F2" para renomear,  copiei o nome do arquivo original, deixei como estava, dei um "F2" no arquivo de legenda e colei....

Quem sabe alguém mais possa dar outra opinião...

Offline Hawker Hurricane AII

  • Usuário Ubuntu
  • *
  • Mensagens: 153
    • Ver perfil
    • Software Livre Vale do Sinos
Re: VLC se perde nas legendas
« Resposta #4 Online: 09 de Dezembro de 2006, 20:41 »
Pois vou tentar uma remoção completa do pacote. Não achei nenhuma configuração sobre isso no programa, mas vamos ver se não é uma questão de algum arquivo de configuração escondido. Acho que se for isso a remoção completa deve resolver.

Depois posto o resultado. Enquanto isso quem tiver alguma idéia, por favor, me dê uma luz.

Obrigado

Editando:

Resolvi o problema. Depois de ter removido o programa por completo e não ter adiantado, só poderia ser uma configuração padrão que estava causando o transtorno. Um recurso ótimo mas que desconhecia me ajudou e muito a descobrir a solução (por isso gosto do VLC hehehe). Abri o programa e abrir o filme. Deu o erro e fui olhando os menus até que entrei em "Visão" > "Mensagens". Ali me apareceu claro como a luz do sol o motivo para que as legendas desaparecessem do nada e voltassem a aparecer. A mensagem:
Citar
subsdec error: failed to convert subtitle encoding.
Try manually setting a character-encoding before you open the file.

Depois foi só escolher a codificação correta da legenda, no caso foi ISO-8859-1 e mandar ver. Tudo certo agora.

A única coisa estranha é que antes eu nunca precisei escolher a codificação, mesmo para este filme. Já tinha olhado ele algumas vezes e nunca tive problemas. Mas então fica a dica, problemas com a legenda, verifiquem a codificação.

Obrigado pela ajuda Felix.

Valeu
« Última modificação: 09 de Dezembro de 2006, 21:07 por Hawker Hurricane AII »
Luftwaffe Flugzeugführer

Data Storage @ sda2 80GB
Ubuntu Edgy Eft 6.10 @ sdb1 250GB
Linux User #401658 @ counter.li.org

Offline Rwainder Miller

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil
Re: VLC se perde nas legendas
« Resposta #5 Online: 10 de Dezembro de 2006, 07:53 »
Pois vou tentar uma remoção completa do pacote. Não achei nenhuma configuração sobre isso no programa, mas vamos ver se não é uma questão de algum arquivo de configuração escondido. Acho que se for isso a remoção completa deve resolver.

Depois posto o resultado. Enquanto isso quem tiver alguma idéia, por favor, me dê uma luz.

Obrigado

Editando:

Resolvi o problema. Depois de ter removido o programa por completo e não ter adiantado, só poderia ser uma configuração padrão que estava causando o transtorno. Um recurso ótimo mas que desconhecia me ajudou e muito a descobrir a solução (por isso gosto do VLC hehehe). Abri o programa e abrir o filme. Deu o erro e fui olhando os menus até que entrei em "Visão" > "Mensagens". Ali me apareceu claro como a luz do sol o motivo para que as legendas desaparecessem do nada e voltassem a aparecer. A mensagem:
Citar
subsdec error: failed to convert subtitle encoding.
Try manually setting a character-encoding before you open the file.

Depois foi só escolher a codificação correta da legenda, no caso foi ISO-8859-1 e mandar ver. Tudo certo agora.

A única coisa estranha é que antes eu nunca precisei escolher a codificação, mesmo para este filme. Já tinha olhado ele algumas vezes e nunca tive problemas. Mas então fica a dica, problemas com a legenda, verifiquem a codificação.

Obrigado pela ajuda Felix.

Valeu
como se faz para mudar a codificação? to com o mesmo problema mas não vejo opção para mudar a codificação do vídeo se puder me ajudar,valeu


Offline Hawker Hurricane AII

  • Usuário Ubuntu
  • *
  • Mensagens: 153
    • Ver perfil
    • Software Livre Vale do Sinos
Re: VLC se perde nas legendas [resolvido]
« Resposta #6 Online: 10 de Dezembro de 2006, 15:38 »
Opa

Para abrir o arquivo não use a opção Quick Open File, e sim apenas Open File. Isso vai lhe exibir uma janela com mais opções. Então aponte o caminho do vídeo e depois da legenda. Quando tu marcar o checkbox "Usar arquivo de legendas" um botão ao lado será ativado. Então clique em "Advanced Settings" e dentro desta terceira janela a primeira opção é a codificação.

Espero que ajude.

Falou
Luftwaffe Flugzeugführer

Data Storage @ sda2 80GB
Ubuntu Edgy Eft 6.10 @ sdb1 250GB
Linux User #401658 @ counter.li.org

ginho

  • Visitante
Re: VLC se perde nas legendas [resolvido]
« Resposta #7 Online: 10 de Dezembro de 2006, 16:14 »
Cara, tua dica funcionou inclusive com o arquivo de legenda SRC de nome diferente do AVI
Obrigado.
Agora tenho 2 filmes para assistir.

Offline engleo

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: VLC se perde nas legendas [resolvido]
« Resposta #8 Online: 24 de Maio de 2007, 13:40 »
 :D CARA VALEW PELA DICA...
VIVA O LINUX...