Autor Tópico: Problema wireless toshiba AS-1528  (Lida 48537 vezes)

libonati

  • Visitante
Re: Problema wireless toshiba AS-1528
« Resposta #15 Online: 24 de Junho de 2010, 09:13 »
Roteador D-Link-DI524G 802.11g/2.4GHz. E o modelo do modem? Sua operadora (net,oi,etc...)?
« Última modificação: 24 de Junho de 2010, 09:16 por libonati »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema wireless toshiba AS-1528
« Resposta #16 Online: 24 de Junho de 2010, 10:27 »
O ubuntu foi inicializado normalmente, e com o ícone de conexão wireless na parte superior direita da tela, que reconheceu a rede wireless, mas não conectava!!!
Após instalado, conectei via cabo na net, e baixei as atualizações... Acredito que isso não é um erro, estou certo???
Reiniciei o Ubuntu e o ícone de wireless havia desaparecido!!! Entrei em sistema>admin.>gerenciar redes... Porem, mais uma vez não consegui conectar via wireless.
Bom, agora o Ubuntu está como novo, rs... Sem nenhum pacote instalado, a não ser os da atualização. E não tem mais o ndiswrapper instalado.

zekkerj Não executei o comando sudo lshw -C network, pelo motivo de haver instalado tudo novamente... Também não executei o sudo modprobe -r ndiswrapper, já que o ndiswrapper não estava instalado.
A saída do "lshw" seria importante, pra gente ver se o wireless está ativo ou desabilitado (que o módulo está carregado eu já vi, conforme abaixo).

Pode postar também a saída do comando "nm-tool", também vai ajudar.

Citar
Agora os outros comandos:

Código: [Selecionar]
pirata@Note-Toshiba:~$ lsmod | grep ath
ath5k                 121792  0
mac80211              204922  1 ath5k
ath                     7611  1 ath5k
cfg80211              126485  3 ath5k,mac80211,ath
led_class               2864  1 ath5k
Eis os módulos que tinham que aparecer.

Citar
Código: [Selecionar]
pirata@Note-Toshiba:~$ iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
A interface está aí, mas ainda não aparece como configurada.

Citar
Código: [Selecionar]
pirata@Note-Toshiba:~$ ifconfig
eth0      Link encap:Ethernet  Endereço de HW 00:14:0b:07:f9:42  
          endereço inet6: fe80::214:bff:fe07:f942/64 Escopo:Link
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:1041 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:753 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:1352917 (1.3 MB) TX bytes:72473 (72.4 KB)
          IRQ:17 Endereço de E/S:0xa000

lo        Link encap:Loopback Local  
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:716 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:716 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:55408 (55.4 KB) TX bytes:55408 (55.4 KB)

[b]wlan0     Link encap:Ethernet  Endereço de HW 00:12:bf:3c:5e:07  
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
[/b]
Novamente confirmando a informação.

Citar
zekkerj, Desde já agradeço muito a força que vc tem dado. E se vc achar necessário, posso reinstalar todo o Ubuntu novamente, prefiro que não, mas se vc julgar necessário pode falar.
Uso o roteador D-Link-DI524G 802.11g/2.4GHz. Uso chave WEP.
Não, não precisa reinstalar. Foi uma opção radical, mas por outro lado você eliminou de uma tacada só todas as variáveis --- agora temos um sistema limpo pra trabalhar.

Só não gostei dessa última informação. O DI-524 é um dos piores roteadores que a DLink já fez, se não o pior. Há uma grande chance dele ser o verdadeiro vilão por trás do seu problema. Mas por enquanto vamos fingir/acreditar que ele funciona.  ::)

Mais alguns testes, por favor:

sudo iwconfig wlan0 txpower on
iwlist wlan0 scan
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline pirata29

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Problema wireless toshiba AS-1528
« Resposta #17 Online: 24 de Junho de 2010, 15:44 »
Bom, meu modem é um Thonsom e a operadora é a Speedy/Telefonica.

Agora seguem os comandos...

Citar
pirata@Note-Toshiba:~$ sudo lshw -C network
[sudo] password for pirata:
  *-network:0             
       description: Wireless interface
       product: AR2413 802.11bg NIC
       vendor: Atheros Communications Inc.
       physical id: a
       bus info: pci@0000:08:0a.0
       logical name: wlan0
       version: 01
       serial: 00:12:bf:3c:5e:07
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k latency=168 maxlatency=28 mingnt=10 multicast=yes wireless=IEEE 802.11bg
       resources: irq:19 memory:c0200000-c020ffff
  *-network:1
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: d
       bus info: pci@0000:08:0d.0
       logical name: eth0
       version: 10
       serial: 00:14:0b:07:f9:42
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=64 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10MB/s
       resources: irq:17 ioport:a000(size=256) memory:c0210800-c02108ff
pirata@Note-Toshiba:~$ nm-tool

NetworkManager Tool

State: connected

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath5k
  State:             disconnected
  Default:           no
  HW Address:        00:12:BF:3C:5E:07

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points
    Sacal:           Infra, 00:17:9A:FD:B3:21, Freq 2412 MHz, Rate 54 Mb/s, Strength 71 WEP


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            8139too
  State:             unmanaged
  Default:           no
  HW Address:        00:14:0B:07:F9:42

  Capabilities:
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Properties
    Carrier:         off


pirata@Note-Toshiba:~$ sudo iwconfig wlan0 txpower on
pirata@Note-Toshiba:~$ iwlist wlan0 scan
wlan0     No scan results

pirata@Note-Toshiba:~$

Após digitar todos esses comandos, digitei novamente o ¨iwconfig¨, para ver o estado a rede após o comando ¨txpower on¨, mas nada mudou...
Dentre tantos outros tutoriais que ví, uns diziam que poderia ser algum erro de configuração de ¨IPv6¨, que não é usado mas o driver insiste em forçar... Seria esse o problema???
Outra sugestão é a configuração de ¨IPv4¨.... ???
Bom, como sou leigo, posso estar falando besteiras, mas vou postar as informações de rede que colhi no windows:

Citar
C:\Documents and Settings\User>ipconfig /all

Configuração de IP do Windows

        Nome do host . . . . . . . . . . . : MARYSP
        Sufixo DNS primário. . . . . . . . :
        Tipo de nó . . . . . . . . . . . . : desconhecido
        Roteamento de IP ativado . . . . . : não
        Proxy WINS ativado . . . . . . . . : não

Adaptador Ethernet Conexão local:

        Estado da mídia . . . . . . . . . . . : mídia desconectada
        Descrição . . . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Et
hernet NIC
        Endereço físico . . . . . . . . . . : 00-14-0B-07-F9-42

Adaptador Ethernet Conexão de rede sem fio:

        Sufixo DNS específico de conexão  . :
        Descrição . . . . . . . . . . . . . : Atheros AR5005G Wireless Network A
dapter
        Endereço físico . . . . . . . . . . : 00-12-BF-3C-5E-07
        DHCP ativado. . . . . . . . . . . . : Sim
        Configuração automática ativada . . : Sim
        Endereço IP . . . . . . . . . . . . : 192.168.0.102
        Máscara de sub-rede . . . . . . . . : 255.255.255.0
        Gateway padrão. . . . . . . . . . . : 192.168.0.1
        Servidor DHCP . . . . . . . . . . . : 192.168.0.1
        Servidores DNS. . . . . . . . . . . : 200.204.0.10
                                            192.168.0.1
        Concessão obtida. . . . . . . . . . : quinta-feira, 24 de junho de 2010
15:30:47
        Concessão expira. . . . . . . . . . : quinta-feira, 1 de julho de 2010 1
5:30:47

C:\Documents and Settings\User>

Mais uma vez, e quantas forem necessárias, obrigado pela sua boa vontade.
Abraço

libonati

  • Visitante
Re: Problema wireless toshiba AS-1528
« Resposta #18 Online: 24 de Junho de 2010, 18:05 »
Qual o modelo do modem?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema wireless toshiba AS-1528
« Resposta #19 Online: 24 de Junho de 2010, 19:01 »
Citar
NetworkManager Tool

State: connected

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath5k
  State:             disconnected
  Default:           no
  HW Address:        00:12:BF:3C:5E:07

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points
    Sacal:           Infra, 00:17:9A:FD:B3:21, Freq 2412 MHz, Rate 54 Mb/s, Strength 71 WEP

essa saída é muito interessante, mostra que seu AP foi detectado.

Não quer insistir um pouco mais no Gerenciador de Redes? Ou talvez até mesmo instalar o WiCD, no lugar no NetworkManager (se vc não pretende usar modem 3G).
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline pirata29

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Problema wireless toshiba AS-1528
« Resposta #20 Online: 28 de Junho de 2010, 20:12 »
Putz, não acredito que não tem ninguém que possa me ajudar!!!
Tenho um note Toshiba, com placa Atheros, Modem Thonsom SpeedTouch V6, roteador D-link 524...
Ubuntu 10.04 instalado, funcionando tudo, menos wireless....
Rede wireless detectada... Eu no alto da minha experiência em Linux acredito que seja algum problema no arquivo interfaces!!!
Alguém ajude!!! por favor!!! já vou completar uma semana sem conseguir resolver o problema... tentando todos os tutoriais da net!!!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema wireless toshiba AS-1528
« Resposta #21 Online: 29 de Junho de 2010, 02:28 »
Você chegou a tentar o que eu sugeri no último post?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline pirata29

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Problema wireless toshiba AS-1528
« Resposta #22 Online: 29 de Junho de 2010, 07:18 »
zekkerj, desinstalei todo o NetworkManager. Entrei no Sistema>Administração>Gerenciados de Pacotes Synaptc...
Procurei tudo que se referia ao NetworkManager e mandei desisnstalar. Procurei pelo Wicd e instalei...
E mesmo assim nada. Já reinstalei o Ubuntu novamente, já escolhi pacotes diferentes no repositório, já tentei forçar o madwifi, já tentei pelo ndiswrapper...
Segui um tuto para instalar manualmente, mas quando dou o comando dhclient.... isso que aparece ¨noworking leases in persistent database - sleeping¨...
Já não sei mais o que tentar... Creio que o problema é a configuração no arquivo interfaces.
Se puder dê uma força, Abraço

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema wireless toshiba AS-1528
« Resposta #23 Online: 29 de Junho de 2010, 15:15 »
Se você acha que há problema no arquivo /etc/network/interfaces, apague-o.

Eu devo ter comentado, antes, que o NetworkManager não usa esse arquivo, pelo contrário, se ele encontra algo configurado por lá, ele considera o dispositivo "não-gerenciável".

Só tem uma coisa: as tentativas estão se acumulando, e os resíduos delas também. Seria conveniente reinstalar o sistema antes de tentar prosseguir, de preferência formatando as partições. Assim partimos de um ponto conhecido e controlado.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline pirata29

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Problema wireless toshiba AS-1528
« Resposta #24 Online: 29 de Junho de 2010, 15:40 »
Ok, vou formatar novamente a partição e instalar de novo o Ubuntu... Mas hj tive um problema com meu celular e a rede Wireless aqui de casa... Meu celular não conseguiu se conectar, pq deixei a senha Wep da minha rede com apenas 5 carcteres...Antes era um WEP Hexadecimal, e conectava normalmente... Meu celular é um N95, usa sistema Symbian, que acredito é derivado do Linux, correto??? Estou achando que esses problemas que estou tendo é por causa do sistema WEP/ASCII
O que vc acha???

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema wireless toshiba AS-1528
« Resposta #25 Online: 29 de Junho de 2010, 16:49 »
Eu não gosto de WEP por ser muito frágil. Sempre que posso uso WPA2, do contrário WPA.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline cabruca

  • Usuário Ubuntu
  • *
  • Mensagens: 88
    • Ver perfil
Re: Problema wireless toshiba AS-1528
« Resposta #26 Online: 30 de Junho de 2010, 01:36 »
Cara, tive uns perrengues paracedos com meu Acer. Instalei e desinstalei. Inúmeros comandos de terminal. No final, resolvi assim.

1) Removi todos os drivers (no ndiswrapper e no Drivers de hardware), inclusive pelo synaptic.

2) Removi o Network Manager.

3) Reinstalei o ndiswrapper

4) Reinstalei o driver com o cd original da máquina, que funcionava no ruindows.

5) Instalei o Wicd para substituir o NM.

Espero que ajude.

Offline rjbgbo

  • Usuário Ubuntu
  • *
  • Mensagens: 3.889
  • Xubuntu 18.04LTS
    • Ver perfil
    • Twitter
Re: Problema wireless toshiba AS-1528
« Resposta #27 Online: 30 de Junho de 2010, 07:25 »
Eu não gosto de WEP por ser muito frágil. Sempre que posso uso WPA2, do contrário WPA.

zekkerj, se eu aplicar a mesma senha e login usado no wep terei problemas em trocar p/ o wap2?
Linux User #440843 | Ubuntu User #11469

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema wireless toshiba AS-1528
« Resposta #28 Online: 30 de Junho de 2010, 10:06 »
Olha, a senha WPA não tem as mesmas limitações do WEP, vc pode usar qq tamanho de senha, e qq caracter na senha. Isso significa que vc pode fazer senhas muito mais fortes.

Como vc vai ter mesmo que mexer na configuração da criptografia, nas estações, vc pode até manter a mesma senha, mas não há vantagem nenhuma nisso.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline rjbgbo

  • Usuário Ubuntu
  • *
  • Mensagens: 3.889
  • Xubuntu 18.04LTS
    • Ver perfil
    • Twitter
Re: Problema wireless toshiba AS-1528
« Resposta #29 Online: 30 de Junho de 2010, 10:18 »
Olha, a senha WPA não tem as mesmas limitações do WEP, vc pode usar qq tamanho de senha, e qq caracter na senha. Isso significa que vc pode fazer senhas muito mais fortes.

Como vc vai ter mesmo que mexer na configuração da criptografia, nas estações, vc pode até manter a mesma senha, mas não há vantagem nenhuma nisso.

muito obrigado, qdo puder vou ver isso aqui no meu notebook
já havia lido sobre a segurança do protocolo wep, mas sempre fiquei preocupado em mudar e ter certas dores de cabeça no ubuntu.
Linux User #440843 | Ubuntu User #11469