Autor Tópico: Configure error  (Lida 16108 vezes)

Offline pain of salvation

  • Usuário Ubuntu
  • *
  • Mensagens: 24
    • Ver perfil
Configure error
« Online: 01 de Junho de 2006, 10:43 »
Pessoal, estou tentando instalar o tema rezlooks: http://www.gnome-look.org/content/show.php?content=39179

quando dou um ./configure, aparece no final esta mensagem: checking for GTK... configure: error: GTK+-2.8 is required to compile rezlooks


Alguém pode me ajudar?

Tou usando o Dapper Drake final.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.683
    • Ver perfil
Configure error
« Resposta #1 Online: 01 de Junho de 2006, 13:50 »
É fácil. Vou te dar a rede pra ver se você aprende a pescar!

Quando você executa o ./configure, ele vai verificar se você possui as dependências para poder compilar o pacote. Nem sempre você precisa de todos. Mas quando ele descobre que falta um que não pode faltar, ele pára o processo e te mostra o que está faltando. Neste caso, o GTK+-2.8.

Quando você compila um programa você precisa das bibliotecas de desenvolvimento, mas nem sempre também. Então você pode procurar no Synaptic pelo pacote que está faltando, dentro da pasta onde você está compilando tem um arquivo com a saída do ./configure se você quiser ver lá também.

Agora é com você!
BigLinux no Notebook  / Várias Distros Virtualizadas no PC.