Autor Tópico: LAMP no 6.05  (Lida 4579 vezes)

Offline jcao

  • Usuário Ubuntu
  • *
  • Mensagens: 178
    • Ver perfil
LAMP no 6.05
« Online: 29 de Julho de 2006, 12:20 »
Pessoal, li o tutorial em https://help.ubuntu.com/community/ApacheMySQLPHP
está muito bom, mas o problema é que por questão de compatibilidade e de versões do
PHP, MySQL e Apache preciso das versões
PHP 4
MySQL 4
Apache 1.3
As versões do tutorial irão criar incompatibilidades com as aplicações desenvolvidas ou já em
produção.
Existe alguma dica para isto?

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: LAMP no 6.05
« Resposta #1 Online: 01 de Agosto de 2006, 14:04 »
Utilizar programas tão antigos não é boa ideia, porque têm mais problemas de segurança e porque vai ser dificil encontrar ajuda para eles, tem um forte motivo para utilizar essas versões ? Especialmente Apache 1 ?
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu

Offline jcao

  • Usuário Ubuntu
  • *
  • Mensagens: 178
    • Ver perfil
Re: LAMP no 6.05
« Resposta #2 Online: 10 de Agosto de 2006, 10:30 »
O motivo de ter que instalar as versões 4 do PHP e do MySQL e o Apache 1.3 é que os provedores das aplicações ainda utilizam estas versões. Já tentamos usar as novas versões mas, surgiram problemas de incompatibilidade, ou seja, funciona nos testes mas depois começam a surgir problemas na produção.
 

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: LAMP no 6.05
« Resposta #3 Online: 10 de Agosto de 2006, 13:11 »
Citar
Pessoal, li o tutorial em https://help.ubuntu.com/community/ApacheMySQLPHP
está muito bom, mas o problema é que por questão de compatibilidade e de versões do
PHP, MySQL e Apache preciso das versões
PHP 4
MySQL 4
Apache 1.3
As versões do tutorial irão criar incompatibilidades com as aplicações desenvolvidas ou já em
produção.
Existe alguma dica para isto?
Se precisa desse conjunto de versões em particular não vale a pena seguir o tutorial, vai criar conflitos sim, porque esses serviços, mais concretamente o MySQL e o Apacahe utilizariam a mesma porta para ambas as versões.
Penso que não existem pacotes para Dapper com essas versões por isso vai ter que instalar tudo compilando manualmente...
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu