Autor Tópico: synaptic, packages .. e pequena duvida ..  (Lida 2650 vezes)

_rAv_

  • Visitante
synaptic, packages .. e pequena duvida ..
« Online: 30 de Julho de 2006, 00:35 »
oi td mundo,
é o seguinte, algumas vezes os pacotes mais novos dos programas nao sao encontrados nos repositorios do ubuntu, e pra isso é preciso compilar direto dos sources para se ter as versoes mais novas ..
um exemplo disso é o amsn com suporte a anti-aliasing .. ate ai sem nenhum problema, soh pegar os fontes do tcl e tk compilar e usar os novos recursos .. soh que para o apt e synaptic eles continuam sem estar instalados .. e caso eu queira pegar algum programa que utilize o tk/tcl o synatic vai ficar acusando a falta da dependencia e vai querer pegar a versao mais antiga delas (que é a que está nos repositorios)

a mesma coisa com o kernel, porem pro kernel eu posso utilizar o kernel-package e criar os packages e instalar, ainda nao testei mas acredito que deva funcionar ..

a duvida é como fazer esses packages pra outros programas .. por exemplo o proprio tcl e tk 8.5 se alguem puder dar uma explicada rapida .. ou mostrar algum guia

valeu ae .. paz !!

boi

  • Visitante
Re: synaptic, packages .. e pequena duvida ..
« Resposta #1 Online: 30 de Julho de 2006, 11:16 »
Se você gosta de compilar e instalar tudo na mão, acho que o melhor que você tem a fazer é mudar para uma outra distro, como o Slackware ou o Gentoo. No Ubuntu, se você for ficar fazendo isso, principalmente com bibliotecas, o que vai acontecer é que você vai acabar bagunçando todo o sistema. Experimente o Slackware.

_rAv_

  • Visitante
Re: synaptic, packages .. e pequena duvida ..
« Resposta #2 Online: 30 de Julho de 2006, 16:09 »
esse é um dos problemas eu nao sei exatamente o que pegar principalmente as dependencias e tal .. (sou nb em linux)
eu até ja testei o slack aqui, mas ele fez uma instalacao mto cheia de coisa, gastou quase 3gb ..
e por ser novato eu acho q se eu tiver de fazer tudo na mão vai ficar uma confusão mto maior ..
um exemplo é que o slack instalou o tcl e o tk 8.4 e se eu quiser atualiza-los pro 8.5 eu nao sei como faco pra remover esses 8.4 ja que nao tem um gerenciador de pacote e sao mtos arquivos espalhavos em varias pastas (se alguem puder me explicar como se faz essa remocao vai ser util também)(novato eh soda hehe qq coisa eh uma duvida, curiosidade acima de td)

outra duvida aproveitando o topico,
eu compilei o kernel 2.6.17.7 e instalei aqui .. td funcionou certinho, mais o driver da nvidia nao deu ..
tentei usar o instalador pra ver se compila os modulos restritos, mas deu um erro ..

esse driver da nvidia realmente nao funciona com esse kernel por causa dos restricted-modules ou eu esqueci de colocar alguma coisa da nvidia na hora de compilar o kernel ?!?!

abraço ai td mundo .. e paz !!

_rAv_

  • Visitante
Re: synaptic, packages .. e pequena duvida ..
« Resposta #3 Online: 30 de Julho de 2006, 18:02 »
pra quem tem as mesmas duvidas,

dei uma pesquisada aqui e achei o utilitario checkinstall (# apt-get install checkinstall), que cria um pacote para os programas que vc está compilando, isso não resolve o problema das dependencias mas pelo menos facilita e organiza as coisas caso vc queira remover futuramente as coisas que vc compilar.

ahh e descobri que o mesmo procedimento é feito no slackware utilizando o checkinstall e o pkgtool, portanto ignorem essa ultima pergunta ..

boi

  • Visitante
Re: synaptic, packages .. e pequena duvida ..
« Resposta #4 Online: 30 de Julho de 2006, 18:13 »
Como você já descobriu, o Slack também tem um gerenciador de pacotes, embora seja um pouco primitivo e funcione apenas pelo console. Existem também gerenciadores de pacotes não oficiais, mais modernos, que permitem inclusive a atualização via internet, como o netpkg e o slackpkg. Dá uma passada nessa página, lá você encontra muita informação sobre o Slack:

http://piterpunk.info02.com.br

Outra opção bem legal é o Gentoo, nele você compila absolutamente tudo:

http://gentoobr.org/modules/news

Offline gpr

  • Usuário Ubuntu
  • *
  • Mensagens: 98
    • Ver perfil
    • www.gpr.ppg.br
Re: synaptic, packages .. e pequena duvida ..
« Resposta #5 Online: 22 de Outubro de 2008, 22:00 »
outra duvida aproveitando o topico,
eu compilei o kernel 2.6.17.7 e instalei aqui .. td funcionou certinho, mais o driver da nvidia nao deu ..
tentei usar o instalador pra ver se compila os modulos restritos, mas deu um erro ..

esse driver da nvidia realmente nao funciona com esse kernel por causa dos restricted-modules ou eu esqueci de colocar alguma coisa da nvidia na hora de compilar o kernel ?!?!

compilei o kernel no meu notebook e nao funciona mais NVIDIA nem som ;-(

gustavo@movel:~$ uname -r
2.6.27-gpr-01

que fiz?
que faço?

Ubuntu + Gimp + InkScape + Netbeans + Cssed = Livre.
www.gpr.ppg.br