Autor Tópico: Wireless Ubuntu 12.04  (Lida 35284 vezes)

Offline vctrin

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Wireless Ubuntu 12.04
« Resposta #45 Online: 09 de Julho de 2012, 21:31 »
Olá,

Também tive este mesmo problema com a conexão via Wi-Fi no meu Ubuntu 12.04. Segui as orientações do elias_goiano, reiniciei o Sistema e voltou a funcionar perfeitamente. Valeu! Muito obrigado!

Cordialmente,

Valmir

Offline JULIANA GONÇALVES

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Wireless Ubuntu 12.04
« Resposta #46 Online: 15 de Outubro de 2012, 15:19 »
Galera fiz isto que vcs indicaram mas mesmo assim não voltou a funcionar!! Helppppp!! :'(

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Wireless Ubuntu 12.04
« Resposta #47 Online: 15 de Outubro de 2012, 18:54 »
Execute os comandos abaixo e cole o resultado aqui.

sudo lshw -C network
iwconfig
ifconfig -a
nm-tool
rfkill list wifi
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline sonhandocomlinux

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Wireless Ubuntu 12.04
« Resposta #48 Online: 02 de Dezembro de 2012, 23:24 »
icaro@Icaro ~ $ sudo lshw -C network
  *-network               
       descrição: Interface sem fio
       produto: BCM4312 802.11b/g LP-PHY
       fabricante: Broadcom Corporation
       physical id: 0
       informações do barramento: pci@0000:02:00.0
       nome lógico: eth1
       versão: 01
       serial: 00:24:2c:0e:d9:79
       largura: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=wl0 driverversion=5.100.82.112 ip=192.168.1.104 latency=0 multicast=yes wireless=IEEE 802.11bg
       recursos: irq:18 memória:f0300000-f0303fff
  *-network
       descrição: Ethernet interface
       produto: AR8132 Fast Ethernet
       fabricante: Atheros Communications Inc.
       physical id: 0
       informações do barramento: pci@0000:05:00.0
       nome lógico: eth0
       versão: c0
       serial: 00:26:22:6b:e2:a9
       tamanho: 100Mbit/s
       capacidade: 100Mbit/s
       largura: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full ip=192.168.1.102 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       recursos: irq:42 memória:f0200000-f023ffff ioport:a000(tamanho=128)
icaro@Icaro ~ $ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11  Access Point: Not-Associated   
          Link Quality:5  Signal level:217  Noise level:199
          Rx invalid nwid:0  invalid crypt:0  invalid misc:0

icaro@Icaro ~ $ ifconfig -a
eth0      Link encap:Ethernet  Endereço de HW 00:26:22:6b:e2:a9 
          inet end.: 192.168.1.102  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: fe80::226:22ff:fe6b:e2a9/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:105 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:156 erros:0 descartados:0 excesso:0 portadora:1
          colisões:0 txqueuelen:1000
          RX bytes:13631 (13.6 KB) TX bytes:23474 (23.4 KB)

eth1      Link encap:Ethernet  Endereço de HW 00:24:2c:0e:d9:79 
          inet end.: 192.168.1.104  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: fe80::224:2cff:fe0e:d979/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:4643 erros:0 descartados:0 excesso:0 quadro:247
          Pacotes TX:3819 erros:12 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:5112257 (5.1 MB) TX bytes:552949 (552.9 KB)
          IRQ:18

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:16 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:16 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:1232 (1.2 KB) TX bytes:1232 (1.2 KB)

icaro@Icaro ~ $ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            atl1c
  State:             unmanaged
  Default:           no
  HW Address:        00:26:22:6B:E2:A9

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on


- Device: eth1  [linksys Automático(a)] ---------------------------------------
  Type:              802.11 WiFi
  Driver:            wl
  State:             connected
  Default:           yes
  HW Address:        00:24:2C:0E:D9:79

  Capabilities:
    Speed:           54 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    ptp_prefeitura:  Infra, 00:02:6F:52:9B:BB, Freq 2417 MHz, Rate 11 Mb/s, Strength 24
    WIbiritenet-Empresas: Infra, 00:27:22:44:7C:C8, Freq 2427 MHz, Rate 0 Mb/s, Strength 24
    *linksys:        Infra, 00:25:9C:76:BC:95, Freq 2412 MHz, Rate 54 Mb/s, Strength 100 WPA WPA2

  IPv4 Settings:
    Address:         192.168.1.104
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             200.222.123.100
    DNS:             200.165.132.155


icaro@Icaro ~ $ rfkill list wifi
0: brcmwl-0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Wireless Ubuntu 12.04
« Resposta #49 Online: 03 de Dezembro de 2012, 00:37 »
Sonhandocomlinux, vc continua com problema com essa placa? Caramba, pensei que vc já tinha resolvido ou desistido.

Todo mundo, nos outros tópicos, resolve apenas instalando o firmware e removendo o driver proprietário.

sudo apt-get install --reinstall firmware-b43-lpphy-installer b43-fwcutter
sudo apt-get install --reinstall bcmwl-kernel-source
sudo apt-get remove bcmwl-kernel-source


Observe que o firmware tem que ser o mesmo do teu hardware, e há dois tipos, o comum (firmware-b43-installer) e o "Low Power" (firmware-b43-lpphy-installer). Por isso sempre é preciso confirmar o hardware pelo comando "lshw -C network".

Vez em quando, a instalação do driver proprietário bloqueia o driver nativo. Isso se resolve com os comandos:

grep b43 /etc/modules || echo b43 | sudo tee -a /etc/modules

Depois de executar esse comando vc tem que reiniciar a máquina.

Os outros colegas, em especial a JULIANA GONCALVES, por favor, antes de tentar alterar alguma coisa em sua máquina, execute os comandos de avaliação ("sudo lshw -C network", etc) e poste o resultado aqui, pra não piorar a situação.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline sonhandocomlinux

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Wireless Ubuntu 12.04
« Resposta #50 Online: 09 de Dezembro de 2012, 15:11 »
Oi Zekkerj

É... não adianta! nao funcionou denovo.
Instalei agora o Linux Mint 14, pra ver se funcionava (desde o último post), ms é o mesmo problema:
         1-wireless não consegue conectar, ou conecta e quando transmite 1 bit, cai; e
         2- o modo gráfico normal (com todos os recursos - no meu caso agora o cinnamon), trava se não estiver com o cabo de rede ligado
         2.1 - com o cabo ligado ele conecta, gera o sinal wireless e tudo mais. conecta inclusive se eu der "ifconfig eth0 down", desligando a ethernet e funcionando só com o wifi

não sei se os dois problemas tem alguma relação.. encontrei casos dos dois em separado, ms não muitos dos dois juntos.
o estranho é pensar que nenhuma das soluções que encontrei até agora, pra nenhum dos dois problemas, funcionou pra mim! (cagado de urubu)

Pois então, o fato é que:
     Ontem a noite consegui fazer a wireless funcionar instalando o driver do winxp pra minha placa (broadcom 4312 lp-pphy), q baixei no site da broadcom
instalei com o ndiswrapper, e pro meu gozo, dpois de meses o negócio funcionou.
     Aí reiniciei, pra testar, e pimba! funcionou denovo! só que dessa vez ele travou o cinnamon por causa da ausencia do cabo. Reiniciei com o cabo, e tirei dpois; normalmente travaria o cinnamon, mas funcionou.
Usei por horas..

Só que hoje liguei denovo e voltou ao que era antes. sem eu ter feito nada
agora instalei o proprietário aí que vc falou, e nao consigo mais voltar ao ponto em que parei ontem.. :/

Pensei em mudar de distro denovo, ms vi o erro acontecendo com outros no Fedora, no opensuse... vai mudar nada, eu acho.

Icaro

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Wireless Ubuntu 12.04
« Resposta #51 Online: 10 de Dezembro de 2012, 09:35 »
Cara, eu consideraria problema de hardware aí. Nunca vi placa Broadcomm precisar de driver Windows pra funcionar.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D