Autor Tópico: Modulo Segurança santander  (Lida 32181 vezes)

Offline gilbertoros

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
Modulo Segurança santander
« Online: 03 de MAR?O de 2013, 03:28 »
Olá, instalei o java runtime 1.8.0 no ubuntu 12.10 e funciona normalmente para acessar o BB no firefox, porem no banco santander pede para instalar modulo de segurança e quando clico em instalar , ele me manda para o site do java .
O que devo fazer?

Offline bmota

  • Usuário Ubuntu
  • *
  • Mensagens: 1.040
  • um ex-desocupado à procura de ajudar quem precisa.
    • Ver perfil
Re: Modulo Segurança santander
« Resposta #1 Online: 03 de MAR?O de 2013, 11:59 »
olá, se usas o openjdk, veja se tu tem o icedtea plugin instalado:
Código: [Selecionar]
sudo apt-get install icedtea-plugin
01- pentium 4 1.8 Ghz 512 MB RAM 40 GB HD- LMDE// 02-notebook Samsung RV415 amd e300 1.3ghz 6gb RAM 320GB HD - Windows 8.1/ Linux Mint 17.2 cinnamon // skype: brandosilva
eu voltei.....

Offline gilbertoros

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
Re: Modulo Segurança santander
« Resposta #2 Online: 03 de MAR?O de 2013, 14:31 »
olá, se usas o openjdk, veja se tu tem o icedtea plugin instalado:
Código: [Selecionar]
sudo apt-get install icedtea-plugin
Sou novato no ubuntu, pode me fazer um passo a passo?
Devo desinstalar o java 1.8 , como faço?

Offline Ioca100

  • Usuário Ubuntu
  • *
  • Mensagens: 2.848
  • Rio,Brasil
    • Ver perfil
Re: Modulo Segurança santander
« Resposta #3 Online: 03 de MAR?O de 2013, 15:33 »
Aperte as teclas Ctrl+Alt+t, depois copie e cole no terminal: sudo apt-get install icedtea-plugin
Dê enter, vai pedir sua senha, mas não aparece, por motivo de segurança, é assim mesmo, tecle enter.
Reinicie o pc e testa lá no Santander.
Usuário Linux- 449417

Offline DelRod

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil
    • ACM
Re: Modulo Segurança santander
« Resposta #4 Online: 03 de MAR?O de 2013, 15:36 »
olá, se usas o openjdk, veja se tu tem o icedtea plugin instalado:
Código: [Selecionar]
sudo apt-get install icedtea-plugin
Sou novato no ubuntu, pode me fazer um passo a passo?
Devo desinstalar o java 1.8 , como faço?

tente consoante o pretendido ou necessidade: -
Remover: sudo apt-get remove --purge (nome do pacote)
Remover pacotes antigos ou duplicados: sudo apt-get autoclean
Remover pacotes com problemas: sudo apt-get -f remove (nome do pacote)
Remover pacotes instalados: sudo apt-get remove (nome do pacote)

Normalmente resolve os problemas.

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Modulo Segurança santander
« Resposta #5 Online: 03 de MAR?O de 2013, 20:03 »
olá, se usas o openjdk, veja se tu tem o icedtea plugin instalado:
Código: [Selecionar]
sudo apt-get install icedtea-plugin

bmota, tem um detalhe nesse icedtea, pelo comando será instalado o java do openjdk 6, que atualmente se encontra muito defasado em relação ao Java 7, diria até obsoleto. Acho que seria melhor:

Código: [Selecionar]
sudo apt-get install icedtea-7-plugin
Dessa maneira é instalado o openjdk-jre-7 também. Acho que teria que instalar o icedtea-7-jre-jamvm também.
« Última modificação: 03 de MAR?O de 2013, 20:12 por Sergio Benjamim »
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline gilbertoros

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
Re: Modulo Segurança santander
« Resposta #6 Online: 04 de MAR?O de 2013, 02:11 »
olá, se usas o openjdk, veja se tu tem o icedtea plugin instalado:
Código: [Selecionar]
sudo apt-get install icedtea-plugin
Sou novato no ubuntu, pode me fazer um passo a passo?
Devo desinstalar o java 1.8 , como faço?

tente consoante o pretendido ou necessidade: -
Remover: sudo apt-get remove --purge (nome do pacote)
Remover pacotes antigos ou duplicados: sudo apt-get autoclean
Remover pacotes com problemas: sudo apt-get -f remove (nome do pacote)
Remover pacotes instalados: sudo apt-get remove (nome do pacote)

Normalmente resolve os problemas.
como vejo o nome do pacote java para poder desinstala-lo?
preciso desinstalar o java 1.8 ou posso deixa-lo no sistema e instalar em cima o openjdk 6?

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Modulo Segurança santander
« Resposta #7 Online: 04 de MAR?O de 2013, 10:12 »
olá, se usas o openjdk, veja se tu tem o icedtea plugin instalado:
Código: [Selecionar]
sudo apt-get install icedtea-plugin
Sou novato no ubuntu, pode me fazer um passo a passo?
Devo desinstalar o java 1.8 , como faço?

tente consoante o pretendido ou necessidade: -
Remover: sudo apt-get remove --purge (nome do pacote)
Remover pacotes antigos ou duplicados: sudo apt-get autoclean
Remover pacotes com problemas: sudo apt-get -f remove (nome do pacote)
Remover pacotes instalados: sudo apt-get remove (nome do pacote)

Normalmente resolve os problemas.
como vejo o nome do pacote java para poder desinstala-lo?
preciso desinstalar o java 1.8 ou posso deixa-lo no sistema e instalar em cima o openjdk 6?


Não instale a versão 6 não, instale a versão 7 (como eu falei, a versão 6 é quase obsoleta). Na Central de Programas o número vem junto ao nome, só clicar em "Mais informações" para ver os detalhes.

Pode manter a versão 8 aí, mas aí vai ter que configurar o openjdk 7 como padrão no sistema:

Código: [Selecionar]
sudo update-alternatives --config java
sudo update-alternatives --config javaplugin

Não sei se são exatamente esses comandos, estou sem java para testar.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline DelRod

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil
    • ACM
Re: Modulo Segurança santander
« Resposta #8 Online: 04 de MAR?O de 2013, 21:41 »
olá, se usas o openjdk, veja se tu tem o icedtea plugin instalado:
Código: [Selecionar]
sudo apt-get install icedtea-plugin
Sou novato no ubuntu, pode me fazer um passo a passo?
Devo desinstalar o java 1.8 , como faço?

tente consoante o pretendido ou necessidade: -
Remover: sudo apt-get remove --purge (nome do pacote)
Remover pacotes antigos ou duplicados: sudo apt-get autoclean
Remover pacotes com problemas: sudo apt-get -f remove (nome do pacote)
Remover pacotes instalados: sudo apt-get remove (nome do pacote)

Normalmente resolve os problemas.
como vejo o nome do pacote java para poder desinstala-lo?

Se instalou através de um site, nesse mesmo site tem de estar o nome do pacote e demais referencias, tente voltar ao site e fassa como se quisesse instala-lo novamente para copiar/escrever o nome

preciso desinstalar o java 1.8 ou posso deixa-lo no sistema e instalar em cima o openjdk 6?


Não instale a versão 6 não, instale a versão 7 (como eu falei, a versão 6 é quase obsoleta). Na Central de Programas o número vem junto ao nome, só clicar em "Mais informações" para ver os detalhes.

Pode manter a versão 8 aí, mas aí vai ter que configurar o openjdk 7 como padrão no sistema:

Código: [Selecionar]
sudo update-alternatives --config java
sudo update-alternatives --config javaplugin

Não sei se são exatamente esses comandos, estou sem java para testar.

Offline gilbertoros

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
Re: Modulo Segurança santander
« Resposta #9 Online: 06 de MAR?O de 2013, 03:09 »
olá, se usas o openjdk, veja se tu tem o icedtea plugin instalado:
Código: [Selecionar]
sudo apt-get install icedtea-plugin
Sou novato no ubuntu, pode me fazer um passo a passo?
Devo desinstalar o java 1.8 , como faço?

tente consoante o pretendido ou necessidade: -
Não funcionou, deu a seguinte mensagem:
Só existe uma alternativa no grupo de ligação java (fornecendo /usr/bin/java): /usr/lib/jvm/java-8-oracle/jre/bin/java
Nada para configurar.
root@gilberto-System-Product-Name:/home/gilberto# sudo update-alternatives --config javaplugin
update-alternatives: erro: sem alternativas para javaplugin
o qu devo fazer. quando eu entro na conta ele pede para instalar o java, porem o java ja esta instalado, ele pede para instalar o java 7 e eu tenho instalado o 8?

Remover: sudo apt-get remove --purge (nome do pacote)
Remover pacotes antigos ou duplicados: sudo apt-get autoclean
Remover pacotes com problemas: sudo apt-get -f remove (nome do pacote)
Remover pacotes instalados: sudo apt-get remove (nome do pacote)

Normalmente resolve os problemas.
como vejo o nome do pacote java para poder desinstala-lo?
preciso desinstalar o java 1.8 ou posso deixa-lo no sistema e instalar em cima o openjdk 6?


Não instale a versão 6 não, instale a versão 7 (como eu falei, a versão 6 é quase obsoleta). Na Central de Programas o número vem junto ao nome, só clicar em "Mais informações" para ver os detalhes.

Pode manter a versão 8 aí, mas aí vai ter que configurar o openjdk 7 como padrão no sistema:

Código: [Selecionar]
sudo update-alternatives --config java
sudo update-alternatives --config javaplugin

Não sei se são exatamente esses comandos, estou sem java para testar.

Offline DelRod

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil
    • ACM
Re: Modulo Segurança santander
« Resposta #10 Online: 06 de MAR?O de 2013, 09:13 »
olá, se usas o openjdk, veja se tu tem o icedtea plugin instalado:
Código: [Selecionar]
sudo apt-get install icedtea-plugin
Sou novato no ubuntu, pode me fazer um passo a passo?
Devo desinstalar o java 1.8 , como faço?

tente consoante o pretendido ou necessidade: -
Não funcionou, deu a seguinte mensagem:
Só existe uma alternativa no grupo de ligação java (fornecendo /usr/bin/java): /usr/lib/jvm/java-8-oracle/jre/bin/java
Nada para configurar.
root@gilberto-System-Product-Name:/home/gilberto# sudo update-alternatives --config javaplugin
update-alternatives: erro: sem alternativas para javaplugin
o qu devo fazer. quando eu entro na conta ele pede para instalar o java, porem o java ja esta instalado, ele pede para instalar o java 7 e eu tenho instalado o 8?

Remover: sudo apt-get remove --purge (nome do pacote)
Remover pacotes antigos ou duplicados: sudo apt-get autoclean
Remover pacotes com problemas: sudo apt-get -f remove (nome do pacote)
Remover pacotes instalados: sudo apt-get remove (nome do pacote)

Normalmente resolve os problemas.
como vejo o nome do pacote java para poder desinstala-lo?
preciso desinstalar o java 1.8 ou posso deixa-lo no sistema e instalar em cima o openjdk 6?


Não instale a versão 6 não, instale a versão 7 (como eu falei, a versão 6 é quase obsoleta). Na Central de Programas o número vem junto ao nome, só clicar em "Mais informações" para ver os detalhes.

Pode manter a versão 8 aí, mas aí vai ter que configurar o openjdk 7 como padrão no sistema:

Código: [Selecionar]
sudo update-alternatives --config java
sudo update-alternatives --config javaplugin

Não sei se são exatamente esses comandos, estou sem java para testar.
Tenho ousado os seguintes comendos
( pode não ser necessário ) ----> sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update

>>>>>
sudo apt-get install oracle-java7-installer
sudo apt-get install icedtea-plugin

Se não der certo tentes estes comandos.

sudo add-apt-repository ppa:openjdk/ppa
sudo apt-get update
sudo apt-get remove purge -f sun-java6-*
sudo apt-get install icedtea-plugin icedtea6-plugin


Ambas as situações o java instalado é actualizado para a versão mais recente.

Mas pode tentar de uma outra forma através de um ficheiro denominado jre-6u31-linux-x64.bin

Consulte: - http://www.diolinux.com.br/2012/01/como-instalar-o-java-oficial-no-ubuntu.html




Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Modulo Segurança santander
« Resposta #11 Online: 06 de MAR?O de 2013, 16:52 »
Tenho usado os seguintes comendos
( pode não ser necessário ) ----> sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update

>>>>>
sudo apt-get install oracle-java7-installer
sudo apt-get install icedtea-plugin

Se não der certo tentes estes comandos.

sudo add-apt-repository ppa:openjdk/ppa
sudo apt-get update
sudo apt-get remove purge -f sun-java6-*
sudo apt-get install icedtea-plugin icedtea6-plugin


Ambas as situações o java instalado é actualizado para a versão mais recente.

Mas pode tentar de uma outra forma através de um ficheiro denominado jre-6u31-linux-x64.bin

Consulte: - http://www.diolinux.com.br/2012/01/como-instalar-o-java-oficial-no-ubuntu.html


DellRod, quando se trata de Java esses artigos de dicas de instalação ficam obsoletos muito rápido (ele data da época do ubuntu 11.10). Por que instalar o java 6 da Oracle se pode-se instalar o openjdk 7 que funciona em muitos sites de bancos? E outra, a dica do site ensina a instalar, mas e para atualizar, terá que fazer tudo de novo? Não é mais fácil instalar o openjdk 7 lá pela Central de Programas, e que se mantém atualizado com uma certa regularidade? Ou pelo menos instala o Java 7 da Oracle mesmo.

Eu não recomendo a instalação dos 2 PPA que vc indicou, o primeiro (ppa:webupd8team/java) acaba instalando o java 7 da Oracle, mas pode comprometer a segurança do sistema (se tratando de PPA's pode-se ocorrer a instalação de software malicioso, além do programa que a pessoa está instalando). Só recomendo a instalação deste PPA (e de qualquer outro) caso a pessoa confie no webupd8 e queira manter o Java atualizado regularmente. O segundo PPA está super ultrapassado e não há suporte para as novas versões do Ubuntu, e não faz sentido instalar PPA para manter o openjdk 6 atualizado, se há o openjdk 7 nos próprios repositórios oficiais do Ubuntu, que se mantém atualizado com certa frequência. No Ubuntu 12.04 os comandos do ppa:openjdk/ppa não funcionarão.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline DelRod

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil
    • ACM
Re: Modulo Segurança santander
« Resposta #12 Online: 06 de MAR?O de 2013, 17:47 »
Tenho usado os seguintes comendos
( pode não ser necessário ) ----> sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update

>>>>>
sudo apt-get install oracle-java7-installer
sudo apt-get install icedtea-plugin

Se não der certo tentes estes comandos.

sudo add-apt-repository ppa:openjdk/ppa
sudo apt-get update
sudo apt-get remove purge -f sun-java6-*
sudo apt-get install icedtea-plugin icedtea6-plugin


Ambas as situações o java instalado é actualizado para a versão mais recente.

Mas pode tentar de uma outra forma através de um ficheiro denominado jre-6u31-linux-x64.bin

Consulte: - http://www.diolinux.com.br/2012/01/como-instalar-o-java-oficial-no-ubuntu.html


DellRod, quando se trata de Java esses artigos de dicas de instalação ficam obsoletos muito rápido (ele data da época do ubuntu 11.10). Por que instalar o java 6 da Oracle se pode-se instalar o openjdk 7 que funciona em muitos sites de bancos? E outra, a dica do site ensina a instalar, mas e para atualizar, terá que fazer tudo de novo? Não é mais fácil instalar o openjdk 7 lá pela Central de Programas, e que se mantém atualizado com uma certa regularidade? Ou pelo menos instala o Java 7 da Oracle mesmo.

Eu não recomendo a instalação dos 2 PPA que vc indicou, o primeiro (ppa:webupd8team/java) acaba instalando o java 7 da Oracle, mas pode comprometer a segurança do sistema (se tratando de PPA's pode-se ocorrer a instalação de software malicioso, além do programa que a pessoa está instalando). Só recomendo a instalação deste PPA (e de qualquer outro) caso a pessoa confie no webupd8 e queira manter o Java atualizado regularmente. O segundo PPA está super ultrapassado e não há suporte para as novas versões do Ubuntu, e não faz sentido instalar PPA para manter o openjdk 6 atualizado, se há o openjdk 7 nos próprios repositórios oficiais do Ubuntu, que se mantém atualizado com certa frequência. No Ubuntu 12.04 os comandos do ppa:openjdk/ppa não funcionarão.

A configuração do java é:

Fornecedor: Oracle Coporation
Versão: Java SE 7 Update 15
Sistema Operacional: Linux 3,5,0-26-generic
Java Arquitetura: 64-bit

Esta é a versão que foi instalada como acima referi.
Há algum problema de segurança?
recebo uma resposta positiva em http://www.java.com/pt_BR/download/linux_manual.jsp?locale=pt_BR


Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Modulo Segurança santander
« Resposta #13 Online: 06 de MAR?O de 2013, 23:13 »
Tenho usado os seguintes comendos
( pode não ser necessário ) ----> sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update

>>>>>
sudo apt-get install oracle-java7-installer
sudo apt-get install icedtea-plugin

Se não der certo tentes estes comandos.

sudo add-apt-repository ppa:openjdk/ppa
sudo apt-get update
sudo apt-get remove purge -f sun-java6-*
sudo apt-get install icedtea-plugin icedtea6-plugin


Ambas as situações o java instalado é actualizado para a versão mais recente.

Mas pode tentar de uma outra forma através de um ficheiro denominado jre-6u31-linux-x64.bin

Consulte: - http://www.diolinux.com.br/2012/01/como-instalar-o-java-oficial-no-ubuntu.html


DellRod, quando se trata de Java esses artigos de dicas de instalação ficam obsoletos muito rápido (ele data da época do ubuntu 11.10). Por que instalar o java 6 da Oracle se pode-se instalar o openjdk 7 que funciona em muitos sites de bancos? E outra, a dica do site ensina a instalar, mas e para atualizar, terá que fazer tudo de novo? Não é mais fácil instalar o openjdk 7 lá pela Central de Programas, e que se mantém atualizado com uma certa regularidade? Ou pelo menos instala o Java 7 da Oracle mesmo.

Eu não recomendo a instalação dos 2 PPA que vc indicou, o primeiro (ppa:webupd8team/java) acaba instalando o java 7 da Oracle, mas pode comprometer a segurança do sistema (se tratando de PPA's pode-se ocorrer a instalação de software malicioso, além do programa que a pessoa está instalando). Só recomendo a instalação deste PPA (e de qualquer outro) caso a pessoa confie no webupd8 e queira manter o Java atualizado regularmente. O segundo PPA está super ultrapassado e não há suporte para as novas versões do Ubuntu, e não faz sentido instalar PPA para manter o openjdk 6 atualizado, se há o openjdk 7 nos próprios repositórios oficiais do Ubuntu, que se mantém atualizado com certa frequência. No Ubuntu 12.04 os comandos do ppa:openjdk/ppa não funcionarão.

A configuração do java é:

Fornecedor: Oracle Coporation
Versão: Java SE 7 Update 15
Sistema Operacional: Linux 3,5,0-26-generic
Java Arquitetura: 64-bit

Esta é a versão que foi instalada como acima referi.
Há algum problema de segurança?
recebo uma resposta positiva em http://www.java.com/pt_BR/download/linux_manual.jsp?locale=pt_BR



Para que os comandos para instalar repositório do openjdk (que não é atualizado há tempos), e ainda instalação do openjdk 6? Antes de sair mexendo no sistema, é bom a pessoa ter uma noção do que está fazendo. Vc instalou/atualizou o openjdk 6 sem necessidade (efeito placebo aquele monte de comandos). Vc sabe qual dos comandos te fez ter o java 7 da oracle?

Os primeiros comandos não tem nada a ver com os últimos, vc misturou java 7 da Oracle com openjdk 6 (de repositório que não atualiza a tempos), um não é solução do outro.

Citar
Ambas as situações o java instalado é actualizado para a versão mais recente.

O OpenJDK instalado pelo repositório não é o mais atualizado.

Citar
Mas pode tentar de uma outra forma através de um ficheiro denominado jre-6u31-linux-x64.bin

Esse 6u31 está extremamente ultrapassado. Não vamos brincar com segurança no Linux.
« Última modificação: 06 de MAR?O de 2013, 23:18 por Sergio Benjamim »
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline SergioCl

  • Usuário Ubuntu
  • *
  • Mensagens: 23
  • Ubuntu 19.10 user
    • Ver perfil
Re: Modulo Segurança santander
« Resposta #14 Online: 07 de MAR?O de 2013, 00:49 »
Eu uso o Internet Banking do Santander sem nenhum problema.
Mas para isso tenho instalado o Java da Oracle, penso que lamentavelmente o site do banco só aceita a versão da Oracle, eu pelo menos nunca consegui fazer funcionar com outra.

O amigo Sergio Benjamim tem razão sobre os riscos da instalação de PPA, mas acredito que o webupd8 seja confiável. Tenho que manter o Java sempre atualizado para acessar o Internet Banking e venho me valendo desse PPA sem nunca ter notado nada de errado.