Autor Tópico: Problema com apt-get update [Resolvido]  (Lida 40905 vezes)

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Problema com apt-get update
« Resposta #45 Online: 28 de Outubro de 2013, 15:55 »
Faça o que a mensagem sugere.

Código: ($) [Selecionar]
sudo service vboxdrv setup

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #46 Online: 28 de Outubro de 2013, 15:57 »
Resposta obtida, Arthur:

Citar
vboxdrv: unrecognized service

O que faço agora?! :(
« Última modificação: 28 de Outubro de 2013, 16:02 por vicktorjunior »
Não me siga, estou perdido.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Problema com apt-get update
« Resposta #47 Online: 28 de Outubro de 2013, 16:06 »
Amigos,

Segui o indicado pelo Arthur Bernardes e retornei ao meu antigo Virtualbox.
Porém ao iniciar minha máquina virtual, aparece o seguinte erro:
Citar
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Outro erro:
Citar
Falha ao abrir uma sessão para a máquina virtual windowsxp.
The virtual machine 'windowsxp' has terminated unexpectedly during startup with exit code 1.

Como devo proceder pra resolver este problema?
Preciso urgentemente acessar essa máquina virtual. :/

roda no terminal:

sudo /etc/init.d/vboxdrv setup

depois pelo terminal digita:

sudo apt-get update

sudo apt-get install dkms


o pacote dkms vai ser o responsável pelo não aparecimento mais desse pedido para rodar sudo /etc/init.d/vboxdrv setup toda vez que você atualizar, por exemplo, o kernel do Ubuntu.
« Última modificação: 28 de Outubro de 2013, 16:09 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #48 Online: 28 de Outubro de 2013, 16:07 »
Linuser,

Essa é a resposta para o primeiro comando:

Citar
sudo /etc/init.d/vboxdrv setup
sudo: /etc/init.d/vboxdrv: comando não encontrado

O que faço?
Não me siga, estou perdido.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Problema com apt-get update
« Resposta #49 Online: 28 de Outubro de 2013, 16:12 »
Linuser,

Essa é a resposta para o primeiro comando:

Citar
sudo /etc/init.d/vboxdrv setup
sudo: /etc/init.d/vboxdrv: comando não encontrado

O que faço?

Veja se em /etc/init.d/ tem o arquivo vboxdrv ou algo bem parecido com isso (pode o nome ter sido um pouco alterado). Se não tiver então algo deu errado na sua instalação do VirtualBox.
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Problema com apt-get update
« Resposta #50 Online: 28 de Outubro de 2013, 16:13 »
Remova tudo que é Virtualbox com o comando:

Código: ($) [Selecionar]
sudo apt-get purge virtualbox-4*
E depois instale o dkms como o amigo sugeriu, com o comando:

Código: ($) [Selecionar]
sudo apt-get install dkms
E depois faça o download da versão 4.2.18 do Virtualbox (32 bits) e instale-o com os seguintes comandos em terminal:

Código: ($) [Selecionar]
cd /tmp ; wget -c http://download.virtualbox.org/virtualbox/4.2.18/virtualbox-4.2_4.2.18-88780~Ubuntu~precise_i386.deb ; sudo dpkg -i virtualbox-4.2_4.2.18-88780~Ubuntu~precise_i386.deb ; sudo service vboxdrv setup
Depois, instale o pacote de extensão, baixe-o do seguinte link:


Em seguida, tente abrir o Virtualbox.

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #51 Online: 28 de Outubro de 2013, 16:16 »
Tentei executar o virtualbox pelo terminal. Eis a resposta e os passos que realizei:

Citar
$ virtualbox
WARNING: The character device /dev/vboxdrv does not exist.
    Please install the virtualbox-ose-dkms package and the appropriate
    headers, most likely linux-headers-generic.

    You will not be able to start VMs until this problem is fixed.
Error opening file for reading: Permissão negada

junior@Junior:~$ sudo apt-get virtualbox-ose-dkms
[sudo] password for junior:
E: Operação virtualbox-ose-dkms inválida

junior@Junior:~$ sudo apt-get install  virtualbox-ose-dkms
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Os NOVOS pacotes a seguir serão instalados:
  virtualbox-ose-dkms
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 8 não atualizados.
É preciso baixar 22,2 kB de arquivos.
Depois desta operação, 121 kB adicionais de espaço em disco serão usados.
Obter:1 http://archive.ubuntu.com/ubuntu/ precise-updates/universe virtualbox-ose-dkms all 4.1.12-dfsg-2ubuntu0.5 [22,2 kB]
Baixados 22,2 kB em 0s (25,2 kB/s)            
Selecionando pacote virtualbox-ose-dkms previamente não selecionado.
(Lendo banco de dados ... 303756 ficheiros e directórios actualmente instalados.)
Desempacotando virtualbox-ose-dkms (de .../virtualbox-ose-dkms_4.1.12-dfsg-2ubuntu0.5_all.deb) ...
Configurando virtualbox-ose-dkms (4.1.12-dfsg-2ubuntu0.5) ...

junior@Junior:~$ virtualbox
WARNING: The character device /dev/vboxdrv does not exist.
    Please install the virtualbox-ose-dkms package and the appropriate
    headers, most likely linux-headers-generic.

    You will not be able to start VMs until this problem is fixed.
Error opening file for reading: Permissão negada

junior@Junior:~$ sudo apt-get install linux-headers-generic
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
linux-headers-generic já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 8 não atualizados.

Se está tudo OK. Porquê ainda recebo os mesmos erros?:

Citar
Falha ao abrir uma sessão para a máquina virtual windowsxp.
The virtual machine 'windowsxp' has terminated unexpectedly during startup with exit code 1.

Citar
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Estou ficando sem esperanças. :/

Arthur,

Já havia removido tudo que é virtualbox através deste comando. Mas tentarei novamente e realizarei os passos que comentastes. Apesar de já tê-los feito.
Não me siga, estou perdido.

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #52 Online: 28 de Outubro de 2013, 16:18 »
Linuser,

Essa é a resposta para o primeiro comando:

Citar
sudo /etc/init.d/vboxdrv setup
sudo: /etc/init.d/vboxdrv: comando não encontrado

O que faço?

Veja se em /etc/init.d/ tem o arquivo vboxdrv ou algo bem parecido com isso (pode o nome ter sido um pouco alterado). Se não tiver então algo deu errado na sua instalação do VirtualBox.

Então, Linuser.

Não encontrei o arquivo vboxdrv. Apenas virtualbox está na pasta init.d

O que faço?
Não me siga, estou perdido.

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #53 Online: 28 de Outubro de 2013, 16:23 »
Arthur,

Resposta aos passos indicados:

Citar
:~$ sudo apt-get purge virtualbox-4*
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Note, a seleccionar 'virtualbox-dbg' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-ose-guest-x11' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-source' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-ose' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-guest-dkms' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-guest-x11' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-2.0' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-2.1' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-2.2' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-3.0' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-3.1' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-3.2' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-4.0' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-4.1' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-4.2' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-ose-guest-utils' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-ose-dkms' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-guest-additions-iso' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-dkms' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-ose-source' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-guest-additions' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-ose-guest-source' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-ose-qt' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-ose-dbg' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-ose-fuse' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-qt' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-guest-source' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-fuse' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-guest-utils' para a expressão regular 'virtualbox-4*'
Note, a seleccionar 'virtualbox-ose-guest-dkms' para a expressão regular 'virtualbox-4*'
O pacote virtualbox-guest-additions não está instalado, então não será removido
O pacote virtualbox-guest-additions-iso não está instalado, então não será removido
O pacote virtualbox-dbg não está instalado, então não será removido
O pacote virtualbox-fuse não está instalado, então não será removido
O pacote virtualbox-guest-dkms não está instalado, então não será removido
O pacote virtualbox-guest-source não está instalado, então não será removido
O pacote virtualbox-guest-utils não está instalado, então não será removido
O pacote virtualbox-guest-x11 não está instalado, então não será removido
O pacote virtualbox-ose não está instalado, então não será removido
O pacote virtualbox-ose-dbg não está instalado, então não será removido
O pacote virtualbox-ose-fuse não está instalado, então não será removido
O pacote virtualbox-ose-guest-dkms não está instalado, então não será removido
O pacote virtualbox-ose-guest-source não está instalado, então não será removido
O pacote virtualbox-ose-guest-utils não está instalado, então não será removido
O pacote virtualbox-ose-guest-x11 não está instalado, então não será removido
O pacote virtualbox-ose-qt não está instalado, então não será removido
O pacote virtualbox-ose-source não está instalado, então não será removido
O pacote virtualbox-source não está instalado, então não será removido
Os pacotes a seguir serão REMOVIDOS:
  virtualbox-dkms* virtualbox-ose-dkms* virtualbox-qt*
0 pacotes atualizados, 0 pacotes novos instalados, 3 a serem removidos e 8 não atualizados.
Depois desta operação, 22,7 MB de espaço em disco serão liberados.
Você quer continuar [S/n]? s
(Lendo banco de dados ... 303755 ficheiros e directórios actualmente instalados.)
Removendo virtualbox-ose-dkms ...
Removendo virtualbox-dkms ...

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 4.1.12
Kernel:  3.2.0-55-generic-pae (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.2.0-55-generic-pae/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.2.0-55-generic-pae/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.2.0-55-generic-pae/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.2.0-55-generic-pae/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod.....

DKMS: uninstall completed.

------------------------------
Deleting module version: 4.1.12
completely from the DKMS tree.
------------------------------
Done.
Removendo virtualbox-qt ...
Expurgando arquivos de configuração de virtualbox-qt ...
Processando gatilhos para hicolor-icon-theme ...
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para gnome-menus ...
Processando gatilhos para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processando gatilhos para man-db ...
Processando gatilhos para shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Processando gatilhos para menu ...

Citar
~$ sudo apt-get install dkms
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
dkms já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 8 não atualizados.

Citar
~$ cd /tmp ; wget -c http://download.virtualbox.org/virtualbox/4.2.18/virtualbox-4.2_4.2.18-88780~Ubuntu~precise_i386.deb ; sudo dpkg -i virtualbox-4.2_4.2.18-88780~Ubuntu~precise_i386.deb ; sudo service vboxdrv setup
Erro ao analisar URL do proxy http://localhost:4001 : O número de porta é inválido
dpkg: erro processando virtualbox-4.2_4.2.18-88780~Ubuntu~precise_i386.deb (--install):
 impossível acessar arquivo: Arquivo ou diretório não encontrado
Erros foram encontrados durante o processamento de:
 virtualbox-4.2_4.2.18-88780~Ubuntu~precise_i386.deb
vboxdrv: unrecognized service

Não baixei o pacote de extensão que me indicaste pois acho que não obtive sucesso nos passos acima.

O que devo fazer, agora?
Não me siga, estou perdido.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Problema com apt-get update
« Resposta #54 Online: 28 de Outubro de 2013, 16:41 »
Fez o que o Arthur recomendou acima e não deu certo?

Eu prefiro ir assim:

- Remova todos os pacote .deb do Virtualbox presente na sua pasta de Downloads do Ubuntu.

- Considerando que você já removeu todas as instalações do Virtualbox existentes no seu sistema e instalou o pacote dkms, baixe os seguintes arquivos:

http://download.virtualbox.org/virtualbox/4.3.0/virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb

e

http://download.virtualbox.org/virtualbox/4.3.0/Oracle_VM_VirtualBox_Extension_Pack-4.3.0-89960.vbox-extpack


Depois de baixado e dentro da pasta Downloads pelo terminal, executar o comando:

sudo dpkg -i virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb

alternativa gráfica a isso, clicar duas vezes (clique duplo) sobre o arquivo virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb digitar sua senha quando pedido e esperar a instalação. Esta forma é mais demorada, pois abre a central de programas para instalação e demora o processo.


- Depois falo sobre o outro pacote baixado ok, por hora veja se o VB funciona. Mas antes, ainda faz mais isso no terminal:

sudo adduser seu_usuário vboxusers

troque o que destaquei em vermelho pelo seu nome de usuário, aquele que você digita para entrar no Ubuntu. No meu caso o comando seria assim:

sudo adduser linuser104 vboxusers (apenas um exemplo)

- se ainda precisar, roda o comando:

sudo /etc/init.d/vboxdrv setup

outra vez.
« Última modificação: 28 de Outubro de 2013, 16:51 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #55 Online: 28 de Outubro de 2013, 16:51 »
Linuser,

Realizei os procedimentos até a hora em que executei o comando para instalar o virtualbox que baixei pelo link que me indicaste.
Segue o que obtive:
Citar
sudo dpkg -i virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb
Selecionando pacote virtualbox-4.3 previamente não selecionado.
(Lendo banco de dados ... 303226 ficheiros e directórios actualmente instalados.)
Desempacotando virtualbox-4.3 (de virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb) ...
Configurando virtualbox-4.3 (4.3.0-89960~Ubuntu~precise) ...
addgroup: O grupo 'vboxusers' já existe como um grupo de sistema. Saindo.
Stopping VirtualBox kernel modules ...done.
Uninstalling old VirtualBox DKMS kernel modules ...done.
Trying to register the VirtualBox kernel modules using DKMSError! Your kernel headers for kernel 2.6.38-11-generic-pae cannot be found.
Please install the linux-headers-2.6.38-11-generic-pae package,
or use the --kernelsourcedir option to tell DKMS where it's located
 ...failed!
  (Failed, trying without DKMS)
Recompiling VirtualBox kernel modules ...failed!
  (Look at /var/log/vbox-install.log to find out what went wrong)

Processando gatilhos para ureadahead ...
Processando gatilhos para shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para gnome-menus ...
Processando gatilhos para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processando gatilhos para hicolor-icon-theme ...

Acho que alguma coisa deu errada onde grifei em negrito.
O que sugeres?
Não me siga, estou perdido.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Problema com apt-get update
« Resposta #56 Online: 28 de Outubro de 2013, 16:57 »
ok, acho que falta os pacotes de compilação, então instala ele:

sudo apt-get install build-essential fakeroot linux-headers-`uname -r`

depois retorna o processo anterior.
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #57 Online: 28 de Outubro de 2013, 17:00 »
De qualquer forma continuei...

E verifiquei que o VirtualBox foi instalado. O 4.3. Excelente! Um problema a menos!

Agora estou tentando acessar a minha máquina virtual que já estava criada e não estou conseguindo. Aparece o erro que indiquei anteriormente:

Citar
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Obrigado pela ajuda até aqui Linuser!

Espero poder resolver este problema agora.

O que me sugeres?
Não me siga, estou perdido.

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #58 Online: 28 de Outubro de 2013, 17:02 »
Executei o comando que me indicaste anteriormente. E tive essa resposta:

Citar
$ sudo apt-get install build-essential fakeroot linux-headers-`uname -r`
[sudo] password for junior:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote linux-headers-2.6.38-11-generic-pae
E: Não foi possível encontrar o pacote através da expressão regular 'linux-headers-2.6.38-11-generic-pae'

Não entendo muito dessas instalações. Mas me parece que ele identificou algo errado, sei lá.

O que faço? :S
Não me siga, estou perdido.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Problema com apt-get update
« Resposta #59 Online: 28 de Outubro de 2013, 17:03 »
Executei o comando que me indicaste anteriormente. E tive essa resposta:

Citar
$ sudo apt-get install build-essential fakeroot linux-headers-`uname -r`
[sudo] password for junior:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote linux-headers-2.6.38-11-generic-pae
E: Não foi possível encontrar o pacote através da expressão regular 'linux-headers-2.6.38-11-generic-pae'

Não entendo muito dessas instalações. Mas me parece que ele identificou algo errado, sei lá.

O que faço? :S

qual é o resultado do comando:

uname -r

no seu terminal aí.
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].