Autor Tópico: Problema com apt-get update [Resolvido]  (Lida 36775 vezes)

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #30 Online: 28 de Outubro de 2013, 13:51 »
Obrigado pela resposta, Eliseu!

Seguinte, fui no local onde está o arquivo .deb do VirtualBox e executei o que me você me indicou.
Eis o resultado:

Citar
$ sudo dpkg -i *.deb
Selecionando pacote google-chrome-stable previamente não selecionado.
(Lendo banco de dados ... 303359 ficheiros e directórios actualmente instalados.)
Desempacotando google-chrome-stable (de google-chrome-stable_current_i386.deb) ...
Preparando para substituir launchpad-getkeys 0.3.2-1~webupd8~oneiric (usando launchpad-getkeys_0.3.2-1~webupd8~oneiric_all.deb) ...
Desempacotando substituto launchpad-getkeys ...
dpkg: erro processando virtualbox-4.3_4.3.0-89960~Ubuntu~precise_amd64.deb (--install):
 arquitetura do pacote (amd64) não combina com a do sistema (i386)
dpkg: considerando remoção de virtualbox em favor de virtualbox-4.3 ...
dpkg: não, não posso continuar com remoção de virtualbox (--auto-deconfigure ajudará):
 virtualbox-dkms depende de virtualbox (>= 4.1.12-dfsg-2ubuntu0.5)
  virtualbox está para ser removido.
dpkg: sobre virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb contendo virtualbox-4.3:
 virtualbox-4.3 conflita com virtualbox
  virtualbox (versão 4.1.12-dfsg-2ubuntu0.5) está presente e instalado.
dpkg: erro processando virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb (--install):
 pacotes conflitantes - não instalando virtualbox-4.3
Configurando google-chrome-stable (30.0.1599.114-1) ...
Configurando launchpad-getkeys (0.3.2-1~webupd8~oneiric) ...
Processando gatilhos para menu ...
Processando gatilhos para man-db ...
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para gnome-menus ...
Processando gatilhos para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Erros foram encontrados durante o processamento de:
 virtualbox-4.3_4.3.0-89960~Ubuntu~precise_amd64.deb
 virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb

Pelo que pude entender, leigo que sou, acho que o VirtualBox anterior continua instalado na minha máquina. Mesmo eu tendo desinstalado via "Central de Programas do Ubuntu".

Como devo proceder pra solucionar esse problema ou, qualquer outro que seja?
Não me siga, estou perdido.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Problema com apt-get update
« Resposta #31 Online: 28 de Outubro de 2013, 14:18 »
porque o local onde você executou o comando

sudo dpkg -i *.deb

havia duas versões do vitualbox, uma 32bits e outra 64bits e o comando em questão está mandando instalar tudo que é .deb no local de onde foi executado o comando.


Remover algo pela central não vai apagar o cache do .deb baixado, apenas vai remover a instalação do pacote, mas em cache o .deb pode ainda estar lá.
« Última modificação: 28 de Outubro de 2013, 14:20 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #32 Online: 28 de Outubro de 2013, 14:34 »
Linuser, obrigado pela contribuição!

Para solucionar o problema eu devo excluir a versão incompatível com meu sistema?

Como faço para deletar algo do cachê?
Não me siga, estou perdido.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Problema com apt-get update
« Resposta #33 Online: 28 de Outubro de 2013, 14:37 »
Linuser, obrigado pela contribuição!

Para solucionar o problema eu devo excluir a versão incompatível com meu sistema?

Como faço para deletar algo do cachê?

onde foi mesmo que você deu este comando (sudo dpkg -i *.deb), em que pasta?

a pasta de cache do apt-get/Synaptic/central de programas é /var/cache/apt/archives e se você quiser apenas remover alguns .deb entre nela e escolha quais devem ser removido (deletados).

Se quer remover tudo que é .deb de lá o comando seria:

sudo apt-get clean
« Última modificação: 28 de Outubro de 2013, 14:40 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #34 Online: 28 de Outubro de 2013, 14:39 »
Linuser,

Eu dei o comando na pasta Downloads do meu usuário.

Vou tentar entrar na pasta que me indicaste para ver se encontro o VirtualBox ainda instalado.
Deve solucionar o problema, né?
Não me siga, estou perdido.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Problema com apt-get update
« Resposta #35 Online: 28 de Outubro de 2013, 14:42 »
Linuser,

Eu dei o comando na pasta Downloads do meu usuário.

Vou tentar entrar na pasta que me indicaste para ver se encontro o VirtualBox ainda instalado.
Deve solucionar o problema, né?

seu sistema é 64bits ou 32bits?

virtualbox-4.3_4.3.0-89960~Ubuntu~precise_amd64.deb (este é para 64bits)
virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb    (este é para 32bits)

para instalar um pacote por vez o comando é:

sudo dpkg -i nome_do_pacote.deb

ao invés de:

sudo dpkg -i *.deb

que como disse antes instala tudo que é .deb da pasta em questão.
« Última modificação: 28 de Outubro de 2013, 14:49 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #36 Online: 28 de Outubro de 2013, 14:43 »
Não encontrei nada na pasta /var/cache/apt/archives pelo Nautilus.

Devo executar o comando apt-get clean?
Não me siga, estou perdido.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Problema com apt-get update
« Resposta #37 Online: 28 de Outubro de 2013, 14:46 »
Não encontrei nada na pasta /var/cache/apt/archives pelo Nautilus.

Devo executar o comando apt-get clean?

não precisa já que não tem nada lá.

Seus .deb, como você mesmo disse, estão em Downloads, então não é legal usar um comando para instalar tudo que tem lá em .deb se existe pacotes .deb que entram em conflito, entendeu?
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #38 Online: 28 de Outubro de 2013, 14:48 »
Entendi.

Vou tentar executar o comando que me indicaste sudo dpkg -i nome_do_pacote.deb

Com o nome do pacote: virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb

Não me siga, estou perdido.

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #39 Online: 28 de Outubro de 2013, 15:10 »
Linuser,

Não deu certo o comando que me indicaste.

Eis o que apareceu ao executar o comando sudo dpkg -i virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb:
Citar
sudo dpkg -i virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb[sudo] password for junior:
dpkg: erro: status do banco de dados dpkg está bloqueado por um outro processo

O que faço?
Estou tentando instalar o VirtualBox 4.3 mas não estou conseguindo.
Nem executar o arquivo .deb que baixei na pasta Downloads está resolvendo. A central de programas abre, eu clico em instalar e coloco a senha. A central parece que vai carregar a instalação, mas não acontece nada.

Não me siga, estou perdido.

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #40 Online: 28 de Outubro de 2013, 15:16 »
Resolvi o problema anterior lançando um "killall" no apt-get

Agora aparece o seguinte:

Citar
sudo dpkg -i virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.debdpkg: erro processando virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb (--install):
 impossível acessar arquivo: Arquivo ou diretório não encontrado

Erros foram encontrados durante o processamento de:
 virtualbox-4.3_4.3.0-89960~Ubuntu~precise_i386.deb


O que fazer?
Não me siga, estou perdido.

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.162
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re: Problema com apt-get update
« Resposta #41 Online: 28 de Outubro de 2013, 15:27 »
tenta este comando:

Código: [Selecionar]
echo "deb http://download.virtualbox.org/virtualbox/debian $(lsb_release -sc) contrib" | sudo tee /etc/apt/sources.list.d/virtualbox.list && wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add - && sudo apt-get update && sudo apt-get install virtualbox-4.3
« Última modificação: 28 de Outubro de 2013, 17:19 por selvaking »
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #42 Online: 28 de Outubro de 2013, 15:29 »
Selvaking,

Tenho essa resposta ao executar seu comandão:

Citar
bash: /etc/apt/sources.list.d/virtualbox.list: Permissão negada

E agora?
Não me siga, estou perdido.

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Problema com apt-get update
« Resposta #43 Online: 28 de Outubro de 2013, 15:31 »
O Virtualbox 4.3 deu muito problema aqui, preferi usar o 4.2.18!

Offline vicktorjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 46
  • Um ex-windows user, tentando viver no mundo "open"
    • Ver perfil
Re: Problema com apt-get update
« Resposta #44 Online: 28 de Outubro de 2013, 15:50 »
Amigos,

Segui o indicado pelo Arthur Bernardes e retornei ao meu antigo Virtualbox.
Porém ao iniciar minha máquina virtual, aparece o seguinte erro:
Citar
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Outro erro:
Citar
Falha ao abrir uma sessão para a máquina virtual windowsxp.
The virtual machine 'windowsxp' has terminated unexpectedly during startup with exit code 1.

Como devo proceder pra resolver este problema?
Preciso urgentemente acessar essa máquina virtual. :/
Não me siga, estou perdido.