Autor Tópico: [Resolvido] Nvidia - mato ou morro  (Lida 6212 vezes)

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
[Resolvido] Nvidia - mato ou morro
« Online: 11 de Janeiro de 2008, 17:57 »
Oi pessoal !

Peço mais uma vez a ajuda de vocês. Fazem já uns dois meses que venho tentando
fazer fazer funcionar os drivers Nvidia no meu pc. Não sei mais o que fazer e
imagino que a solução deva ser simples, pois não encontrei nada igual ou parecido
com o que tenho passado.

Preciso que alguem me ajude acompanhando o tópico, não tem problema se errar
alguma coisa. A gente refaz !

Fiquem a vontade para pedir mais informações.

O problema:

1 - Drivers instalados o pc não navega na internet.
2 - As rotas do Kernel somem
3 - Se uso a opção "pci=routeirq" no boot o pc navega beleza, mas pc trava completamente
4 - glxgears funciona "aos pulos" é só abrir uma janela qualquer, mesmo do gedit, e ele
trava uns dois segundos e segue funcionando, mas logo o pc trava

O que foi tentado:

1 - Instalação dos drivers de todas as formas - Manual - Envy - Repositórios
incluindo drivers beta

2 - Formatação N vezes, instalando os drivers da forma citada acima, antes das atualizações de
segurança e depois delas, com cd's originais e baixados todos md5sum comferidos antes e depois
de gravados

3 - Os mesmos problemas ocorrem com o Gutsy 64

4 - Foi compilado Kernel

5 - Com e sem Java instalado

6 - Configuração manual do Xorg usando diversas opções encontradas na net e nos foruns,
também pelo nvidia-settings

7 - Conectava com autenticação via pppoe, coloquei usuario e senha no modem

8 - Memtest dezenas de horas, a placa mãe é nova, os hds são novos, a placa de video é nova

Conclusão:

1 - Os drivers e módulos dos dispositivos sobem bem (não percebi diferenças)

2 - Talvez os drivers nvidia não estejam conseguindo acesso completo ao X devido "pci=routeirq"

3 - Pode ser uma questão de prioridade, tempo de carregamento ou dependência de algum processo

4 - O mais provável é um problema de rede (foi o motivo mais próximo que encontrei)


O hardware:

Asus K8v-xe (chipset VIA K8T890 e VT 8251)

Athlon 64 2800+ = Hd 80 sata II e Hd 80 sata I =  memoria DDR400 2x512
Placa Video Pci-e xFx 7300GS 256+256

Monitor LG Flatron 17" = 1 cdrw/dvdr LG e 1 dvdrw/cdrw

Sistemas: Ubuntu Gutsy 32 e 64 + Window$ XP


Sem os drivers tudo funciona perfeitamente. Menos é claro a qualidade visual.
 

                                                                Desde já agradeço !
« Última modificação: 26 de Janeiro de 2008, 09:03 por edjen »
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #1 Online: 11 de Janeiro de 2008, 18:58 »
Lá vai eu iniciante tentando ajudar...

No meu kernel edge tem uns ajustes talvez possa ajudar, mas sem módulos restritos OK!!!!

cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Oct  4 10:33:51 PDT 2007

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# Uncomment if you have a wacom tablet
#       InputDevice     "stylus"        "SendCoreEvents"
#       InputDevice     "cursor"        "SendCoreEvents"
#       InputDevice     "eraser"        "SendCoreEvents"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "abnt2"
    Option         "XkbLayout" "br"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "Monitor Genérico"
    HorizSync       30.0 - 70.0
    VertRefresh     50.0 - 160.0

    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Placa de Vídeo Genérica"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Placa de Vídeo Genérica"
    Monitor        "Monitor Genérico"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Já experimentou colocar as frequencias de seu monitor???

já tentou mudar a resolução pelo ubuntu ao invés do nvidia settings!!! Pois mudar pelo nvidia comigo não funciona...

Qual driver vc usa??? Não me fale que é o 169.07 por favor...

Já tentou desinstalar os drivers nvidia que foram compilados na sua máquina para tirar os resquícios numa nova instalação???

Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #2 Online: 11 de Janeiro de 2008, 19:13 »
Oi Hqxriven !

Tentei sim. Já coloquei a resolução no xorg, até tenho o cd do monitor com as especificações. E já tentei com todos os drivers disponiveis. Agora tô com uma instalação limpa só instalei o multimedia. Mas o problema parece que não são os drivers em si, mas está havendo algum conflito com o chipset ou a rede.

               Qualquer coisa que você achar que possa ajudar coloca aquí. Não se preocupe por ser novato, o importante é o que você compartilha e não o que guarda pra si mesmo.
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #3 Online: 11 de Janeiro de 2008, 19:22 »
Vc está com qual driver instalado agora???

Quando vc ativa ele acontece o que???

A resolução fica super bugada???

Já tentou isso...

DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
EndSubSection
EndSection

Foi a única coisa que resolveu aqui...

Continua postando eu tô no fórum....

EDIT1

Instale o mc!!!

EDIT2

Instale o 100.14.23 o último é bugado!!!
Hqx
« Última modificação: 11 de Janeiro de 2008, 19:26 por Hqxriven »
Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #4 Online: 11 de Janeiro de 2008, 19:28 »
Agora eu tô com o que o sistema coloca na instalação "nv", não tenho problema de resolução, só que se eu ativar os drivers restritos ou instalar de qualquer forma o pc trava. Tá tudo funcionando bem, só que não posso usar nenhum efeito (glx). Eu já usei o 100.14.23 também deu problema.
« Última modificação: 11 de Janeiro de 2008, 19:30 por edjen »
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #5 Online: 11 de Janeiro de 2008, 19:33 »
Estou achando que não estão pegando o endereço da sua placa corretamente...

Deixa uma dar uma olhada aqui no kernel...

EDIT1: Continuo olhando...

EDIT2: O site que mostrava algumas coisas, baboooo

Então vou tentar explicar eu mesmo...

No kernel existe uma opção chamada

CONFIG_PCI_GODIRECT
CONFIG_PCI_DIRECT
CONFIG_PCI_GOANY
CONFIG_PCI_ANY

No kernel do ubuntu a opção go any está ativada e no meu não...

No meu a opção Go direct está ativada...

Resumindo a opção any procura pela bios primeiro e se ela não der o endereço direito Tchau!!!

No meu procura direto no PCI...

Acho que a explicação em inglês funciona melhor...

# choice
# prompt "PCI access mode"
# depends on PCI
# default PCI_GOANY
#
# config PCI_GOBIOS
# bool "BIOS"
# ---help---
# On PCI systems, the BIOS can be used to detect the PCI devices and
# determine their configuration. However, some old PCI motherboards
# have BIOS bugs and may crash if this is done. Also, some embedded
# PCI-based systems don't have any BIOS at all. Linux can also try to
# detect the PCI hardware directly without using the BIOS.
#
# With this option, you can specify how Linux should detect the PCI
# devices. If you choose "BIOS", the BIOS will be used, if you choose
# "Direct", the BIOS won't be used, and if you choose "Any", the
# kernel will try the direct access method and falls back to the BIOS
# if that doesn't work. If unsure, go with the default, which is
# "Any".
#
# config PCI_GODIRECT
# bool "Direct"
#
# config PCI_GOANY
# bool "Any"

Por isso falei para vc dar uma tentativa nele...

Hqx
« Última modificação: 11 de Janeiro de 2008, 19:58 por Hqxriven »
Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #6 Online: 11 de Janeiro de 2008, 20:04 »
Beleza, acho que o caminho pode ser pra esse lado ! Só me diz o caminho dessas opções.
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #7 Online: 11 de Janeiro de 2008, 20:13 »
Existem dois caminhos

E os dois não são muito bons...

O primeiro é vc fazer um backup dos arquivos importantes e fazer uma recompilação de kernel e alterar a opção...

A segunda é fazer um backup dos arquivos importantes e instalar o meu kernel hqx-edge que já tem essa opção mudada...

Eu não sei se existe a opção de mudar isso só com comandos normais acho que é só kernel...

Hqx
Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #8 Online: 11 de Janeiro de 2008, 20:18 »
O que eu quis dizer é qual o caminho para mim achar essas opções no meu pc tipo: /aqui/algumacoisa/achei
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #9 Online: 11 de Janeiro de 2008, 20:22 »
Entendi...

/boot/config-2.6.22-14-generic

Lá vc vai ver as configurações usadas, mas não pode mudar senão vai dar crash no sistema!!!!


EDIT1

Vou procurar opções menos radicais para vc... qualquer coisa coloco aqui!!

Hqx
« Última modificação: 11 de Janeiro de 2008, 20:30 por Hqxriven »
Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline k7br

  • Usuário Ubuntu
  • *
  • Mensagens: 770
  • Ubuntu 9.04
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #10 Online: 12 de Janeiro de 2008, 01:03 »
Salve!
edjen, vou na dedução (o famoso chute :P)
Veja com o comando lspci a identificação da sua placa de vídeo ,depois acrescente na Section "Device" do xorg.conf ,a seguinte linha :
BusID      "PCI:X:X:X"
Você troca os X pelos números obtidos no lspci ,geralmente isso não resolve heheh ,aí você pode tentar outro chute :
Acrescente na Section "Device" a seguinte linha :
VideoRam       262144

Essa linha está relacionada com essa parte do dpkg-reconfigure xserver-xorg ↓       
                                                                                       
                                   Configurando xserver-xorg
 │ Tipicamente, a quantidade de memória dedicada que sua placa de vídeo       
 │ utiliza é autodetectada pelo servidor X, mas alguns chips de vídeo         
 │ integrados (como o Intel i810) possuem pouca ou nenhuma memória de vídeo   
 │ própria e usam a memória principal do sistema para suas necessidades.       
 │                                                                             
 │ Este parâmetro deveria normalmente ser deixado em branco e ser           
 │ especificado somente caso a placa de vídeo não possua RAM ou caso o         
 │ servidor X tenha problemas autodetectando a quantidade de RAM.             
 │                                                                             
 │ Quantidade de memória (em kB) a ser usada pela placa de vídeo: 

Sendo que:
131072 = 128 MB
262144 = 256 MB  e por ái vai..

Espero que não se machuque com os chutes  ::)

Só me resta desejar ...
Boa sorte!

Off:
Lá vai eu iniciante tentando ajudar...
hahahaha.. essa piada foi boa, Hqxriven ;D

Abraços

       



Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #11 Online: 12 de Janeiro de 2008, 07:08 »
Oi k7br !

Essas dicas são boas. Eu já tinha tentado limitar a quantidade de memoria da placa de video e não deu resultado pra mim, mas pode servir pra outra pessoa. A BusID já está correta no xorg. A placa é bem identificada pelo Ubuntu. Mas vou tentar, já que no xorg está 2:0:0 e no lspci está 02:00.0. Como eu disse, talvez a solução seja simples. Vou tentar depois agora tô com a net ocupada.

                                                     Obrigado !
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline prct

  • Usuário Ubuntu
  • *
  • Mensagens: 84
  • Ubuntu 8.04 LTS
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #12 Online: 12 de Janeiro de 2008, 09:11 »
Antes de mais, boas a todos.

Gostaria de perguntar se já fizeste uma actualização da bios do pc?

http://support.asus.com/download/download.aspx?SLanguage=pt-pt

Se não, força actualiza e depois instala tudo de novo e sem instalação dos drivers. Deixa os originalmente instalados pelo gutsy. Se utilizares o ultimate não avances com a instalação dos drivers da placa gráfica.
Asus T3 Intel 2Duo Core Quad 2.4, 2Gb Ram, 2x 160Gb HDD SataII, Asus EAH2600PRO 512Mb Ram

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #13 Online: 12 de Janeiro de 2008, 22:45 »
Oi prct ! Tudo beleza !

Fiz sim, meu amigo atualizei, fiz downgrade e voltei pra ultima atualização.

Hoje achei este tópico, mas não tive tempo de experimentar:


http://www.sistemafenix.com.br/forum/viewtopic.php?t=104&view=next&sid=bbe2e5412ce9af0ece8b7138d6f6d629

                           
Tem algumas opções que eu nunca tinha visto.

                                                     Obrigado pela atenção !
                                                                         
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline k7br

  • Usuário Ubuntu
  • *
  • Mensagens: 770
  • Ubuntu 9.04
    • Ver perfil
Re: Nvidia - mato ou morro
« Resposta #14 Online: 12 de Janeiro de 2008, 23:42 »
Oi, edjen
Realmente o seu BusID está certo mesmo..sendo assim eu acho que não irá resultar em nada :'( ,mas esse tópico que você passou ,quem sabe ? Talvez dê certo ,não custa nada (dpkg-reconfigure xserver-xorg) tentar .

Por enquanto ficarei devendo ,mas se eu achar alguma coisa, posto aqui  ;)

Abraços e boa sorte!