Autor Tópico: Ubuntu 9.10 detecta rede wireless mas não navega.  (Lida 21827 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #15 Online: 28 de Fevereiro de 2010, 13:45 »
Olha, eu tenho pra mim que teu problema não é no driver da placa de rede, e sim no NetworkManager (ou no wpa_supplicant).

Faz um teste pra gente, descarrega o módulo ndiswrapper ("sudo modprobe -r ndiswrapper") e carrega o driver nativo no lugar ("sudo modprobe ath_5k"), vê se a interface wlan0 reaparece (talvez apareça como "ath0").
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #16 Online: 01 de MAR?O de 2010, 23:35 »
Citar
Faz um teste pra gente, descarrega o módulo ndiswrapper ("sudo modprobe -r ndiswrapper") e carrega o driver nativo no lugar ("sudo modprobe ath_5k"), vê se a interface wlan0 reaparece (talvez apareça como "ath0").
Outra idéia? :'(

marcio@marcio-desktop:~$ sudo modprobe -r ndiswrapper
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
marcio@marcio-desktop:~$ sudo modprobe ath_5k
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
FATAL: Module ath_5k not found.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #17 Online: 01 de MAR?O de 2010, 23:48 »
Falha minha: o nome é "ath5k", não "ath_5k".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #18 Online: 03 de MAR?O de 2010, 13:25 »
Citar
Falha minha: o nome é "ath5k", não "ath_5k".
Eu vi em outro tópico que vc respondeu e já havia tentado com "ath5k", mas também não funcionou.

:~$sudo modprobe ath5k
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper , it will be ignored in a future release.
E continuou sem detectar a rede.


« Última modificação: 03 de MAR?O de 2010, 13:31 por Winthorp »

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #19 Online: 03 de MAR?O de 2010, 15:54 »
Experimente como alternativa instalar outro network-manager  :
Código: [Selecionar]
sudo apt-get install wicd
Pra minha wireless funcionar no Kubuntu tive que instalar.
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #20 Online: 04 de MAR?O de 2010, 09:47 »
Citar
Experimente como alternativa instalar outro network-manager  :
Código:

sudo apt-get install wicd

Pra minha wireless funcionar no Kubuntu tive que instalar.
Blz, vou tentar e depois falo se funcionou ou não.

Uma coisa estranha está acontecendo, quando dou shutdown, o sistema desliga, fica a tela escura, mas ainda com luminosidade com a máquina ligada. Antes eu tinha o ubuntu 7.04 e desligava normalmente. Será que  pode ter sido algum erro na instalação ou no download e gravação do livecd? Já ouviu algum relato sobre isso?

Offline Hanadriel

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #21 Online: 05 de MAR?O de 2010, 16:07 »
Galera para nao ficar sobrecarregado o forum vou utilizar o mesmo aqui....

Primeiramente sempre usei Windows desde 98 ao win7,mas me interessei pelo ubuntu.Entao tenho desde 9.04 tive dificuldades em acessar a net com conexao movel..Bendito 3G.Agora Adquiri o ubuntu 9.10 e gostei muito,porem queria estudar ele antes de instalar.Começei a usar pelo Live CD.Consegui com muita diculdade conectar atraves do wi-fi...
Agora vem o problema:

Eu conectava certinho atraves do live cd,porem agora nao consigo mais.Eu divido a net com o meu irmao.entao tenho que modificar o MAc para entrar.Eu fazia Assim:

sudo iwlist wlan0 scan

sudo iwconfig wlan0 channel <canal>
sudo iwocnfig wlan0 essid <nome_da_rede_wifi>

Depois

sudo iwconfig

Se vc estiver conectado ao ap, então vai aparecer algo como.

Access Point: 00:02:72:68:3E:5A

Ai sim, pode configurar a rede.

sudo ifconfig wlan0(minha placa sem fio) down
sudo ifconfig wlan0 hw ether 00:01:02:04:05
sudo ifconfig wlan0 <ip> netmask <mascara> up
route add default gw <ip_gateway>


so lembrando que nao tenho AP(Acess Point)

so que nao por entender muito do sistema Linux.Eu puz para reiniciar o pc e tirei o cd sem esperar a finalizaçao.e agora fazendo desta mesma forma nao conecta de forma alguma.

Por favor me ajudem

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #22 Online: 06 de MAR?O de 2010, 00:08 »
Vc quer ajuda? Vai um conselho que vai ser útil pra toda a vida: "Pato novo não mergulha em água funda".

Vc está criando uma dificuldade adicional no teu problema, por ter que alterar o MAC address pra enganar seu provedor.

Já não chega a dificuldade de aprender a usar o Linux, se vc tem cultura windows? Ou de superar as dificuldades de conexão da rede wireless?

Então, compra um roteador wireless ou um AP, coloque ele pra compartilhar sua conexão. As horas da tua vida que vc vai perder brigando com o computador custam dez, cem, mil vezes mais que esse aparelho.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #23 Online: 06 de MAR?O de 2010, 22:33 »
Citar
Experimente como alternativa instalar outro network-manager  :
Código:

sudo apt-get install wicd

Pra minha wireless funcionar no Kubuntu tive que instalar.
pintinho, instalei o wicd. Até detectou a rede, mas continuou na mesma, sempre solicitando a senha, lembrando que a senha está correta.
Agora, nem a rede detecta mais, só consigo acessar a net via cabo.
Cara, to achando legal usar o ubuntu. Já instalei o Java, Tomcat, mysql e tá funcionando. Mas esse problema do wireless está me desanimando.
Também tem o problema que quando dou shutdown, a máquina não desliga completamente, tenho que apertar o power, tem alguma configuração pra máquina desligar sozinha?
Vlw pela atenção dada até agora. To desanimando, mas ainda não desisti. :-\

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #24 Online: 07 de MAR?O de 2010, 09:40 »
Instalei o Kubuntu 10.04 (alfa 3) e a wireless dele está funcionando normal.
Já estou no segundo dia de uso e não tive nenhum problema.
O driver usado é o ath9k, que carrega automaticamente na inicialização.
É provável que o Ubuntu 10.04 também funcione normal (só vou saber quando instalar a versão final).
Se quiser tentar, tem o link para baixar no Tópico Oficial: Ubuntu 10.04 LTS (Lucid Lynx ) - Versão Alfa3 Disponível
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline Sayman

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #25 Online: 27 de Junho de 2010, 14:30 »
Minha Cituação é a mesma dele, e também nao conseguir achar uma solução.

o q será?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #26 Online: 27 de Junho de 2010, 14:38 »
Fala Sayman,

A gente precisa ter mais dados do seu sistema, pra poder te aconselhar sobre como resolver seu problema.

Posta a saída dos comandos abaixo.

sudo lshw -C network

iwconfig wlan0

ifconfig
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Sayman

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #27 Online: 04 de Julho de 2010, 23:32 »
Opa, desculpa a demora, ainda nao resolvir.

segue as linhas.
luiz@ubuntu:~$ sudo lshw -C network
  *-network               
       description: Wireless interface
       physical id: 1
       bus info: firewire@1
       logical name: wlan0
       serial: 00:25:86:e3:ff:fb
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=usb driverversion=2.6.32-21-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bgn
luiz@ubuntu:~$






luiz@ubuntu:~$ iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         

luiz@ubuntu:~$ iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
luiz@ubuntu:~$ ifconfig
eth0      Link encap:Ethernet  Endereço de HW 00:1a:4d:97:3f:49 
          endereço inet6: fe80::21a:4dff:fe97:3f49/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:11724 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:11294 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:12594723 (12.5 MB) TX bytes:1569857 (1.5 MB)
          IRQ:24

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:12 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:12 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:720 (720.0 B) TX bytes:720 (720.0 B)

ppp0      Link encap:Protocolo Ponto-a-Ponto 
          inet end.: 187.78.40.242  P-a-P:200.217.255.225  Masc:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Métrica:1
          pacotes RX:11464 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:11111 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:3
          RX bytes:12322379 (12.3 MB) TX bytes:1265055 (1.2 MB)

wlan0     Link encap:Ethernet  Endereço de HW 00:25:86:e3:ff:fb 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:3 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:339 (339.0 B) TX bytes:0 (0.0 B)



eu configurei o wicd pra whey keyshare.

minha rede é wp2. mais continua dando erro de senha invalida!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #28 Online: 05 de Julho de 2010, 00:58 »
Desculpe, mas eu não estou entendendo para quê vc quer essa conexão wireless.

Tua conexão ADSL não está funcionando??? Dá pra saber, vendo a saída do ifconfig.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

libonati

  • Visitante