Autor Tópico: [RESOLVIDO] Problema com grep  (Lida 1378 vezes)

Offline TiagoFC

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
[RESOLVIDO] Problema com grep
« Online: 25 de MAR?O de 2010, 11:59 »
Bom dia pessoaL, quando executo o comando sensor para verificar a temperatura da CPU, preciso filtrar somente as linhas da CPU q exibem um ALARM, para enviar email para o administrador do Servidor. Para isso eu quero dar um grep nas linhas que começam com "c" e terminam em "ALARM", dessa forma pego somente as informaçoes da cpu com relaçao a sua temperatura, mas nao sei formular esse grep -> sensors | grep ?

Como seria o grep onde a linha deve começar com 'c' e terminar em 'ALARM'?
« Última modificação: 25 de MAR?O de 2010, 12:33 por TiagoFC »

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema com grep
« Resposta #1 Online: 25 de MAR?O de 2010, 12:07 »
comando | grep ^padrão

O comando acima vai filtrar apenas as linhas iniciadas com "padrão"
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema com grep
« Resposta #2 Online: 25 de MAR?O de 2010, 12:15 »
A sim, tem a parte da filtragem do final também né. Acho que seu comando ficaria assim:

Citar
sensors  | grep ^c | grep ALARM$

Acho que é isso.
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline TiagoFC

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Problema com grep
« Resposta #3 Online: 25 de MAR?O de 2010, 12:32 »
é isso mesmo!! vlw pessoal!