Autor Tópico: Ubuntu 11.04 conecta, mas não acessa alguns sites com internet rádio [Resolvido]  (Lida 43060 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #15 Online: 21 de Maio de 2011, 01:28 »
Jurava que já tinha respondido aqui. :-\

Nós já conseguimos descartar do problema ser dos aplicativos, resta ser da comunicação. Um teste que eu gostaria que você fizesse seria diminuir o tamanho do MTU da conexão. Conecte-se por cabo e execute o comando abaixo:

sudo ifconfig eth0 mtu 1400

Veja se nessa configuração o problema de acesso continua acontecendo.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #16 Online: 25 de Maio de 2011, 19:32 »
Boa noite,
desculpe a demora.
Fiz a configuração, mas o problema persiste.
Veja se executei corretamente:
Código: [Selecionar]
luizjunior@luizjunior-Vostro1310:~$ sudo ifconfig eth0 mtu 1400
[sudo] password for luizjunior:
luizjunior@luizjunior-Vostro1310:~$

Fico no aguardo...
Obrigado.
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #17 Online: 09 de Julho de 2011, 14:01 »
Olá luizjunior,

Tem alguma novidade no seu problema?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #18 Online: 09 de Julho de 2011, 14:04 »
É que não consegui resolvê-lo, falaste que iriamos tentar desabilitar o IPV6 do navegador se não me engano, caso o último procedimento não tivesse sucesso. E o problema persiste, ao acessar algumas páginas fica apenas carregando e não abre nada...
É um caso perdido tu achas?
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #19 Online: 09 de Julho de 2011, 15:03 »
Pra desabilitar o IPv6:

sudo sysctl net.ipv6.conf.all.disable_ipv6=1

Se não resolver, teremos que baixar o nível e começar a acompanhar a transferência dos arquivos diretamente. :-\
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #20 Online: 13 de Julho de 2011, 19:15 »
Zekkerj,
Problema resolvido! ;D  Consigo acessar o site do Youtube perfeitamente. Gostaria de agradecer sua boa vontade em ajudar. Muito Obrigado! E, aproveito para tirar uma dúvida a respeito do Fórum: por exemplo, agora outros problemas que tenho (no que diz respeito a internet mesmo) caso não encontre solução em nenhum lugar, devo criar um novo tópico e dar este por resolvido, estou certo?
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites [Resolvido]
« Resposta #21 Online: 13 de Julho de 2011, 19:26 »
Antes de dar o tópico como resolvido, reinicie a máquina e veja se o problema retorna, e principalmente se a solução continua funcionando. Pq o comando que a gente usou não é permanente, é preciso editar um arquivo pra que a modificação se torne permanente.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites [Resolvido]
« Resposta #22 Online: 13 de Julho de 2011, 22:03 »
Zekkerj,
realmente reiniciando a máquina o problema persiste. Tentei desabilitar novamente o ipv6 como indicou na primeira vez, mas parece que agora não surtiu nenhum efeito. O que faremos? Vamos editar o arquivo que você falou para desabilitar o ipv6 permanentemente já que na primeira vez funcionou?
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites [Resolvido]
« Resposta #23 Online: 13 de Julho de 2011, 23:33 »
O arquivo é o /etc/sysctl.conf, onde você vai adicionar uma linha "net.ipv6.conf.all.disable_ipv6 = 1" ao fim do arquivo. Mas seria bom um pouco mais de testes...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #24 Online: 13 de Julho de 2011, 23:57 »
Tudo bem, então o que eu faço agora?
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #25 Online: 14 de Julho de 2011, 22:44 »
Problema resolvido (agora é verdade  ;D). O Problema foi resolvido desabilitando o ipv6. Depois da suspeita do Zekkerj de que poderia ser o ipv6 o causador do problema de navegação, e do nosso teste bem sucedido, encontrei aqui no fórum( http://ubuntuforum-br.org/index.php?topic=24215.60) este tópico com instruções de como editar o arquivo /etc/sysctl.conf de forma a desabilitar permanentemente o ipv6. Já reiniciei o note várias vezes, desliguei e liguei, e em todas elas a navegação foi estável e, inclusive, mais rápida que antes. Segui o tópico citado apenas na seguinte etapa:
"Então edita o como root com:
Código: [Selecionar]
sudo gedit /etc/sysctl.confAdicione as linhas abaixo:
Código: [Selecionar]
#disable ipv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Depois digite no terminal os comandos abaixo um a um.

Código: [Selecionar]
echo "#disable ipv6" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.all.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.default.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.lo.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
Até agora tudo numa boa, qualquer coisa que acontecer neste aspecto, posto aqui para compartilhar com os colegas. Novamente, obrigado Zekkerj, e obrigado ao fórum.

(E vamo que vamo, porque a peleia tá boa)  8)
« Última modificação: 15 de Julho de 2011, 14:57 por luizjunior »
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #26 Online: 16 de Julho de 2011, 02:34 »
Cara, não sei o que houve, depois de, inclusive, assistir vídeos no youtube, agora além de não acessar o site, quando tento acessá-lo, a navegação tranca para outras páginas e é preciso reiniciar o navegador. o Java está instalado (jre6), e o flash da adobe (pelo site, opção 11.04+) também, porém o flash está instalado com outros dois complementos que não sei o nome agora, mas que são do repositório do ubuntu mesmo, se não me engano mas, como Zekkerj falou, isso não tem a ver com acessar ou não o site. Agora não deu para entender mesmo. Parece ser alguma conflito que dá pelo fato de ter que reiniciar o navegador...  ???
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites (sem entender)
« Resposta #27 Online: 16 de Julho de 2011, 14:12 »
Agora, não sei se é erro no site, creio que não mas, ao tentar acessar o fórum aqui, Abre até a parte dos menus (Home, Regras, Ajuda, etc..) e o restante da página não abre. Pelo windows, o restante demora um pouco, mas abre sem problemas.

Segue testes que fiz para verificação do Java e Flash:
Digitando “flash” no Synaptic, os programas listados, que estão instalados são: adobe-flashplugin; adobe-flash-properties-gtk; e ubuntu-restricted-extras.

Pela central de programas do Ubuntu, consigo verificar que o “Adobe Flash Plugin 10” está instalado, com os seguintes complementos:
“GTK+control panel for Adobe Flash Player plugin version 10”;
“Biblioteca NetScape Portable Runtime”.

O “Plug-in do Adobe Flash” não está instalado, ao tentar instalá-lo, pede para remover o GTK, que acredito que seja um espécie de substituto...?

Ao verificar pelo terminal, sobre o flash:
Código: [Selecionar]
luizjunior@luizjunior-Vostro1310:~$ sudo apt-get install adobe-flashplugin
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
adobe-flashplugin já é a versão mais nova.
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  libnspr4-0d libkprintutils4 libkutils4
Use 'apt-get autoremove' para removê-los.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 5 não atualizados.
luizjunior@luizjunior-Vostro1310:~$

Pois bem, no Firefox, about:plugins, aparece o Shockwave Flash: application/x-shockwave-flash; e application/futuresplash”

Digitando “java”, aparecem instalados: java-common; openjdk-6-jre; icedtea-plugin; sun-java6-plugin; icedtea-next; sun-java6-bin; sun-java6-jre; default-jre; libacces-bridge-java; default-jre-headless; libacces-bridge-java-jni; openjdk-6-jre-headless; libclucene0dbl; ca-certificates-java; tzdata-java; icetea6-plugin; ubuntu-restricted-extras; openjdk-6-jre-lib; libgtksourceview2.0-common; brltty; gdb; libvirtodbc0; libdbus-1-3; virtuoso-opensource-6.1-bin; virtuoso-opensource-6.1-common; dbus; virtuoso-minimal; plasma-scriptengine-javascript; libkjsembed4; libjs-jquery; sun-java6-fonts; libgudev-1.0-0; libjson-perl; libkjsapi4; libjson-glib-1.0-0; libwebkitgtk-1.0-0; libwebkitgtk-1.0-common; docbook-xsl.

Verificando a instalação do java pelo terminal:

Código: [Selecionar]
luizjunior@luizjunior-Vostro1310:~$ sudo apt-get install sun-java6-jre
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
sun-java6-jre já é a versão mais nova.
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  libnspr4-0d libkprintutils4 libkutils4
Use 'apt-get autoremove' para removê-los.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 5 não atualizados.
luizjunior@luizjunior-Vostro1310:~$

Configurando o Java, aparece a seguinte opção selecionada: (por orientação da wiki, escolhi o /usr/lib/jvm/java-6-openjdk/jre/bin/java e o modo automático, preferi este do que o manual)
Código: [Selecionar]
luizjunior@luizjunior-Vostro1310:~$ sudo update-alternatives --config java
Existem 2 escolhas para a alternativa java (disponibiliza /usr/bin/java).

  Selecção   Caminho                                   Prioridade Estado
------------------------------------------------------------
  0            /usr/lib/jvm/java-6-openjdk/jre/bin/java   1061      modo automático
  1            /usr/lib/jvm/java-6-openjdk/jre/bin/java   1061      modo manual
* 2            /usr/lib/jvm/java-6-sun/jre/bin/java       63        modo manual

Pressione enter para manter a escolha actual[*], ou digite o número da selecção: 0
update-alternatives: a usar /usr/lib/jvm/java-6-openjdk/jre/bin/java para disponibilizar /usr/bin/java (java) em modo automático.
luizjunior@luizjunior-Vostro1310:~$  

Instalação do plugin:
Código: [Selecionar]
luizjunior@luizjunior-Vostro1310:~$ sudo apt-get install sun-java6-plugin
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
sun-java6-plugin já é a versão mais nova.
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  libnspr4-0d libkprintutils4 libkutils4
Use 'apt-get autoremove' para removê-los.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 5 não atualizados.
luizjunior@luizjunior-Vostro1310:~$

Aqui aparece o Erro: Configurando o Ubuntu:
Código: [Selecionar]
luizjunior@luizjunior-Vostro1310:~$ sudo update-alternatives --config javap
update-alternatives: erro: nenhuma alternativa para javap.
luizjunior@luizjunior-Vostro1310:~$

Não sei se tem a ver o problema de configuração do java no ubuntu... E parece que o Firefox não está usando o Adobe Flash, e sim esse Shockwave (acredito que são complementos distintos.. são?) E, Zekkerj, você falou de outras alternativas que podiam ser tomadas... aguardo orientação, acho que fui até onde o meu desconhecimento permitiu.  :-[
« Última modificação: 16 de Julho de 2011, 14:27 por luizjunior »
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites (sem entender)
« Resposta #28 Online: 16 de Julho de 2011, 21:03 »
Zekkerj, ainda, estou suspeitando de outra coisa. Será que o arquivo /etc/sysctl.conf que editei (afoitamente) para desabilitar o ipv6:
Código: [Selecionar]
#disable ipv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Isto não pode ter voltado para como estava antes, automaticamente?

E vi que você indicou, em outro tópico, apenas adicionar 1 linha no final do arquivo com:
Código: [Selecionar]
net.ipv6.conf.all.disable_ipv6 = 1
A forma que fiz está errada? Ou as duas formas funcionam?
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites (sem entender)
« Resposta #29 Online: 17 de Julho de 2011, 00:33 »
Errado, não está, mas acho que acaba desnecessário (ou talvez ineficiente). Pelo menos eu nunca fiz a edição dessa forma.

Diga uma coisa, o problema é só no site do Youtube, mesmo? Já tentou em outro site?

E sua máquina, é um notebook ou um desktop? Sendo um notebook, já tentou levar sua máquina pra outra conexão pra ver como ela se comporta?

Sobre o plugin do Flash, ele é instalado (smj) pelo pacote "flashplugin-installer" do repositório multiverse.

sudo apt-get install flashplugin-installer

Ah, antes que esqueça... seu sistema indica que 5 pacotes precisam de atualização. Já viu quais são?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D