Autor Tópico: Não consigo atualizar Ubuntu 12.04 e Central de Programas não funciona [Resolvi]  (Lida 30843 vezes)

Offline HenriqueZT

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
    • Minha página pessoal
Pessoal,

Após a recente instalação do Ubuntu 12.04 eu não consigo atualizar o sistema. Aparece o erro:

Um erro ocorreu, por favor, use o Gerenciador de Pacotes a partir do menu com clique direito ou apt-get em um terminal para ver o que está errado. A mensagem do erro foi: ' Erro: Abrindo o cache (E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages, E:The package lists or status file could not be parsed or opened.)'.Isso geralmente significa que os pacotes instalados possuem dependências não resolvidas.

O problema é que não consigo atualizar os pacotes porque a atualização não funciona. A Central de Programas também não funciona. Aparece o erro:

Relatório do problema inválido - Não foi possível determinar o pacote ou o nome do pacote fonte.

O que fazer?
« Última modificação: 13 de Maio de 2012, 20:56 por HenriqueZT »
Uso um Itautec Infoway Note W7635
Genuine Intel® CPU T2060 @ 1.60GHz × 2
Linux Ubuntu da última versão

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Não consigo atualizar Ubuntu 12.04 e Central de Programas não funciona
« Resposta #1 Online: 13 de Maio de 2012, 13:49 »
abre o terminal (Ctrl+Alt+T) e digita:

sudo apt-get install -f
sudo apt-get update


Veja se funciona o central de programas caso não tente acrescentado mais esse comando aos outros:

sudo apt-get upgrade

esse ultimo é necessário a internet está ativa, pois vai baixar todas as atualizações disponíveis no momento e instalar.

Anote e cole aqui qualquer mensagem de erro dos comandos sugeridos ok.
« Última modificação: 13 de Maio de 2012, 13:51 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline Rerison LPI000247880

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Não consigo atualizar Ubuntu 12.04 e Central de Programas não funciona
« Resposta #2 Online: 13 de Maio de 2012, 14:24 »
Pessoal,

Após a recente instalação do Ubuntu 12.04 eu não consigo atualizar o sistema. Aparece o erro:

Um erro ocorreu, por favor, use o Gerenciador de Pacotes a partir do menu com clique direito ou apt-get em um terminal para ver o que está errado. A mensagem do erro foi: ' Erro: Abrindo o cache (E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages, E:The package lists or status file could not be parsed or opened.)'.Isso geralmente significa que os pacotes instalados possuem dependências não resolvidas.

O problema é que não consigo atualizar os pacotes porque a atualização não funciona. A Central de Programas também não funciona. Aparece o erro:

Relatório do problema inválido - Não foi possível determinar o pacote ou o nome do pacote fonte.

O que fazer?



Certa vez eu tive uma problema semelhante ao seu o que resolveu  foi apagar a pasta lists com todo seu conteúdo.
Entra na pasta /var/lib/apt e executa o com mando baixo, se vc quiser pode fazer uma copia da pasta /lists, mas não acho necessário.

#rm -r lists/
#apt-get update
Rerison Silva
Certified Linux Professional - LPIC-1
Novell Certified Linux Administrator - NCLA

Offline HenriqueZT

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
    • Minha página pessoal
Re: Não consigo atualizar Ubuntu 12.04 e Central de Programas não funciona
« Resposta #3 Online: 13 de Maio de 2012, 20:55 »
Seguindo as instruções de vocês, eu comecei pelo comando "install -f"

$ sudo apt-get install -f
Lendo listas de pacotes... Erro!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages
E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.


Não ajudou. Aí eu tentei o comando seguinte:

$ sudo apt-get update
Baixados 12,7 MB em 13min 47s (15,4 kB/s)
Lendo listas de pacotes... Erro!
W: Ocorreu um erro durante a verificação da assinatura. O repositório não está actualizado e serão utilizados os ficheiros anteriores de índice. Erro do GPG: http://extras.ubuntu.com precise Release: As seguintes assinaturas eram inválidas: BADSIG 16126D3A3E5C1192 Ubuntu Extras Archive Automatic Signing Key <ftpmaster@ubuntu.com>

W: Erro GPG: http://ppa.launchpad.net precise Release: As seguintes assinaturas eram inválidas: BADSIG 5AF549300FEB6DD9 Launchpad PPA for Florian Diesch
W: Falhou ao buscar http://extras.ubuntu.com/ubuntu/dists/precise/Release  

W: Alguns arquivos index falharam ao ser baixados. Eles foram ignorados, ou cópias antigas são usadas ao invés.
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages
E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.


Também não ajudou. Tentei este comando:

$ sudo apt-get upgrade
Lendo listas de pacotes... Erro!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages
E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.


Resolvi tentar a solução sugerida pelo Rerison. Excluí a pasta /Lists e lancei o comando "update".

# cd /var/lib/apt
/var/lib/apt# rm -r lists/
/var/lib/apt# apt-get update


Dessa vez deu tudo certo.
Mas ao tentar rodar o Gerenciador de Atualizações, ele deu pau e mostrou o seguinte erro:

O sistema de pacotes está quebrado
Verifique se você está utilizando repositórios de terceiros. Se estiver, desabilite-os, já que normalmente são fonte de problemas.
Além disso, execute o seguinte comando em um Terminal: apt-get install -f
Os seguintes pacotes têm dependências não satisfeitas:
skype: Depends: libc6 (>= 2.7-1) mas a 2.15-0ubuntu10 está instalada
       Depends: libgcc1 (>= 1:4.3) mas a 1:4.6.3-1ubuntu5 está instalada
       Depends: libqt4-dbus (>= 4.4.3) mas a 4:4.8.1-0ubuntu4.1 está instalada
       Depends: libqt4-network (>= 4.4.3) mas a 4:4.8.1-0ubuntu4.1 está instalada
       Depends: libqtcore4 (>= 4.4.3) mas a 4:4.8.1-0ubuntu4.1 está instalada
       Depends: libqtgui4 (>= 4.4.3) mas a 4:4.8.1-0ubuntu4.1 está instalada
       Depends: libstdc++6 (>= 4.3) mas a 4.6.3-1ubuntu5 está instalada
       Depends: libxss1 mas não está instalado


Eu me lembrei que, há alguns dias eu tentei instalar o skype, sem sucesso. Resolvi tentar o "apt-get install -f"

# apt-get install -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os pacotes extra a seguir serão instalados:
  libxss1
Os NOVOS pacotes a seguir serão instalados:
  libxss1
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 64 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso baixar 8.604 B de arquivos.
Depois desta operação, 73,7 kB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? s
Obter:1 http://br.archive.ubuntu.com/ubuntu/ precise/main libxss1 i386 1:1.2.1-2 [8.604 B]
Baixados 8.604 B em 1s (5.185 B/s)
Selecionando pacote libxss1 previamente não selecionado.
(Lendo banco de dados ... 171231 ficheiros e directórios actualmente instalados.)
Desempacotando libxss1 (de .../libxss1_1%3a1.2.1-2_i386.deb) ...
Configurando libxss1 (1:1.2.1-2) ...
Configurando skype (2.2.0.35-1) ...
Processando gatilhos para libc-bin ...
ldconfig deferred processing now taking place


Só depois disso é que o Gerenciador de Atualizações e a Central de Programas voltaram a funcionar. Muito obrigado, amigos!
Espero que essas instruções ajudem a outros que passem pelo mesmo problema!
« Última modificação: 13 de Maio de 2012, 20:58 por HenriqueZT »
Uso um Itautec Infoway Note W7635
Genuine Intel® CPU T2060 @ 1.60GHz × 2
Linux Ubuntu da última versão

Offline marcusdraw

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Olá pessoal, estou com o mesmo problema e seguir os passos

# cd /var/lib/apt
/var/lib/apt# rm -r lists/
/var/lib/apt# apt-get update
/var/lib/apt# apt-get install -f

e o problema persiste.

root@ubuntu:~# apt-get update
0% [Connecting to br.archive.ubuntu.com (200.236.31.4)] [Connecting to security.ubuntu.com (91.189.92.166)]
Ign http://br.archive.ubuntu.com precise InRelease
Ign http://br.archive.ubuntu.com precise-updates InRelease
Err http://br.archive.ubuntu.com precise/multiverse i386 Packages
.
.
.
26% [Connecting to security.ubuntu.com (91.189.92.167)]   


E fica travado nos 26% por horas.

alguém pode ajudar?

Creto

  • Visitante
Olá rode esse comando:

Código: [Selecionar]
sudo rm /var/lib/apt/lists* ; sudo rm /var/lib/apt/lists/partial* ; sudo apt-get -f install ; sudo apt-get clean ; sudo apt-get update
Espere terminar se não aparecerem mais os erros:

Código: [Selecionar]
sudo apt-get upgrade
Se os erros persistirem:

sudo gedit /etc/apt/sources.list

e mostre ao forum o conteudo da janela que se abrir

T+

Offline Sulphar

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
    • Bem-Estar
Re: Não consigo atualizar Ubuntu 12.04 e Central de Programas não funciona
« Resposta #6 Online: 24 de Maio de 2012, 12:25 »
abre o terminal (Ctrl+Alt+T) e digita:

sudo apt-get install -f
sudo apt-get update


Veja se funciona o central de programas caso não tente acrescentado mais esse comando aos outros:

sudo apt-get upgrade

esse ultimo é necessário a internet está ativa, pois vai baixar todas as atualizações disponíveis no momento e instalar.

Anote e cole aqui qualquer mensagem de erro dos comandos sugeridos ok.

W: Falhou ao buscar cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release i386 (20120423)/dists/precise/restricted/binary-i386/Packages  Por favor, use o apt-cdrom para fazer com que este CD-ROM seja reconhecido pelo APT. O apt-get update não pode ser usado para adicionar novos CD-ROMs

W: Falhou ao buscar http://ppa.launchpad.net/crebs/ppa/ubuntu/dists/precise/main/source/Sources  404  Not Found

W: Falhou ao buscar http://ppa.launchpad.net/crebs/ppa/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found

E: Alguns arquivos index falharam ao ser baixados. Eles foram ignorados, ou cópias antigas são usadas ao invés.

Creto

  • Visitante
Viu a minha mensagem acima ???

T+

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Não consigo atualizar Ubuntu 12.04 e Central de Programas não funciona
« Resposta #8 Online: 24 de Maio de 2012, 12:59 »
W: Falhou ao buscar cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release i386 (20120423)/dists/precise/restricted/binary-i386/Packages  Por favor, use o apt-cdrom para fazer com que este CD-ROM seja reconhecido pelo APT. O apt-get update não pode ser usado para adicionar novos CD-ROMs

W: Falhou ao buscar http://ppa.launchpad.net/crebs/ppa/ubuntu/dists/precise/main/source/Sources  404  Not Found

W: Falhou ao buscar http://ppa.launchpad.net/crebs/ppa/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found

Ola

Abra => Canais de software

1) desmarque o cd rom
2) localize e desmarque ppa.launchpad.net crebs

Feche após as alterações

Entre em terminal e digite
Código: [Selecionar]
sudo apt-get update para corrigir o problema.

[]'s

Offline rodrigoalmeida

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
TEm com baixar atualizações para ubuntu 12.04 para intalações offline?
« Resposta #9 Online: 25 de Maio de 2012, 19:44 »
Olá, eu gostaria de baixar os arquivos de atualizaçoão, drives, e alguns programas para instalar o ubuntu 12.04 LTS 64 bits offline, instalo ele para amigos e a instalação é muito demorada por causa dos downloads, tem como baixar estes arquivos e instalar manualmente depois?

Offline santahell

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Estou com um problema parecido tentei alguns recursos e mesmo assim continuam os problemas:
quando aciono o comano via terminal "sudo apt-get update" a mensagem final é esta: Baixados 2.854 B em 22s (124 B/s)
W: Falhou ao buscar http://ppa.launchpad.net/am-monkeyd/nautilus-elementary-ppa/ubuntu/dists/precise/main/source/Sources  404  Not Found

W: Falhou ao buscar http://ppa.launchpad.net/am-monkeyd/nautilus-elementary-ppa/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found

W: Falhou ao buscar http://ppa.launchpad.net/murrine-daily/ppa/ubuntu/dists/precise/main/source/Sources  404  Not Found

W: Falhou ao buscar http://ppa.launchpad.net/murrine-daily/ppa/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found

E: Alguns arquivos index falharam ao ser baixados. Eles foram ignorados, ou cópias antigas são usadas ao invés.

quando executo o upgrade, a mensagem é esta:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
W: Duplicate sources.list entry http://ppa.launchpad.net/shnatsel/zram/ubuntu/ precise/main i386 Packages (/var/lib/apt/lists/ppa.launchpad.net_shnatsel_zram_ubuntu_dists_precise_main_binary-i386_Packages)

o que fazer?

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Ola

o que fazer?

Procurar pelo erro 404 aqui no forum

Existe uma infinidade de topicos ensinando a resolver.

O mesmo se aplica a duplicidade de repositorios em seus sources

[]'s

Offline splintersap

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Desculpe ainda responder....mas comigo nenhum dos casos acima resolveu..

Para mim o que resolveu foi:

 abrir pelo terminal :  software-properties-gtk

Selecionar Baixar de: http://mirrors.mit.edu/ubuntu

 rm -r /var/lib/apt/lists/

apt-get clean

apt-get update

apt-get upgrade

fez todas as atualizações e esta tudo certo agora.

espero ajudar alguem...

abraços


Offline lisboasl

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Desculpe ainda responder....mas comigo nenhum dos casos acima resolveu..

Para mim o que resolveu foi:

 abrir pelo terminal :  software-properties-gtk

Selecionar Baixar de: http://mirrors.mit.edu/ubuntu

 rm -r /var/lib/apt/lists/

apt-get clean

apt-get update

apt-get upgrade

fez todas as atualizações e esta tudo certo agora.

espero ajudar alguem...

abraços

-------------------------------------------------------------
Bom dia, splintersap

Quero mais agradecer por seu tutorial do que qualquer outra coisa. Tentei todos os outros acima (e agradeço também) mas não havia obtido resultado até tentar fazer o que você postou. Foi o único que não deu erro e que me permitiu acesso à Central de Programas do Ubuntu.

Muito obrigado.

Offline Cassio Jose

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Com certeza a resposta é >gerenciador de atualizações>configurações>outros software: desmarque todas e assinale de duas em duas e você descobrirá quais opções está impedindo as atualizações serve também para PPA duplicados . O que você faz: deixe as caixas de diálogos desmarcadas e depois você as remarcas e faz as atualizações parciais que ficaram faltandos. Isso não sei se resolve o problema como um todos mas as mensagens de erro no terminal vão terminar .Lembre-se só os http://.