Autor Tópico: Problemas com o Ubuntu  (Lida 8472 vezes)

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Problemas com o Ubuntu
« Online: 10 de Maio de 2013, 23:57 »
Toda vez que eu vou usar o APT aparecem estes erros:

sudo apt-get upgrade
[sudo] password for aparecida:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Você pode querer executar 'apt-get -f install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
 libc6 : Depende: libc-bin (= 2.15-0ubuntu10.3) mas 2.15-0ubuntu10.4 está instalado
 libc6-dev : Depende: libc6 (= 2.15-0ubuntu10.4) mas 2.15-0ubuntu10.3 está instalado
E: Dependências desencontradas. Tente usar -f.

sudo apt-get -f install
(Lendo banco de dados ... 255747 ficheiros e directórios actualmente instalados.)
Preparando para substituir libc6 2.15-0ubuntu10.3 (usando .../libc6_2.15-0ubuntu10.4_i386.deb) ...

A copy of the C library was found in an unexpected directory:
  '/lib/i386-linux-gnu/libc-2.15.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/i386-linux-gnu' and try again.

dpkg: erro processando /var/cache/apt/archives/libc6_2.15-0ubuntu10.4_i386.deb (--unpack):
 sub-processo novo script pre-installation retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/libc6_2.15-0ubuntu10.4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

E quando eu tentei atualizar o libc6 pelo Synaptic aparece isso:

(Lendo banco de dados ... 255747 ficheiros e directórios actualmente instalados.)
Preparando para substituir libc6 2.15-0ubuntu10.3 (usando .../libc6_2.15-0ubuntu10.4_i386.deb) ...

A copy of the C library was found in an unexpected directory:
  '/lib/i386-linux-gnu/libc-2.15.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/i386-linux-gnu' and try again.

dpkg: erro processando /var/cache/apt/archives/libc6_2.15-0ubuntu10.4_i386.deb (--unpack):
 sub-processo novo script pre-installation retornou estado de saída de erro 1
Nenhum relatório apport escrito pois MaxReports já foi atingido
                                                               Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/libc6_2.15-0ubuntu10.4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Um pacote falhou na instalação. Tentando recuperar:
dpkg: problemas de dependência impedem a configuração de libc6-dev:
 libc6-dev depende de libc6 (= 2.15-0ubuntu10.4); porém:
  Versão de libc6 no sistema é 2.15-0ubuntu10.3.
dpkg: erro processando libc6-dev (--configure):
 problemas de dependência - deixando desconfigurado
Configurando rsyslog (5.8.6-1ubuntu8.1) ...
dpkg: erro processando rsyslog (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 10
Erros foram encontrados durante o processamento de:
 libc6-dev
 rsyslog


Offline Jone Metal

  • Usuário Ubuntu
  • *
  • Mensagens: 163
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #1 Online: 11 de Maio de 2013, 02:57 »
Tenta este comando pelo terminal
Código: [Selecionar]
sudo apt-get install -f
sudo dpkg --configure -a
« Última modificação: 11 de Maio de 2013, 03:03 por Jone Metal »

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #2 Online: 11 de Maio de 2013, 17:54 »
No meu post está la a saída do 1º comando.
Já o segundo deu isso:

sudo dpkg --configure -a
[sudo] password for aparecida:
dpkg: problemas de dependência impedem a configuração de libc6-dev:
 libc6-dev depende de libc6 (= 2.15-0ubuntu10.4); porém:
  Versão de libc6 no sistema é 2.15-0ubuntu10.3.
dpkg: erro processando libc6-dev (--configure):
 problemas de dependência - deixando desconfigurado
Configurando rsyslog (5.8.6-1ubuntu8.1) ...
dpkg: erro processando rsyslog (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 10
Erros foram encontrados durante o processamento de:
 libc6-dev
 rsyslog

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #3 Online: 11 de Maio de 2013, 21:33 »
Tenta removendo os pacotes quebrados e reinstale novamente depois:

Código: [Selecionar]
sudo apt-get -f remove
sudo apt-get update && sudo apt-get upgrade

De preferência, tenta utilizando a aptitude. Para instalar faça:

Código: [Selecionar]
sudo apt-get install aptitude
Depois o mesmo comando apenas mudando o apt-get pelo aptitude

Código: [Selecionar]
sudo aptitude update && sudo aptitude upgrade
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline Jone Metal

  • Usuário Ubuntu
  • *
  • Mensagens: 163
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #4 Online: 11 de Maio de 2013, 21:38 »
Tenta este caso o do amigo jkmsjq não dê certo
Código: [Selecionar]
dpkg -i --force-all /var/cache/apt/archives/libxv1*.debe depois
Código: [Selecionar]
depois apt-get -f install
« Última modificação: 11 de Maio de 2013, 21:40 por Jone Metal »

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #5 Online: 11 de Maio de 2013, 22:00 »
Meu sistema ficou louco!
Depois de uma atualização que deu este error.
Agora fui dar o comando do jkmsjq

Apareceu que a maioria dos pacotes do sistema está quebrado!
Nem deu para copiar tudo, vou botar só final do comando sudo apt-get -f remove:

0 pacotes atualizados, 0 pacotes novos instalados, 2619 a serem removidos e 0 não atualizados.
2 pacotes não totalmente instalados ou removidos.
Depois desta operação, 5.880 MB de espaço em disco serão liberados.
Você está prestes a fazer algo potencialmente destrutivo.
Para continuar digite a frase 'Sim, faça o que eu digo!'

Também tentei do Jone Metal:

sudo dpkg -i --force-all /var/cache/apt/archives/lideb1*.d
dpkg: erro processando /var/cache/apt/archives/libxv1*.deb (--install):
 impossível acessar arquivo: Arquivo ou diretório não encontrado
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/libxv1*.deb


Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #6 Online: 11 de Maio de 2013, 22:05 »
No terminal digite:

Código: [Selecionar]
sudo nautilus /var/cache/apt/archives/
Delete os arquivos que estiverem na pasta.

Depois no mesmo terminal digite:

Código: [Selecionar]
sudo apt-get update && sudo apt-get upgrade
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #7 Online: 11 de Maio de 2013, 22:17 »
Deu isso:

sudo apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Você pode querer executar 'apt-get -f install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
 libc6 : Depende: libc-bin (= 2.15-0ubuntu10.3) mas 2.15-0ubuntu10.4 está instalado
 libc6-dev : Depende: libc6 (= 2.15-0ubuntu10.4) mas 2.15-0ubuntu10.3 está instalado
E: Dependências desencontradas. Tente usar -f.
aparecida@Aparecida:~$

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #8 Online: 12 de Maio de 2013, 15:47 »
Faz como o recomendado pelo terminal:

Código: [Selecionar]
sudo apt-get upgrade -f
Detalhe:

Já tentou instalar esses pacotes via Synaptic... ???
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #9 Online: 12 de Maio de 2013, 17:33 »
Mesma coisa.

Preparando para substituir libc6 2.15-0ubuntu10.3 (usando .../libc6_2.15-0ubuntu10.4_i386.deb) ...

A copy of the C library was found in an unexpected directory:
  '/lib/i386-linux-gnu/libc-2.15.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/i386-linux-gnu' and try again.

dpkg: erro processando /var/cache/apt/archives/libc6_2.15-0ubuntu10.4_i386.deb (--unpack):
 sub-processo novo script pre-installation retornou estado de saída de erro 1
Nenhum relatório apport escrito pois MaxReports já foi atingido
                                                               Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/libc6_2.15-0ubuntu10.4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com o Ubuntu
« Resposta #10 Online: 13 de Maio de 2013, 13:30 »
Olá Ryderr,

Execute os comandos abaixo e cole o resultado aqui.

dpkg-query --search /lib/i386-linux-gnu/libc-2.15.so

OBS: Não tente forçar a instalação ou remoção de nada em sua máquina até a gente entender direito o que está acontecendo com ela.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #11 Online: 14 de Maio de 2013, 11:46 »
Desculpem a demora.

O comando acima deu isso:

dpkg-query: nenhum caminho achado correspondendo ao padrão  /lib/i386-linux-gnu/libc-2.15.so.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com o Ubuntu
« Resposta #12 Online: 14 de Maio de 2013, 12:05 »
Mais alguns comandos...

uname -a

sudo apt-get --dry-run remove libc-dev

OBS: O último comando é para fazer uma simulação da remoção de uma das bibliotecas que está em conflito. É imporante, neste momento, que seja feita apenas a simulação. O objetivo é apenas saber se essa remoção quebraria mais alguma coisa, sem necessariamente fazer a remoção.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline asslinux

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #13 Online: 14 de Maio de 2013, 15:55 »
Fiz um RAID10 por software funcionou durante um ano +- só que agora esta dando RAID  Degraded
já tentei modo de restauração mais não consigo voltar a raid.

queria agora pelome nos recuperar os dados.


conto com a colaboração de todos.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com o Ubuntu
« Resposta #14 Online: 14 de Maio de 2013, 16:06 »
sugiro que você abra um tópico pra seu problema. Assim você terá mais repostas, e não atrapalha a solução do problema dos outros.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D