Autor Tópico: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04  (Lida 45681 vezes)

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #30 Online: 01 de Julho de 2007, 11:05 »
Oi Gabriel.goc,

Não, não desisti. Somente nosso amigo Alarcon que não soube mais o que dizer.
O meu caso está assim:
navego por algumas páginas como Google, Bol, Ig, Turma da Monica, e só; mas as páginas de real interesse como Ubuntu, plugins do Mozilla, repositórios do Ubuntu  (via apt-get, synaptic), etc simplesmente não abrem, o navegar ou o programa de atualização informa que não há conecção com internet.
A minha última tentativa foi re-instalar o ubuntu com a rede desabilitada no setup da placa. Mas deu na mesma, nada mudou, e os arquivos chap-secrets e pap-secrets estão em branco.
Consegui atualizar o sistema via APTonCD e até agora foi só.
Ainda não comprei novo modem, porque o rebelde que tenho até que funciona bem, só temos algumas arestas para aparar no Ubuntu.
Desistir do Linux eu não vou de jeito nenhum, acredito que o futuro está no Linux. No máximo vou esperar o próximo lançamento do Ubuntu (7.10) para testar. Mas por hora vou continuar tentando.
Aprender é assim. É errando que se aprende e faz pensar.
Estamos todos aqui para aprender um com o outro.
Espero resposta.
Um abraço.
« Última modificação: 01 de Julho de 2007, 19:55 por jaioliver »

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #31 Online: 01 de Julho de 2007, 21:47 »
Pow, o seu caso tah complicado mesmo..
heheheh

Eu estou efetuando uma pesquisa no fórum oficial, vou ver se acho alguma coisa..
Mas enquanto isso.
Tenta dar esses comandos no terminal:
sudo /etc/init.d/sl-modem-daemon stop

modprobe -r ungrab-winmodem

modprobe -r slamr

sudo mknod -m 600 /dev/slamr0 c 242 0

modprobe ungrab-winmodem

modprobe slamr

sudo slmodemd --country=BRAZIL --perm=0666 /dev/slamr0
Um de cada vez, nessa ordem mesmo...

.....Aí tenta conectar e veja se funcionou...

Flws...aguardo resposta

Ahh...E posta os resultados destes comandos quando estiver conectado:
route -n
route -v

E se você pudesse abrir o computador e ver o modelo do chipset do seu modem, seria interessante também postar aqui.
Mas um informação que pode ser útil...

« Última modificação: 03 de Julho de 2007, 14:03 por gabriel.goc »

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #32 Online: 02 de Julho de 2007, 21:03 »
Olá Gabriel.goc,

Fiz os comando que voce sugeriu e deu este resultado:
home@home-desktop:~$ sudo /init.d/sl-modem-daemon stop
sudo: /init.d/sl-modem-daemon: command not found
home@home-desktop:~$ modprobe -r ungrab-winmodem
FATAL: Module ungrab_winmodem not found.
home@home-desktop:~$  modprobe -r slamr &
[2] 6162
[1]   Exit 1                  modprobe -rslamr
home@home-desktop:~$ FATAL: Module slamr not found.
home@home-desktop:~$ sudo mknod -m 600 /dev/slamr0 c 242 0
home@home-desktop:~$ sudo slmodemd --coutry=BRAZIL--perm=0666 /dev/slamr0
Usage: slmodemd [option...] <device>
Where 'device' is name of modem device (default `/dev/slamr0')
  and 'option' may be:
  -h, --help            this usage
  -u, --usage           this usage
  -v, --version         show version and exit
  -c, --country=VAL     default modem country name (default `USA')
      --countrylist     show list of supported countries
  -a, --alsa            ALSA mode (see README for howto)
  -g, --group=VAL       Modem TTY group (default `uucp')
  -p, --perm=VAL        Modem TTY permission (default `0660')
  -r, --ringdetector    with internal ring detector (software)
  -n, --nortpriority    run with regular priority
  -s, --shortbuffer     use short buffer (4 periods length)
  -d, --debug=VAL       debug level (default `0')
  -l, --log=VAL         logging mode (default `5')
home@home-desktop:~$ route -n
Tabela de Roteamento IP do Kernel
Destino             Roteador        MáscaraGen.     Opções Métrica Ref   Uso Iface
200.199.191.129 0.0.0.0         255.255.255.255   UH         0      0        0 ppp0
169.254.0.0       0.0.0.0         255.255.0.0          U           0      0        0 eth0
0.0.0.0             0.0.0.0         0.0.0.0                 U           0      0        0 ppp0
0.0.0.0             0.0.0.0         0.0.0.0                 U         1000   0        0 eth0
[2]+  Exit 1                  modprobe -r slamr

home@home-desktop:~$ route -v
Tabela de Roteamento IP do Kernel
Destino                Roteador        MáscaraGen.         Opções Métrica Ref   Uso Iface
200.199.191.129       *               255.255.255.255           UH    0      0        0 ppp0
link-local                  *               255.255.0.0                  U     0      0        0 eth0
default                    *               0.0.0.0                         U     0      0        0 ppp0
default                    *               0.0.0.0                         U   1000   0        0 eth0

Voce pede:
E se você pudesse abrir o computador e ver o modelo do chipset do seu modem, seria interessante também postar aqui.
Mas um informação que pode ser útil...

 mas o que devo procurar no circuito do modem? Um chip especifico? Preciso de dados para poder identificar corretamente nosso amigo.
Vou fazer o que voce pediu, mas preciso de mais informações de como identificar o chipset fisicamente.
Eu simplesmente não sei o que procurar, qual circuito integrado devo relatar?

O que descobri, até agora foi que é fax modem cnr v1.2b para placa mãe onboard e no windows (Máquina dual-boot - Windows XP:Ubuntu 7.04) aparece como HSP56MR(VIA) o ID do modem é 1106:3068 Fabricante Conexante. E tem a aparência do enderaço abaixo, já que não consegui inserir aqui a imagem.
http://produto.mercadolivre.com.br/MLB-58540257-modem-cnr-ou-amr-para-placas-mae-omboad-56k-novo-garantia-_JM

PS.: No site do fabricante da placa mãe (http://www.phitronics.com.br/P4V800-M_driver.asp) descobri:
Modem
Nome do Driver PCtel AMR/CNR Modem card driver
Versão 12.0341.0027
Data de Lançamento  2005/02/02


Muito obrigado pelas dicas e vamos em frente.
« Última modificação: 03 de Julho de 2007, 00:11 por jaioliver »

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #33 Online: 03 de Julho de 2007, 14:00 »
Há um erro no que você postou, o comando certo é este:
-->>> sudo slmodemd --country=BRAZIL--perm=0666 /dev/slamr0
e não:
sudo slmodemd --coutry=BRAZIL--perm=0666 /dev/slamr0


É só este procedimento, e tentar conecta... :p
Citar
sudo /etc/init.d/sl-modem-daemon stop

modprobe -r ungrab-winmodem

modprobe -r slamr

sudo mknod -m 600 /dev/slamr0 c 242 0

modprobe ungrab-winmodem

modprobe slamr

sudo slmodemd --country=BRAZIL --perm=0666 /dev/slamr0
« Última modificação: 03 de Julho de 2007, 14:06 por gabriel.goc »

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #34 Online: 03 de Julho de 2007, 14:03 »
Ahhh...Esqueci de perguntar uma coisa, qual é o driver que você usa??

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #35 Online: 06 de Julho de 2007, 23:22 »
Fiz:
Há um erro no que você postou, o comando certo é este:
-->>> sudo slmodemd --country=BRAZIL--perm=0666 /dev/slamr0
e não:
sudo slmodemd --coutry=BRAZIL--perm=0666 /dev/slamr0


É só este procedimento, e tentar conecta... :p
Citar
sudo /etc/init.d/sl-modem-daemon stop

modprobe -r ungrab-winmodem

modprobe -r slamr

sudo mknod -m 600 /dev/slamr0 c 242 0

modprobe ungrab-winmodem

modprobe slamr

sudo slmodemd --country=BRAZIL --perm=0666 /dev/slamr0


E veio a resposta:
error: mdm setup: cannot start `/dev/slamr0: no such file or directory
error: cannot setup device `/dev/slamr0


Ahhh...Esqueci de perguntar uma coisa, qual é o driver que você usa??
Uso o slmodem-2.9.11-20070505
ou seja o pacote de instalação sugerido por Alarcon.
Uma coisa interessante: nos sites que consigo abrir e navegar, como o Ig ou Gmail, consigo velocidadede download da ordem de 5 a 7kbps (com picos de até 17kbps e estável em 5,8kbps), o que descobri é uma ótima velocidade em uma conexão discada.

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #36 Online: 07 de Julho de 2007, 00:07 »
Só a título de informação adicional(talvez ajude), executei o scanModem e a resposta foi:
---------------------- System information ----------------------- CPU=i686,  Ubuntu 7.04 
Linux version 2.6.20-16-generic (root@terranova) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2
SMP Thu Jun 7 20:19:32 UTC 2007 
scanModem update of:  2007_June_16
The modem symbolic link is /dev/modem -> ttySL0
The slmodemd set symbolic link is /dev/ttySL0 -> /dev/pts/0
ALSAversion 1.0.13 USB modem not detected by lsusb
Modem or host audio card candidates have firmware information:
 PCI slot     PCI ID          SubsystemID     Name 
 00:11.6   1106:3068     1543:4c21     Communication controller: VIA Technologies, Inc. AC'97 Modem Controller 
Modem interrupt assignment and sharing:   19:      18322   IO-APIC-fasteoi   VIA3058, VIA8237 
--- Bootup diagnositcs for card in PCI slot 00:11.6 ----
[   48.146154] ACPI: PCI Interrupt 0000:00:11.6[C] -> GSI 22 (level, low) -> IRQ 19
[   48.146180] PCI: Setting latency timer of device 0000:00:11.6 to 64   
=== Finished modem firmware and bootup diagnostics section. ===
 === Next deducing cogent software ===

alarcon

  • Visitante
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #37 Online: 07 de Julho de 2007, 10:36 »
Só a título de informação adicional(talvez ajude), executei o scanModem e a resposta foi:
---------------------- System information ----------------------- CPU=i686,  Ubuntu 7.04 
Linux version 2.6.20-16-generic (root@terranova) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2
SMP Thu Jun 7 20:19:32 UTC 2007 
scanModem update of:  2007_June_16
The modem symbolic link is /dev/modem -> ttySL0
The slmodemd set symbolic link is /dev/ttySL0 -> /dev/pts/0
ALSAversion 1.0.13 USB modem not detected by lsusb
Modem or host audio card candidates have firmware information:
 PCI slot     PCI ID          SubsystemID     Name 
 00:11.6   1106:3068     1543:4c21     Communication controller: VIA Technologies, Inc. AC'97 Modem Controller 
Modem interrupt assignment and sharing:   19:      18322   IO-APIC-fasteoi   VIA3058, VIA8237 
--- Bootup diagnositcs for card in PCI slot 00:11.6 ----
[   48.146154] ACPI: PCI Interrupt 0000:00:11.6[C] -> GSI 22 (level, low) -> IRQ 19
[   48.146180] PCI: Setting latency timer of device 0000:00:11.6 to 64   
=== Finished modem firmware and bootup diagnostics section. ===
 === Next deducing cogent software ===


Muito estranho o que ocorre com você.

Estou confuso com o que você falou aqui:

"...Uma coisa interessante: nos sites que consigo abrir e navegar, como o Ig ou Gmail, consigo velocidadede download da ordem de 5 a 7kbps (com picos de até 17kbps e estável em 5,8kbps), o que descobri é uma ótima velocidade em uma conexão discada..."

Os softmodems posssuem uma velocidade máxima de 56Kb/s que em KByte seria de 7KB/s, pelo menos é o que eu entendo, me corrija se estiver errado ( 1KByte=8Kbits). Então quando você fala em "5 a 7Kbps
" você na verdade esta querendo dizer é 5 a 7 KBps ?

O que é o máximo que uma conexão discada via sofmodems consegue atingir (56Kb/s=7KB/s), então como pode você obter 17Kbps (você se referia à 17KBps) que já éuma  velocidade de banda larga. Se você realmente quer dizer 17Kbps isso equivale a 2.13KB/s o que é um velocidade baixa, mas dentro do que uma conexão via softmodem é capaz de usar.

Por favor me corrija se estiver erro, mas realmente não entendi direito o que você quis dizer.

Com relação a ter acesso a alguns sites e outro não eu te pergunto, qual é o provedor que você usa para acessar a internet e se não é o caso de você obter do mesmo o DSN primário e o secundário, pois tá parecendo problema deste tipo, ou seja, de url.

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #38 Online: 07 de Julho de 2007, 13:35 »
Acredito que ele esteja falando de KB e não de Kb, o fato dele chegar à 17KB/s não é nenhuma anomalia, essas oscilações acontecem, isso não quer dizer que ele esteja baixando à 17KB/s realmente.

Flwss..
Realmente o DNS pode ser a causa, tente mudar de provedor, ou então colocar o DNS de teu provedor...

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #39 Online: 07 de Julho de 2007, 19:22 »
Oi Gabriel.goc,

Já fiz. Solicitei o DNS e eles me forneceram, tanto o primário quanto o secundário, e já coloquei no discador, mas, quando vejo os detalhes da conexão vemos que ele não está usando o DNS informado. Já tentei mudar o provedor e simplesmente não consegui conectar.

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #40 Online: 07 de Julho de 2007, 19:31 »
Caro Alarcon,

Eu só informei que consigo uma velocidade de + ou - 6KB/s estáveis, apesar dos problemas. Os 17KB/s são picos instantâneos que duram só alguns segundos.
Espero ter esclarecido.

O provedor que consegui melhores resultados foi o provedor Itelefônica e consegui os DNS primário e secundário, que coloquei no discador, mas nos detalhes fornecidos pelo gnome-ppp, quando conectado é que o DNS utilizado é totalmente diferente do fornecido.
PS.: No Windows, SO que utilizo neste instante, consigo navegar livremente na Web com o provedor acima citado.

alarcon

  • Visitante
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #41 Online: 07 de Julho de 2007, 19:46 »
Caro Alarcon,

Eu só informei que consigo uma velocidade de + ou - 6KB/s estáveis, apesar dos problemas. Os 17KB/s são picos instantâneos que duram só alguns segundos.
Espero ter esclarecido.

O provedor que consegui melhores resultados foi o provedor Itelefônica e consegui os DNS primário e secundário, que coloquei no discador, mas nos detalhes fornecidos pelo gnome-ppp, quando conectado é que o DNS utilizado é totalmente diferente do fornecido.
PS.: No Windows, SO que utilizo neste instante, consigo navegar livremente na Web com o provedor acima citado.

Ok tudo entendido sobre velocidade.

vamos aos DNS :-)

abra o gnome-ppp vá em Configuração na aba Rede na parte sobre DNS deixe marcado DSN Manual feche e saia do gnome-ppp. Agora via terminal digite: gedit .wvdial.conf e nesta parte:

;Nameserver =
;Nameserver2 =


coloque o DNS primário e secundário do seu provedor respectivamente e teste depois o gnome-ppp para ver o que acontece desta vez.


Me parece que colocar os DNS pela interface gráfica não funciona (talvez um bug), portanto tente pelo arquivo de configuração .wvdial.conf, mas para que apareça a opção você deve fazer como falei logo acima ok.


Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #42 Online: 09 de Julho de 2007, 22:01 »
Alarcon, Gabriel.goc

 :)Tenho a honra e a total satisfação de responder a voces através do Mozilla Firefox do Ubuntu. :)
Meus amigos, muitíssimo obrigado pela ajuda e pela paciência de vocês, desculpe qualquer deslize e até a próxima aventura.   ;)

Fiz o que nosso amigo Alarcon sugeriu e tudo funcionou muito bem.

Só fiz uma coisinha a mais: em Sistema - Administração - Ferramentas de Rede selecionei o modem como dispositivo de conexão (Já tinha feito isto antes, mas fiz novamente);
Ainda em administração agora em Rede selecionei e configurei a conexão pelo modem (também já tinha feito antes, só fiz novamente para ter certeza) de modo idêntico ao discador gnome-ppp e conferi tudo clicando no icone de rede que tem no área de notificação. E ficamos on-line.

Espero ter contribuido com todos os que acessaram este tópico.

Mais uma vez agradeço a Alarcon e Gabriel.goc, vocês forem demais.

Muito, muito obrigado.

E até a próxima, quem sabe.

alarcon

  • Visitante
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #43 Online: 10 de Julho de 2007, 12:29 »
Alarcon, Gabriel.goc

 :)Tenho a honra e a total satisfação de responder a voces através do Mozilla Firefox do Ubuntu. :)
Meus amigos, muitíssimo obrigado pela ajuda e pela paciência de vocês, desculpe qualquer deslize e até a próxima aventura.   ;)

Fiz o que nosso amigo Alarcon sugeriu e tudo funcionou muito bem.

Só fiz uma coisinha a mais: em Sistema - Administração - Ferramentas de Rede selecionei o modem como dispositivo de conexão (Já tinha feito isto antes, mas fiz novamente);
Ainda em administração agora em Rede selecionei e configurei a conexão pelo modem (também já tinha feito antes, só fiz novamente para ter certeza) de modo idêntico ao discador gnome-ppp e conferi tudo clicando no icone de rede que tem no área de notificação. E ficamos on-line.

Espero ter contribuido com todos os que acessaram este tópico.

Mais uma vez agradeço a Alarcon e Gabriel.goc, vocês forem demais.

Muito, muito obrigado.

E até a próxima, quem sabe.

Que bom!

Isso serve de inspiração para aqueles que desistem logo na primeira tentativa.

Vejam que se o seu tipo de modem tem suporte no linux, o que importa mesmo é a perseverança, pois numa hora destas vocês conseguem. O importante é persistir e desistir jamais. ;D 

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #44 Online: 10 de Julho de 2007, 12:38 »
Alarcon, Gabriel.goc

 :)Tenho a honra e a total satisfação de responder a voces através do Mozilla Firefox do Ubuntu. :)
Meus amigos, muitíssimo obrigado pela ajuda e pela paciência de vocês, desculpe qualquer deslize e até a próxima aventura.   ;)

Fiz o que nosso amigo Alarcon sugeriu e tudo funcionou muito bem.

Só fiz uma coisinha a mais: em Sistema - Administração - Ferramentas de Rede selecionei o modem como dispositivo de conexão (Já tinha feito isto antes, mas fiz novamente);
Ainda em administração agora em Rede selecionei e configurei a conexão pelo modem (também já tinha feito antes, só fiz novamente para ter certeza) de modo idêntico ao discador gnome-ppp e conferi tudo clicando no icone de rede que tem no área de notificação. E ficamos on-line.

Espero ter contribuido com todos os que acessaram este tópico.

Mais uma vez agradeço a Alarcon e Gabriel.goc, vocês forem demais.

Muito, muito obrigado.

E até a próxima, quem sabe.

Putz que bom...
Maior sacrifício, e no final foi um errinho de nada, mas como disse alarcon, isso serve de inspiração para outros que desistem de primeiro...
   E se o Alarcon permitir colocarei a dica do DNS no primeiro post, em "solução de problemas".

Flws...
E espero que a sua experiência com o Linux seja a melhor possível...